Bug 874562 - Anaconda doesn't tell what is wrong on partitioning
Anaconda doesn't tell what is wrong on partitioning
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F18Blocker/F18FinalBlocker
  Show dependency treegraph
 
Reported: 2012-11-08 08:06 EST by Pavel Holica
Modified: 2013-03-12 10:27 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-08 11:15:10 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Error checking storage configuration screenshot (65.41 KB, image/png)
2012-11-08 08:06 EST, Pavel Holica
no flags Details
anaconda.log (13.90 KB, text/plain)
2012-11-08 08:22 EST, Pavel Holica
no flags Details
program.log (31.85 KB, text/plain)
2012-11-08 08:23 EST, Pavel Holica
no flags Details
storage.log (105.62 KB, text/plain)
2012-11-08 08:23 EST, Pavel Holica
no flags Details

  None (edit)
Description Pavel Holica 2012-11-08 08:06:25 EST
Created attachment 640794 [details]
Error checking storage configuration screenshot

Description of problem:
When incorrect partitioning is specified, anaconda allows to click on "Finish partitioning" and doesn't complain about anything. Then, in hub, there is only information "Error checking storage configuration" which doesn't tell what is wrong and can be confusing.

Version-Release number of selected component (if applicable):
anaconda-18.24-1.fc18

How reproducible:
always

Steps to Reproduce:
1. Get to partitioning and do manual configuration
2. Set / to be "vfat" for example
3. click on "Finish partitioning"
  
Actual results:
see attachment

Expected results:
Anaconda should tell (like on Fedora 17 did) what is wrong with the partitioning layout.

Additional info:
Comment 1 Pavel Holica 2012-11-08 08:22:51 EST
Created attachment 640806 [details]
anaconda.log
Comment 2 Pavel Holica 2012-11-08 08:23:14 EST
Created attachment 640807 [details]
program.log
Comment 3 Pavel Holica 2012-11-08 08:23:37 EST
Created attachment 640808 [details]
storage.log
Comment 4 Chris Lumens 2012-11-08 11:15:10 EST
Yeah, this is just a difference in the new installer design.  You'll need to revisit the storage spoke and then it should be fairly obvious what the problem is.

We are trying to prevent people from getting locked into spokes, and to allow people to do other stuff while checks are running.  That's why you are sent back to the hub while storage sanity check runs, and why you have to go back into the spoke to see the detailed errors later.

Note You need to log in before you can comment on or make changes to this bug.