Bug 874614 - Upgrade from Satellite 5.4.1 to 5.5.0 on RHEL 6 clobbers /etc/rhn/rhn.conf
Upgrade from Satellite 5.4.1 to 5.5.0 on RHEL 6 clobbers /etc/rhn/rhn.conf
Status: CLOSED NOTABUG
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Installer (Show other bugs)
550
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Milan Zazrivec
Red Hat Satellite QA List
:
Depends On:
Blocks: 819027
  Show dependency treegraph
 
Reported: 2012-11-08 09:29 EST by Gary Titchmarsh
Modified: 2013-10-24 13:46 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-04 11:25:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Gary Titchmarsh 2012-11-08 09:29:15 EST
Description of problem:
Satellite upgrade re-creates /etc/rhn/rhn.conf with default values, moves old rhn.conf file to /etc/rhn/rhn.conf.orig

rpm upgrades would typically create .rpmnew instead of .orig.


Version-Release number of selected component (if applicable):


How reproducible:
Unknown, only have one Satellite box to upgrade. 

Steps to Reproduce:
1.Install RHEL 6.3
2.Install Satellite 5.4.1
3.Change mount points in /etc/rhn/rhn.conf away from default
4.Upgrade to Satellite 5.5.0 using upgrade option on script.
  
Actual results:

/etc/rhn/rhn.conf returned to RPM version with only Email carried across 

Expected results:

Upgrade script should honour all changes to /etc/rhn/rhn.conf as mount_point is not always default.


Additional info:
Comment 1 Clifford Perry 2013-07-04 11:25:15 EDT
Not a bug - as per this is expected behaviour. Within the rhn-upgrade RPM's text documentation for doing an upgrade we state to back everything up. We then have a step to say - review rhn.conf and restore custom settings. 

Cliff

Note You need to log in before you can comment on or make changes to this bug.