Bug 87464 - External monitor runs at incorrect resolution
External monitor runs at incorrect resolution
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
9
All Linux
medium Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-03-27 01:18 EST by Brian Ryner
Modified: 2007-04-18 12:52 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-29 16:16:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xdpyinfo output (5.96 KB, text/plain)
2003-03-27 01:19 EST, Brian Ryner
no flags Details
XF86Config file (3.14 KB, text/plain)
2003-03-28 02:53 EST, Brian Ryner
no flags Details
XFree86 log when I start with the monitor disconnected (30.21 KB, text/plain)
2003-03-28 02:54 EST, Brian Ryner
no flags Details
XFree86 log when I start with the monitor attached (42.19 KB, text/plain)
2003-03-28 02:55 EST, Brian Ryner
no flags Details

  None (edit)
Description Brian Ryner 2003-03-27 01:18:34 EST
Description of problem:

I have my laptop connected to an external monitor.  Instead of running at
resolution I configured X for, the monitor uses a lower resolution, meaning that
I have to pan around the screen.  The laptop is a Sager NP5660, the monitor is a
ViewSonic P810.  The native resolution of the laptop's display is 1600x1200,
which is what I selected in X's display configuration.

There's a convoluted workaround which might provide a clue as to the problem. 
If I completely disconnect the monitor from the system (apparently it can still
be detected even if it's powered off?), reboot and run the X display
configuration, and restart X, _then_ connect the monitor, the monitor uses the
correct resolution.

This problem did not happen in RH 8.0

Version-Release number of selected component (if applicable):

XFree86-4.3.0-2

How reproducible:

always

Steps to Reproduce:
1. start up the system with the external monitor connected
    
Actual results:

Monitor uses lower resolution.

Expected results:

Monitor should use the resolution I configured.

I'll attach the output of xdpyinfo, in case it's helpful.  This bug appears in
the 9.0 final release.
Comment 1 Brian Ryner 2003-03-27 01:19:50 EST
Created attachment 90740 [details]
xdpyinfo output

This is the output from xdpyinfo _after_ executing the aforementioned
workaround.  I'll check whether it's any different when the monitor is at the
wrong resolution.
Comment 2 Brian Ryner 2003-03-27 01:23:37 EST
Nope, no change in xdpyinfo output after I rebooted (and the monitor is now at
the lower resolution).
Comment 3 Brian Ryner 2003-03-27 01:40:51 EST
In the above workaround, I should note that re-running the display configuration
on each bootup isn't necessary.  I can work around the problem by just booting
up with the monitor physically disconnected.  Also, I tried to do the same
workaround with just stopping and starting the X server instead of rebooting,
but it doesn't work.  This is driving me nuts, so I'll be happy to provide any
logs or files that might help narrow this down.
Comment 4 Mike Chambers 2003-03-27 08:12:37 EST
Can you attach your XFree Config files for both the laptop and the external
monitor and your XFree log file?  Maybe comparing both of them somehow might
come up with an answer.
Comment 5 Mike A. Harris 2003-03-27 11:17:49 EST
There is no "9.0" release, and there won't be.  The release is:

     Red Hat Linux 9

Not "Red Hat Linux 9.0"
Comment 6 Brian Ryner 2003-03-28 02:53:56 EST
Created attachment 90754 [details]
XF86Config file

I'm not sure what you meant about XF86Config files for the laptop and the
monitor.  I only have a single XF86Config, and this is it.
Comment 7 Brian Ryner 2003-03-28 02:54:59 EST
Created attachment 90755 [details]
XFree86 log when I start with the monitor disconnected

This is the XFree86 log when I start up with the monitor disconnected (and upon
reconnecting it, it's at the correct resolution).
Comment 8 Brian Ryner 2003-03-28 02:55:45 EST
Created attachment 90756 [details]
XFree86 log when I start with the monitor attached

This is the XFree86 log file when I start with the monitor connected and it
uses the incorrect lower resolution.
Comment 9 Mike Chambers 2003-03-28 06:18:17 EST
I thought you were reconfiguring your XFree Config file when trying to use the
monitor, is why I asked for both.  Or at least changing it when trying to use
it.  If you are changing it, then yes please attach the changed one as well. 
Otherwise, what you have so far should be enough to start on, thanks.
Comment 10 Mike A. Harris 2003-04-08 08:45:22 EDT
Have you looked at the 'radeon' manpage and tried some of the options
present there?

The greater problem at least in my opinion, is that our configuration tool
is really created for configuring a machine with one single display, and
not for multihead configurations.  As such, any user using multihead must
configure it themselves, and when doing so, if something doesn't work right,
they assume it is a bug and file a bug report.  Often, it is not easy to
even determine if the problem being reported is a real bug in XFree86, a
bug in the config tool, or just end user misunderstanding on how to manually
configure the overly complex configuration themselves.

Not having this kind of hardware, makes it nontrivial for me to properly
assess the problem to determine on my own if it is a bug, or just a
misconfiguration or a shortcoming of our config tool.

I also suggest posting your problem on the xfree86@xfree86.org mailing list,
as that will provide feedback from many other users and developers with and
without this hardware, some of whom may have experienced the same problem
and perhaps found a solution already.

If you find an answer to the problem please update the bug report so I
know where it stands.

Comment 11 Brian Ryner 2003-04-09 23:24:07 EDT
I made some progress here (thanks for the man page pointer).  If I either set
CloneMode to 0, or set it to 2 and enable DDCMode, things work pretty much as
expected.  I'm trying to figure out what the real difference is between these
two settings.
Comment 12 Brian Ryner 2003-04-09 23:25:48 EDT
sorry, CloneDisplay, not CloneMode.
Comment 13 Mike A. Harris 2004-09-29 16:16:21 EDT
This issue should be fixed in the current xorg-x11 6.8.1 release
which is present in our Fedora Development code base, known as
"rawhide".

If this issue turns out to still be reproduceable in the latest
version of Fedora Core, please file a bug report in the X.Org
bugzilla located at http://bugs.freedesktop.org in the "xorg"
component.

Once you've filed your bug report to X.Org, if you paste the new
bug URL here, Red Hat will continue to track the issue in the
centralized X.Org bug tracker, and will review any bug fixes
that become available for consideration in future updates.

Note You need to log in before you can comment on or make changes to this bug.