Bug 874651 - apache-james: Obfuscated code
apache-james: Obfuscated code
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: apache-james-project (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Michal Srb
Fedora Extras Quality Assurance
:
Depends On:
Blocks: FE-Legal 874653
  Show dependency treegraph
 
Reported: 2012-11-08 10:26 EST by Mikolaj Izdebski
Modified: 2013-07-23 09:02 EDT (History)
5 users (show)

See Also:
Fixed In Version: 1.8.1-4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 874653 (view as bug list)
Environment:
Last Closed: 2013-07-23 09:02:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mikolaj Izdebski 2012-11-08 10:26:31 EST
Description of problem:
apache-james-project is bubdling obfuscated JavaScript code that is dual licensed GPL/MIT, however it violates GPLv2 license (because no source code is provided, only obfuscated code, which is not source code, but object code) and violates MIT license by not including the text of the license.

It also includes a copy of galleria, which is MIT-licensed, but no license text is included either.

The license tag says "ASL 2.0", but it should be "ASL 2.0 and MIT and MIT or GPLv2"

Version-Release number of selected component (if applicable):
1.6-3
Comment 1 Tom "spot" Callaway 2012-11-08 12:13:24 EST
You should file this issue upstream.
Comment 2 Michal Srb 2013-07-23 09:02:09 EDT
Fixed in 1.8.1-4.

Note You need to log in before you can comment on or make changes to this bug.