Bug 87471 - core dumped while executing \connect command on psql -f
Summary: core dumped while executing \connect command on psql -f
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: postgresql   
(Show other bugs)
Version: 7.1
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Andrew Overholt
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-03-27 11:23 UTC by Paul Osmialowski
Modified: 2007-04-18 16:52 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-03-27 22:13:33 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Paul Osmialowski 2003-03-27 11:23:41 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
I've started sql script using psql -f
It has crashed on first command:
\connect - user_name
where user_name is the name of user that don't exist on postgresql database
(script worked OK after I've added this user using createuser).
After standard message about lack of user on postgresql, 'Segmentation fault'
message was shown and core file was created.
To do some test, I've started psql and typed \connect - foo
Message about lack of user was shown, and nothing wrong was happen next.
So the problem is only with psql -f option.
I did this test on RH7.3, and it was OK. Problem is only on RH7.1.


Version-Release number of selected component (if applicable):
postgresql-7.0.3-9.2

How reproducible:
Always

Steps to Reproduce:
1.create some test.sql script, i.e.:
\connect - foo
2.type psql -f test.sql
3.remove core file from your home directory


Actual Results:  core was dumped

Expected Results:  nothing

Additional info:

Comment 1 Andrew Overholt 2003-03-27 22:13:33 UTC
As far as we can tell, this bug has been fixed a while ago.


Note You need to log in before you can comment on or make changes to this bug.