Bug 874737 - [upgrade] 1.0 to 1.1 upgrades brings UI error on Organizations edit page
[upgrade] 1.0 to 1.1 upgrades brings UI error on Organizations edit page
Status: CLOSED CURRENTRELEASE
Product: Subscription Asset Manager
Classification: Red Hat
Component: katello-configure (Show other bugs)
1.2
Unspecified Unspecified
unspecified Severity high
: rc
: ---
Assigned To: Katello Bug Bin
Tazim Kolhar
: Triaged
Depends On: 874160
Blocks: sam12-tracker
  Show dependency treegraph
 
Reported: 2012-11-08 13:32 EST by Jordan OMara
Modified: 2016-04-25 20:54 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 874160
Environment:
Last Closed: 2012-11-20 12:12:32 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 2 Tazim Kolhar 2012-11-20 11:22:06 EST
FAILED QA :

# service $service stop (tomcat6,thumbslug,katello,katello-jobs)
# yum update katello*
--> Processing Dependency: netty >= 3.2.3 for package: thumbslug-0.0.26-1.el6_3.noarch
--> Processing Dependency: jakarta-commons-codec for package: thumbslug-0.0.26-1.el6_3.noarch
--> Processing Dependency: oauth for package: thumbslug-0.0.26-1.el6_3.noarch
--> Running transaction check
---> Package akuma.x86_64 0:1.7-3.el6 will be installed
---> Package apache-commons-codec.noarch 0:1.4-9.1_redhat_1.ep6.el6.1 will be installed
---> Package netty.noarch 0:3.2.6-1_redhat_1.2.ep6.el6 will be installed
---> Package oauth.noarch 0:20100601-3.el6 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package                  Arch     Version                      Repository
                                                                           Size
================================================================================
Updating:
 katello-certs-tools      noarch   1.2.1-1h.el6_3               headpin    74 k
 katello-cli-common       noarch   1.2.3-1h.el6_3               headpin   392 k
 katello-common           noarch   1.2.5-1h.el6_3               headpin   331 k
 katello-configure        noarch   1.2.2-1h.el6_3               headpin   122 k
 katello-glue-candlepin   noarch   1.2.5-1h.el6_3               headpin   311 k
 katello-headpin          noarch   1.2.5-1h.el6_3               headpin   4.3 M
 katello-headpin-all      noarch   1.2.5-1h.el6_3               headpin   294 k
 katello-selinux          noarch   1.2.1-1h.el6_3               headpin    24 k
Installing for dependencies:
 akuma                    x86_64   1.7-3.el6                    headpin    16 k
 apache-commons-codec     noarch   1.4-9.1_redhat_1.ep6.el6.1   headpin    77 k
 katello-cli              noarch   1.2.3-1h.el6_3               headpin    77 k
 netty                    noarch   3.2.6-1_redhat_1.2.ep6.el6   headpin   2.9 M
 oauth                    noarch   20100601-3.el6               headpin    56 k
 rubygem-apipie-rails     noarch   0.0.12-2.el6cf               headpin   147 k
 rubygem-ldap_fluff       noarch   0.1.3-1.el6_3                headpin    51 k
 thumbslug-selinux        noarch   0.0.26-1.el6_3               headpin    81 k
Updating for dependencies:
 thumbslug                noarch   0.0.26-1.el6_3               headpin    62 k

Transaction Summary
================================================================================
Install       8 Package(s)
Upgrade       9 Package(s)


Total size: 9.2 M
Downloading Packages:
Running rpm_check_debug
Running Transaction Test


Transaction Check Error:
  file /usr/bin/headpin from install of katello-cli-1.2.3-1h.el6_3.noarch conflicts with file from package katello-cli-headpin-0.1.16-1.el6.noarch

Error Summary
-------------
Comment 3 Jordan OMara 2012-11-20 12:12:32 EST
The upgrade bug was fixed in katello-cli-1.2.4-1h

Note You need to log in before you can comment on or make changes to this bug.