Bug 87481 - Behavior - Devices in kcontrol is ignored by KDE
Behavior - Devices in kcontrol is ignored by KDE
Status: CLOSED UPSTREAM
Product: Red Hat Linux
Classification: Retired
Component: kdebase (Show other bugs)
9
All Linux
medium Severity high
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-03-27 10:48 EST by Chris Ricker
Modified: 2007-04-18 12:52 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-08 10:24:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of desktop missing devices (201.19 KB, image/png)
2003-04-02 11:06 EST, Chris Ricker
no flags Details

  None (edit)
Description Chris Ricker 2003-03-27 10:48:08 EST
fresh install of RHL 9, kdebase-3.1-12

If I go into the Control Center (kcontrol), then select Desktop, then Behavior,
I'm given a Devices option where I can specify which devices I want displayed on
my desktop.

This option is ignored entirely by the KDE shipped with RHL 9. No matter which
devices I select or deselect, my desktop always shows my unmounted floppy
device, and that's the only device it shows.

This bug makes the KDE file manager of very limited utility
Comment 1 Ngo Than 2003-04-02 10:04:59 EST
i have enabled to show some devices (e.g floppy, and cdrom). If i mount
floppy/cdrom device it's showed correct on my desktop.

I have tried on many local machines with 9. and it works.

Comment 2 Chris Ricker 2003-04-02 11:01:14 EST
Reopening. I see this on every RHL9 box I've got. Not sure why you can't
reproduce it.
Comment 3 Chris Ricker 2003-04-02 11:06:28 EST
Created attachment 90843 [details]
screenshot of desktop missing devices
Comment 4 Chris Ricker 2003-04-02 11:08:58 EST
See screenshot. I have enabled:

Mounted CD-ROM
Mounted NFS
Mounted SAMBA

and that's it. I currently have 2 NFS mounts (as you can see in the xterm), 2
smb mounts, and 1 cd-rom mount.

*none* of those show up on the desktop. Instead, the floppy shows up (which
isn't mounted, and which I've asked it not to display whether it's mounted or not)
Comment 5 Chris Ricker 2003-04-02 11:10:02 EST
BTW, I realized my wording might not be clear. I have enabled:

Mounted CD-ROM
Mounted NFS
Mounted SAMBA

and I have all others disabled
Comment 6 Ngo Than 2003-05-08 10:24:42 EDT
kdesktop does not work with automount, it looks like that you are using
automount to mount your devices.

workaround to this problem, you should mount either your devices manuel or just
add devices into /etc/fstab.

I hope it should be fixed in new upstream.

Note You need to log in before you can comment on or make changes to this bug.