Bug 874855 - xmonad does not follow ICCCM and ignores WM_TAKE_FOCUS protocol
xmonad does not follow ICCCM and ignores WM_TAKE_FOCUS protocol
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xmonad (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jens Petersen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-08 18:08 EST by Jon VanAlten
Modified: 2015-07-13 00:43 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-10 02:11:28 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jon VanAlten 2012-11-08 18:08:54 EST
Description of problem:
I experience symptoms of this problem primarily when using java programs (but not all java programs).  Where there is a GUI component that should allow text entry, it is not possible to place the cursor in that component and allow typed text to appear there.

Version-Release number of selected component (if applicable):
Currently seeing this in 0.10-11 but has been observed since I started using xmonad some months ago.

How reproducible:

One known example of java app affected by this bug is thermostat.
# yum install thermostat
$ thermostat service --start
(this^ will block terminal)
$ thermostat gui

In left-most panel of gui, near upper edge, is a search box.  Try as I might, I cannot place the cursor in this search box.  Works when using other WM.

Additional info:

This is a long-standing bug in upstream.

http://code.google.com/p/xmonad/issues/detail?id=177

comment 33 at above link has patch that allegedly fixed things, which is supposed to be upstream for some time now, but others find that they still have this issue (and myself apparently).  comment 107 may have useful info for how to build/install xmonad in rpm package such that java7 users (ie all of f17 users) are also not affected anymore.  I haven't tested it, not really interested in installing wm separate from fedora repos, but I would be happy to test any rpm builds that may sometime be available!
Comment 1 Solitary 2012-11-11 19:04:19 EST
Same problem as mine https://bugzilla.redhat.com/show_bug.cgi?id=837388 although I use Bluetile, which utilizes Xmonad anyway. I would be really happy if someone tried to apply the patch and made a package, Xmonad does seem to take it bit slow, so waiting for upstream could take long. At least some test package would be great, if patching it official would be a problem. The whole Haskell patching and compiling thing is unfortunatelly over my head, otherwise I would try it myself.
Comment 2 Jens Petersen 2012-11-13 09:10:36 EST
Thanks for the reports - will try to get back to you soon.
Comment 3 Ricky Zhou 2012-11-15 02:28:29 EST
I ran into this issue as well, and extracted the relevant patches out of the xmonad and XMonadContrib darcs repos (which have just recently incorporated the patches from the bug).

Here are the patches (track-currently-processing-event.patch is for xmonad, icccmfocus.patch is for XMonadContrib), as well as some quickly modified spec files: http://ricky.fedorapeople.org/xmonad/
Comment 4 Jens Petersen 2012-11-16 22:37:49 EST
*** Bug 837388 has been marked as a duplicate of this bug. ***
Comment 5 Jens Petersen 2012-11-16 22:59:36 EST
Thanks guys.

I committed track-currently-processing-event.patch to xmonad master:

http://pkgs.fedoraproject.org/cgit/xmonad.git/commit/?id=c5692567169accb404382db1b65a43ce2ff771cc
Comment 6 Jens Petersen 2012-11-16 23:10:01 EST
Scratch builds

F18: http://koji.fedoraproject.org/koji/taskinfo?taskID=4697827

F17: http://koji.fedoraproject.org/koji/taskinfo?taskID=4697830

Please test :)

Will update xmonad-contrib and bluetile soon.
Comment 7 Jens Petersen 2012-11-16 23:44:30 EST
I committed icccmfocus.patch to fedora xmonad-contrib:master.
Comment 8 Jens Petersen 2012-11-17 00:03:19 EST
Here is an untested srpm which should build against the above patched xmonad:

http://petersen.fedorapeople.org/ghc-xmonad-contrib-0.10-7.fc19.src.rpm
Comment 9 Jens Petersen 2012-11-17 00:32:47 EST
Ok, xmonad and ghc-xmonad-contrib also built for F19 Rawhide:

http://koji.fedoraproject.org/koji/buildinfo?buildID=366978 (xmonad)
http://koji.fedoraproject.org/koji/buildinfo?buildID=366979 (xmonad-contrib)

These builds should work also on F18 (since rawhide is still on ghc-7.4.1)
but not for F17 or earlier.
Comment 10 Fedora Update System 2012-11-29 23:14:55 EST
xmonad-0.10-15.fc18,ghc-xmonad-contrib-0.10-7.fc18,bluetile-0.6-10.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/xmonad-0.10-15.fc18,ghc-xmonad-contrib-0.10-7.fc18,bluetile-0.6-10.fc18
Comment 11 Fedora Update System 2012-11-30 02:57:35 EST
xmonad-0.10-15.fc17,ghc-xmonad-contrib-0.10-7.fc17,bluetile-0.6-10.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/xmonad-0.10-15.fc17,ghc-xmonad-contrib-0.10-7.fc17,bluetile-0.6-10.fc17
Comment 12 Jens Petersen 2012-11-30 03:00:11 EST
If people could test either of these that would be most helpful.

Once we are sure they are good - it can also be backported to f16
if there is demand I guess.
Comment 13 Solitary 2012-11-30 10:12:35 EST
Just updated my bluetile, ghc-xmonad and ghc-xmonad-contrib and did quick test and Netbeans IDE with OpenJDK 1.7 works as supposed to, earlier mentioned test case too. Awesome! :)
Comment 14 Jon VanAlten 2012-11-30 11:05:28 EST
I've updated *xmonad* packages from the update (not bluetile, I don't use it) and all is well.  Added karma.  Thanks a lot for getting this out, Jens!
Comment 15 Fedora Update System 2012-11-30 15:29:26 EST
Package xmonad-0.10-15.fc18, ghc-xmonad-contrib-0.10-7.fc18, bluetile-0.6-10.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing xmonad-0.10-15.fc18 ghc-xmonad-contrib-0.10-7.fc18 bluetile-0.6-10.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-19420/xmonad-0.10-15.fc18,ghc-xmonad-contrib-0.10-7.fc18,bluetile-0.6-10.fc18
then log in and leave karma (feedback).
Comment 16 Jens Petersen 2012-12-06 21:47:20 EST
Looks good to me on F18 and F17.

So I will also backport to F16 and EPEL6
Comment 17 Fedora Update System 2012-12-07 00:23:51 EST
xmonad-0.10-3.8.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/xmonad-0.10-3.8.fc16
Comment 19 Fedora Update System 2012-12-10 02:11:31 EST
xmonad-0.10-15.fc18, ghc-xmonad-contrib-0.10-7.fc18, bluetile-0.6-10.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 20 Fedora Update System 2012-12-10 20:31:37 EST
xmonad-0.10-15.fc17, ghc-xmonad-contrib-0.10-7.fc17, bluetile-0.6-10.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 21 Fedora Update System 2013-01-19 22:09:33 EST
xmonad-0.10-3.8.fc16, ghc-xmonad-contrib-0.10-7.fc16, bluetile-0.6-10.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 22 Fedora Update System 2013-01-22 05:14:17 EST
xmonad-0.10-3.4.2.el6,ghc-xmonad-contrib-0.10-7.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/xmonad-0.10-3.4.2.el6,ghc-xmonad-contrib-0.10-7.el6
Comment 23 Fedora Update System 2013-02-15 13:38:07 EST
xmonad-0.10-3.4.2.el6, ghc-xmonad-contrib-0.10-7.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.