Bug 87492 - segfault on invalid hostname
segfault on invalid hostname
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: x3270 (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Karsten Hopp
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-03-27 13:31 EST by Elliot Lee
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-04-01 09:29:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Elliot Lee 2003-03-27 13:31:00 EST
Passing an invalid hostname (e.g. 'asdf') on the command line as a host to connect to 
causes a segfault. Ditto if an invalid hostname is entered in the 'connect' dialog in the GUI.
Comment 1 Karsten Hopp 2003-03-27 15:28:30 EST
Works for me with x3270-3.2.19-4, XFree86-libs-4.3.0-2, glibc-2.3.2-5. Which versions are 
installed on your system ? 
Comment 2 Karsten Hopp 2003-04-01 09:29:44 EST
included <sys/time.h> instead of <time.h>, fixed in next release 

Note You need to log in before you can comment on or make changes to this bug.