Bug 875068 - SAM1.2 puddle katello-configure failed.
SAM1.2 puddle katello-configure failed.
Status: CLOSED UPSTREAM
Product: Subscription Asset Manager
Classification: Red Hat
Component: katello (Show other bugs)
1.2
x86_64 Linux
medium Severity medium
: rc
: ---
Assigned To: Jordan OMara
SAM QE List
:
Depends On:
Blocks: sam12-tracker
  Show dependency treegraph
 
Reported: 2012-11-09 07:51 EST by Tazim Kolhar
Modified: 2016-04-25 20:54 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-30 11:23:59 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
katello-debug attached (78.83 KB, application/x-gzip)
2012-11-09 07:51 EST, Tazim Kolhar
no flags Details

  None (edit)
Description Tazim Kolhar 2012-11-09 07:51:35 EST
Created attachment 641524 [details]
katello-debug attached

Description of problem:
katello-configure failed for new sam puddle
Repo location used :
http://download.devel.redhat.com/devel/candidate-trees/SAM/SAM-1.2-RHEL-6-20121109.n.0/compose/SAM/x86_64/os/

Version-Release number of selected component (if applicable):

# rpm -qa | grep katello
katello-common-1.2.3-1h.el6_3.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-certs-tools-1.2.1-1h.el6_3.noarch
katello-cli-1.2.3-1h.el6_3.noarch
katello-selinux-1.2.1-1h.el6_3.noarch
katello-cli-common-1.2.3-1h.el6_3.noarch
katello-headpin-1.2.3-1h.el6_3.noarch
katello-configure-1.2.2-1h.el6_3.noarch
katello-headpin-all-1.2.3-1h.el6_3.noarch
katello-glue-candlepin-1.2.3-1h.el6_3.noarch


How reproducible:

# yum install -y katello-headpin-all
# katello-configure --deployment=sam
Steps to Reproduce:

1.# yum install -y katello-headpin-all
 
2.# katello-configure --deployment=sam
Starting Katello configuration
The top-level log file is [/var/log/katello/katello-configure-20121109-073626/main.log]
Creating Katello database user
############################################################ ... OK
Creating Katello database
############################################################ ... OK
Creating Candlepin database user
############################################################ ... OK
Populating Katello database schema
###########################################################
  Failed, please check [/var/log/katello/katello-configure/db_migrate.log]
  Report errors using # katello-debug tool.


3.# katello-debug
created directory /tmp/katello-debug-20121109073839
  copying over /var/log/audit/audit.log
  copying over /var/log/httpd
  copying over /etc/httpd/conf.d
  copying over /var/log/tomcat6
  copying over /etc/candlepin/candlepin.conf
  copying over /etc/tomcat6/server.xml
  copying over /etc/thumbslug
  copying over /var/log/thumbslug
  copying over /var/log/katello
  copying over /etc/katello/client.conf
  copying over /etc/katello/katello.yml
  copying over /etc/katello/mapping.yml
  copying over /etc/katello/thin.yml
  skipping /etc/katello/environment.db since it does not exist
  copying over /etc/katello/katello-configure.conf
  skipping /etc/httpd.d/katello.conf since it does not exist
  copying over /var/log/elasticsearch
  copying over /etc/elasticsearch
  skipping /etc/pulp/pulp.conf since it does not exist
  skipping /var/log/pulp since it does not exist
  skipping /etc/httpd.d/pulp.conf since it does not exist
  skipping /etc/qpidd.conf since it does not exist
sed: can't read /tmp/katello-debug-20121109073839/etc/pulp/pulp.conf: No such file or directory
sed: can't read /tmp/katello-debug-20121109073839/etc/pulp/pulp.conf: No such file or directory
certutil: function failed: security library: bad database.
certutil: function failed: security library: bad database.
certutil: function failed: security library: bad database.
ls: cannot access /etc/pki/katello/nssdb/*: No such file or directory
A debug file has been created at /tmp/katello-debug-20121109073839.tar.gz.
Make sure it contains no security sensitive data before making it public!


  
Actual results:


Expected results:


Additional info:
Comment 2 Tom McKay 2012-11-30 11:23:59 EST
Fixed in latest compose
Comment 4 Garik Khachikyan 2012-12-03 08:17:24 EST
# COMMENT

confirm: issue fixed. various upgrade scenarios made during QE testing - all successful. thanks for fixing it.

Note You need to log in before you can comment on or make changes to this bug.