Bug 875140 - Position of charts anchored to cell reseted when opening sheet
Position of charts anchored to cell reseted when opening sheet
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
17
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-09 10:57 EST by Olavi Ourson
Modified: 2012-11-18 21:29 EST (History)
6 users (show)

See Also:
Fixed In Version: libreoffice-3.5.7.2-6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-18 21:29:18 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 54695 None None None 2012-11-12 07:20:29 EST
FreeDesktop.org 56009 None None None 2012-11-12 07:19:07 EST

  None (edit)
Description Olavi Ourson 2012-11-09 10:57:12 EST
Description of problem:
Charts anchored to cell in spreadsheet lose positioning when reopening the file.


Version-Release number of selected component (if applicable):
libreoffice-calc-3.5.7.2-3.fc17.x86_64

How reproducible:


Steps to Reproduce:
1. Create new spreadsheet, add any data (e.g. x,y values)
2. Add chart, set anchor to cell and position chart to row > 1
3. Save file, close and open again.
  
Actual results:
Charts have been moved to top of sheet.


Expected results:
Charts positioning doesn't change.


Additional info:
Comment 1 Caolan McNamara 2012-11-09 14:45:29 EST
caolanm->erack: sounds sufficiently dramatic that it sure been seen and fixed upstream already
Comment 2 Olavi Ourson 2012-11-10 00:49:59 EST
Found that the bug has been reported to freedesktop.org bugzilla:

https://bugs.freedesktop.org/show_bug.cgi?id=56009

Won't be fixed to 3.5.x, but 3.6.x already has the fix.
Comment 3 Olavi Ourson 2012-11-10 03:39:01 EST
Looks like the patch for 3.6.x is directly applicable for 3.5.7:

http://cgit.freedesktop.org/libreoffice/core/commit/?id=89e34ef5e4ff5efc202656bd9a2122745fdc6530&g=libreoffice-3-6

Of course I will be upgrading to Fedora 18 in three weeks or so, but just doing a rebuild with the patch added would solve the issue in the meantime.
Comment 4 Caolan McNamara 2012-11-12 07:33:46 EST
k, will backport to libreoffice-3.5.7.2-6
Comment 5 Fedora Update System 2012-11-12 15:07:42 EST
libreoffice-3.5.7.2-6.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/libreoffice-3.5.7.2-6.fc17
Comment 6 Fedora Update System 2012-11-14 21:40:06 EST
Package libreoffice-3.5.7.2-6.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing libreoffice-3.5.7.2-6.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-18238/libreoffice-3.5.7.2-6.fc17
then log in and leave karma (feedback).
Comment 7 Olavi Ourson 2012-11-15 12:41:18 EST
Tested with libreoffice-3.5.7.2-6, bug is fixed. Cheers!
Comment 8 Fedora Update System 2012-11-18 21:29:20 EST
libreoffice-3.5.7.2-6.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.