Bug 875202 - [iis] ResponseTime data fails to be collected due to incorrect and hard-coded log file prefix validation
[iis] ResponseTime data fails to be collected due to incorrect and hard-coded...
Status: CLOSED WONTFIX
Product: JBoss Operations Network
Classification: JBoss
Component: Plugin -- Other (Show other bugs)
JON 3.1.1
All Windows
unspecified Severity high
: ---
: JON 3.1.2
Assigned To: RHQ Project Maintainer
Mike Foley
:
Depends On: 875203
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-09 14:38 EST by Larry O'Leary
Modified: 2012-11-20 17:59 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 875203 (view as bug list)
Environment:
Last Closed: 2012-11-20 15:59:39 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Larry O'Leary 2012-11-09 14:38:17 EST
Description of problem:
Response Time (CallTime) metrics for an IIS VHost are not being collected and the following message is logged in the agent:

DEBUG [ResourceContainer.invoker.daemon-2] (org.rhq.plugins.iis.IISResponseTimeDelegate)- No log files exist yet


This failure is due to the plug-in looking for the wrong file name prefix. It appears that in IIS 7+ the default log file name begins with "u_ex" however, in IIS 6 (and the existing plug-in) "ex" was the prefix.

Version-Release number of selected component (if applicable):
4.4.0.JON311GA

How reproducible:
Always

Additional info:
From the support engineer who did some preliminary investigating:

After performing some tests locally, I have identified that the root cause should be related to the logging file name. As described in this page [2], "By Default IIS 7 log file format is stored using the u_ex prefix rather than ex prefix as seen in IIS 6." and there is a validation to check the logging file name, as follows:

**CLASS: IISResponseTimeDelegate

 -> This is a snippet of the class that contains the method responsible for validating the file name:

        private class IISResponseTimeLogFileFilter implements FileFilter {
            public boolean accept(File f) {
                String fileName = f.getName().toLowerCase();
                return fileName.startsWith("ex") && fileName.endsWith(".log");
            }
        }
Comment 2 Larry O'Leary 2012-11-20 17:59:46 EST
IIS 7.5 is not supported by plugin.

Note You need to log in before you can comment on or make changes to this bug.