Bug 875214 - geometrically impossible to answer calls
geometrically impossible to answer calls
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: notification-daemon (Show other bugs)
17
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: David Zeuthen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-09 15:22 EST by Stuart D Gathman
Modified: 2013-04-09 15:08 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-03 17:33:54 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Screenshot of useless notifier for incoming call. (2.49 MB, image/png)
2012-11-12 15:54 EST, Stuart D Gathman
no flags Details
Screenshot of useless notifier for incoming call. (2.49 MB, image/png)
2012-11-12 15:57 EST, Stuart D Gathman
no flags Details

  None (edit)
Description Stuart D Gathman 2012-11-09 15:22:31 EST
Description of problem:
The "Accept" button for answering a call is off screen when the notifier appears in gnome-fallback

Version-Release number of selected component (if applicable):
ekiga-3.9.90-1.fc17.i686

How reproducible:
always

Steps to Reproduce:
1. start ekiga (quite the process in itself as reported in other bugs)
2. wait for a call
3. see the Accept button is off screen and frantically look for an "Answer" menu option.

Actual results:
The Accept button on the notifier is off screen, and there is no "answer" menu option (as most other VOIP clients have).

Expected results:
A usable notifier *and* a traditional menu option or button on the main GUI to answer calls as a backup.

Additional info:
The notifier is broken in gnome fallback.  In gnome-shell, the notifier works.  **BUT** if you don't notice the notifier in time and click anywhere else on the screen - it goes away!!  Also, if you miss the Accept button with your mouse by a few pixels (and you are in a hurry to answer to call before it goes to voicemail), it goes away.  So there *still* needs to be an "answer call" button or menu option.
Comment 1 Peter Robinson 2012-11-10 12:14:55 EST
Can you attach a screen shot
Comment 2 Stuart D Gathman 2012-11-12 13:06:45 EST
I'll get a screenshot at next reboot.  But here is more: I'm using Xfce now.  When a call comes in, ekiga doesn't even attempt to provide a notifier!! The call dialog pops us, but if you press the green phone, it attempts to *place* a call, not answer it.  There is truly no way to answer the call!  There really, really needs to be an answer button.
Comment 3 Stuart D Gathman 2012-11-12 15:54:26 EST
Created attachment 643769 [details]
Screenshot of useless notifier for incoming call.
Comment 4 Stuart D Gathman 2012-11-12 15:57:02 EST
Created attachment 643770 [details]
Screenshot of useless notifier for incoming call.
Comment 5 Stuart D Gathman 2012-11-12 15:59:15 EST
(In reply to comment #3)
> Created attachment 643769 [details]
> Screenshot of useless notifier for incoming call.

Moving the main ekiga window around on the desktop does not help.
Comment 6 Fedora Update System 2012-11-27 06:11:07 EST
ekiga-4.0.0-1.fc17,opal-3.10.9-2.fc17,ptlib-2.10.9-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/ekiga-4.0.0-1.fc17,opal-3.10.9-2.fc17,ptlib-2.10.9-1.fc17
Comment 7 Stuart D Gathman 2012-11-27 16:24:28 EST
Found that the MATE desktop allows answering the phone with 3.9.  Since gnome-fallback is reportedly going away, I will not be revisiting it.  I will test Xfce again.
Comment 8 Fedora Update System 2012-11-28 06:29:18 EST
Package ekiga-4.0.0-1.fc17, opal-3.10.9-2.fc17, ptlib-2.10.9-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing ekiga-4.0.0-1.fc17 opal-3.10.9-2.fc17 ptlib-2.10.9-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-19197/ekiga-4.0.0-1.fc17,opal-3.10.9-2.fc17,ptlib-2.10.9-1.fc17
then log in and leave karma (feedback).
Comment 9 Stuart D Gathman 2012-11-29 13:57:08 EST
Tested ekiga 4.0.0.  I really appreciate fixing the notifier, but I don't know what it looks like because the new version won't register!  3.2 would register with no problem with my provider, but 3.9 required starting 3 times, changing NetDet between starts.  4.0 refuses to register at all, even with the work around!  I wasn't sure if I should leave negative karma for the release, but bodhi is getting an internal error when I try, so I won't.
Comment 10 Stuart D Gathman 2012-12-05 16:07:55 EST
Still impossible to answer calls in gnome-fallback.  (Found a workaround for register bug - which is also being properly addressed in bug#882398.)
Comment 11 Eugen Dedu 2012-12-06 17:24:38 EST
The notificaiton window is cut off.  This is a bug in libnotify for sure, since here it works, using gnome-fallback.  This bug should be moved to that component.

There are two workarounds:
- open the call window, and when call arrives click on green phone
- wait until the notification disappears, afterwards open the icon for notifications in gnome taskbar: I suppose the two buttons are shown there
Comment 12 Eugen Dedu 2012-12-07 04:51:17 EST
I can reproduce it.  When the string to be shown in notification is too big, the notification spans after the right edge of the screen, hence hiding the buttons too.  I look a bit how this should be fixed.
Comment 13 Eugen Dedu 2012-12-07 05:27:53 EST
Peter, could you move this bug to libnotify please?
Comment 14 Stuart D Gathman 2012-12-08 11:22:09 EST
I discovered a workaround: install MATE desktop, then edit startup for gnome to run mate-notification-daemon instead of gnome-notification-daemon.  (Or login as MATE desktop, logout, then login with gnome.)

Would this indicate that the real problem is gnome-notification-daemon, rather than libnotify?
Comment 15 Eugen Dedu 2012-12-08 12:51:10 EST
I think so.
Comment 16 Stuart D Gathman 2012-12-10 11:16:01 EST
I tested workarounds in comment#11  -  none of them work

I tried opening the call window, but when the call arrives, the green phone is still greyed out.  I also tried clicking on the notification to make it disappear, but then it doesn't appear in the icon for notifications in gnome taskbar.  If I wait for the notification to disappear, it is too late to answer the call.
Comment 17 Stuart D Gathman 2012-12-10 12:14:26 EST
Specific instructions for using mate-notification-daemon, in case someone is googling this problem:

1) install MATE desktop
2) as root, cd /usr/libexec
3) mv notification-daemon gnome-notification-daemon
4) ln -s mate-notification-daemon notification-daemon

to return to gnome notifier:
5) ln -sf gnome-notification-daemon notification-daemon
Comment 18 Stuart D Gathman 2012-12-10 12:15:51 EST
Forgot to mention - killall notification-daemon for notifier change to take effect.
Comment 19 Eugen Dedu 2012-12-10 15:05:30 EST
(In reply to comment #16)
> I tested workarounds in comment#11  -  none of them work

Hard to believe this...  Could you show it to me somehow?
Comment 20 Stuart D Gathman 2012-12-10 16:10:07 EST
You can connect to my desktop again.  I don't see you on #ekiga.  Using mate-notification-daemon has been working quite well - it seems to be compatible with the gnome version for all the events I've received so far.

If you want to see it, I'll have to revert to gnome-notification-daemon and call myself from my cell so you can see that the call window has no green phone (just a grey one).  The reason you aren't seeing it may be that by the time notifier goes away by itself, the nextiva service has already sent the call to voice mail.  I've tried clicking on the notifier to make it go away, but that may not be the same as waiting for it to go away by itself.  Anyway, waiting for it to go away by itself is not an acceptable option.
Comment 21 Stuart D Gathman 2012-12-10 17:37:13 EST
With some help from Eugen, the comment#11 workaround does work.  The Call Window must be open BEFORE a call comes in.  Once a call comes in, ekiga will not let you open the call window for some reason.  On Windows, ekiga opens the call window instead of a notifier.  I would like to see an option for ekiga to do that on Linux as well.
Comment 22 Stuart D Gathman 2013-02-20 10:50:21 EST
To anyone else with this problem, I recommend just switching to MATE instead of gnome-fallback.
Comment 23 Fedora Update System 2013-02-21 11:14:22 EST
ptlib-2.10.10-1.fc17,opal-3.10.10-1.fc17,ekiga-4.0.1-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/ptlib-2.10.10-1.fc17,opal-3.10.10-1.fc17,ekiga-4.0.1-1.fc17
Comment 24 Fedora Update System 2013-02-21 11:18:14 EST
ptlib-2.10.10-1.fc18,opal-3.10.10-1.fc18,ekiga-4.0.1-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/ptlib-2.10.10-1.fc18,opal-3.10.10-1.fc18,ekiga-4.0.1-1.fc18
Comment 25 Fedora Update System 2013-02-24 03:32:59 EST
Package ptlib-2.10.10-1.fc17, opal-3.10.10-1.fc17, ekiga-4.0.1-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing ptlib-2.10.10-1.fc17 opal-3.10.10-1.fc17 ekiga-4.0.1-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-2890/ptlib-2.10.10-1.fc17,opal-3.10.10-1.fc17,ekiga-4.0.1-1.fc17
then log in and leave karma (feedback).
Comment 26 Fedora Update System 2013-03-03 17:33:56 EST
ptlib-2.10.10-1.fc18, opal-3.10.10-1.fc18, ekiga-4.0.1-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 27 Fedora Update System 2013-03-03 17:40:02 EST
ptlib-2.10.10-1.fc17, opal-3.10.10-1.fc17, ekiga-4.0.1-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 28 Stuart D Gathman 2013-04-09 13:11:52 EDT
Just tried ekiga in cinnamon desktop.  In cinnamon, there is no notifier at all!  I suppose this would be a cinnamon bug, or perhaps a config issue.

However, cinnamon should really have a answer button that doesn't depend on notifiers.  Notifiers have been broken on 2 out of 4 linux desktops I've tried so far.  Has anyone tested answering a call in KDE?
Comment 29 Peter Robinson 2013-04-09 14:35:54 EDT
It's a cinnamon bug. Ultimately there's a notification bus and a standard, we push the notification onto the bus, if the desktop has no way to deal with it there's not much ekiga can do
Comment 30 Eugen Dedu 2013-04-09 15:08:10 EDT
I am amazed to see so many problems (not only you, but others too) with such a small program as notify.  I have asked my collegues to always show the call window, but it was not agreed.  notify is beautiful, but has implementation problems on various platforms.

Note that ekiga tests if notify is available AND that buttons (called actions) are allowed, and only in this case uses notification instead of call window.

Note You need to log in before you can comment on or make changes to this bug.