Bug 87522 - up2date cause kernel BUG at highmem.c:145!
up2date cause kernel BUG at highmem.c:145!
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
8.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Fanny Augustin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-03-28 06:26 EST by Franck mastaing
Modified: 2007-04-18 12:52 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-04-09 05:11:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Franck mastaing 2003-03-28 06:26:54 EST
Description of problem:

When I lauche up2date i've got thge following errors : 

------------[ cut here ]------------
kernel BUG at highmem.c:145!
invalid operand: 0000
autofs sis900 iptable_filter ip_tables ext3 jbd raid1 sym53c8xx sd_mod scsi_mo
CPU:    0
EIP:    0010:[<c013d9c0>]    Not tainted
EFLAGS: 00010246

EIP is at kmap_high [kernel] 0x30 (2.4.18-14)
eax: 00002001   ebx: 00001000   ecx: 00000000   edx: c0390f60
esi: 00000000   edi: f50ce968   ebp: f4c4bf6c   esp: f4c4bedc
ds: 0018   es: 0018   ss: 0018
Process up2date (pid: 1057, stackpage=f4c4b000)
Stack: c1d24f28 00001000 c012fcac 000009b3 c1d24ef0 00001000 00000000 c1d24ef0 
       f50ce968 000009b3 c012f6ee f4c4bf6c c1d24ef0 00000000 00001000 00001000 
       00000000 00000000 00000000 f50ce8c0 00000000 c012fbe0 f4c4bf6c f4c4bfa8 
Call Trace: [<c012fcac>] file_read_actor [kernel] 0xcc (0xf4c4bee4))
[<c012f6ee>] do_generic_file_read [kernel] 0x22e (0xf4c4bf04))
[<c012fbe0>] file_read_actor [kernel] 0x0 (0xf4c4bf30))
[<c012fd70>] generic_file_read [kernel] 0xb0 (0xf4c4bf50))
[<c012fbe0>] file_read_actor [kernel] 0x0 (0xf4c4bf60))
[<c0140282>] sys_pread [kernel] 0xc2 (0xf4c4bf8c))
[<c0133a44>] sys_mremap [kernel] 0x84 (0xf4c4bfa0))
[<c010910f>] system_call [kernel] 0x33 (0xf4c4bfc0))


Code: 0f 0b 91 00 38 9a 25 c0 eb ec 8d b6 00 00 00 00 89 04 24 e8 

Version-Release number of selected component (if applicable):

up2date-3.0.7-1

How reproducible:

by launching : up2date -u

Steps to Reproduce:
1. up2date -u
    
Actual results:


Expected results:


Additional info:
Comment 1 Franck mastaing 2003-04-09 05:11:42 EDT
This problem is not due to any package.
We resolv this by change the memory on the server.

Note You need to log in before you can comment on or make changes to this bug.