Bug 87528 - Glade2 hangs when try to edit menus
Glade2 hangs when try to edit menus
Status: CLOSED UPSTREAM
Product: Red Hat Linux
Classification: Retired
Component: glade2 (Show other bugs)
9
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Havoc Pennington
:
: 88365 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-03-28 09:32 EST by Hardy Merrill
Modified: 2007-04-18 12:52 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-03-28 14:27:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hardy Merrill 2003-03-28 09:32:20 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
Glade2 hangs when try to edit menus.

Version-Release number of selected component (if applicable):
libglade2-2.0.1-3, libglade2-devel-2.0.1-3, glade2-1.1.3-3

How reproducible:
Always

Steps to Reproduce:
1. open glade file
2. click on menu bar in app
3. click on 'Edit Menus...' button in Properties dialog

Actual Results:  glade hangs

Additional info:
Comment 1 Jonathan Blandford 2003-03-28 12:10:44 EST
eeeek!!!!
Comment 2 Jonathan Blandford 2003-03-28 12:25:21 EST
#0  0x420747af in malloc_consolidate () from /lib/tls/libc.so.6
#1  0x42073e09 in _int_malloc () from /lib/tls/libc.so.6
#2  0x420731fb in malloc () from /lib/tls/libc.so.6
#3  0x407b4559 in g_malloc (n_bytes=1108546304) at gmem.c:136

it's not hanging, it's getting ready to crash.
Comment 3 Jonathan Blandford 2003-03-28 14:26:48 EST
http://bugzilla.gnome.org/show_bug.cgi?id=105694
bug exists upstream.  Switching to Raleigh gtk-theme makes it work.  This looks
like a nasty bug.
Comment 4 Havoc Pennington 2003-04-09 11:02:13 EDT
*** Bug 88365 has been marked as a duplicate of this bug. ***
Comment 5 Stephen Tweedie 2003-06-07 13:36:45 EDT
I've encountered the same problem under Red Hat 9; glade-2.0.0 fixes it for me.
 Update for next release?
Comment 6 Havoc Pennington 2003-06-07 13:40:24 EDT
Yep, we're making an upgrade pass through all packages.

Note You need to log in before you can comment on or make changes to this bug.