Bug 875285 - IME names too long in gnome-shell Input Sources indicator
Summary: IME names too long in gnome-shell Input Sources indicator
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: ibus-typing-booster
Version: 18
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Mike FABIAN
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-11-10 05:08 UTC by Jens Petersen
Modified: 2013-05-26 03:37 UTC (History)
4 users (show)

Fixed In Version: ibus-typing-booster-0.0.29-1.fc19
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-05-26 02:56:33 UTC


Attachments (Terms of Use)
too-long-names-in-the-gnome-panel-for-ibus-typing-booster-input-methods.png (601.38 KB, image/png)
2012-11-12 08:15 UTC, Mike FABIAN
no flags Details

Description Jens Petersen 2012-11-10 05:08:03 UTC
Description of problem:
ibus-typing-booster IMEs' names seem to be too long/wide.
Can something please be done to make them shorter.

Steps to Reproduce:
1. add a hunspell input table
2. turn it on
  
Actual results:
eg for Danish appears at "da-DK(hunspell)".

Expected results:
First there should obviously be a space before the "(".
But anyway "da-DK(hunspell)".  There is only one da dictionary
so DK is perhaps redundant and need not be displayed,
alternatively maybe keep "-DK" and drop "(hunspell)"?
(but that makes it hard to find the IME, hmm).

So maybe "da (hunspell)" would be better though it is
still too long really.  Maybe GNOME Shell should truncate
overlong names intelligently instead.

Comment 1 Mike FABIAN 2012-11-12 08:15:08 UTC
Created attachment 643291 [details]
too-long-names-in-the-gnome-panel-for-ibus-typing-booster-input-methods.png

Comment 2 Mike FABIAN 2012-11-12 08:25:40 UTC
The attachment in comment#1 shows the problem.

Even though the currently selected input method is the US English
keyboard which has the short label “en” in the panel, this “en”
label uses a lot of space because ibus-typing-booster methods are
among the input methods which can be selected in the panel. And the
space used is apparently calculated according to the longest such
label of any input method in that list.

So this really looks quite ugly.

Comment 3 Mike FABIAN 2012-11-12 08:29:48 UTC
(In reply to comment #0)
> But anyway "da-DK(hunspell)".  There is only one da dictionary
> so DK is perhaps redundant and need not be displayed,
> alternatively maybe keep "-DK" and drop "(hunspell)"?
> (but that makes it hard to find the IME, hmm).

I think dropping “(hunspell)” and replacing it with one short
character which identifies the ibus-typing-booster input methods
is best.

The ibus-typing-booster input methods can still be found easily
when selecting input methods from the panel because the long name,
which looks like

     ドイツ語 (German -DE(Hunspell))

is displayed as well when selecting an input method from the panel.

Comment 4 Mike FABIAN 2012-11-12 08:33:57 UTC
I noticed this wide name in the panel a while ago and discussed what could be done on IRC:

<mfabian> rtcm: The indicator shown for the selected input method in the panel
          can be only text, right? Or can one include an icon there?
                                                          [12年10月23日 09:23:19]
<rtcm> just text [12年10月23日 09:26:51]
<mfabian> rtcm: OK. [12年10月23日 09:27:29]
<mfabian> rtcm: currently the ibus-typing-booster input methods have something
          like “en-GB(Hunspell)” there, which is quite long and causes the あ
          of ibus-anthy to be centred in a big, empty space. So I should make
          that shorter probably. I thought that instead of “(Hunspell)” a
          single glyph indicating that this is an autocompleter/spellchecker
          input method would be nice.  [12年10月23日 09:30:28]
<mfabian> rtcm: ibus-typing-booster used to have a rocket icon.
                                                          [12年10月23日 09:30:43]
<bochecha_> mfabian: why not just « en » [12年10月23日 09:31:17]
<bochecha_> I mean, it's an English input source after all
                                                          [12年10月23日 09:31:28]
<bochecha_> and if there are several « en » in the menu, GNOME automatically
            adds a « 1 », « 2 », ... [12年10月23日 09:31:49]
<mfabian> rtcm: U+1F680 ROCKET would be nice but this glyph is in very few
          fonts. [12年10月23日 09:31:51]
<mfabian> Yes, I saw this « 1 », « 2 », ... but this makes it hard to
          distinguish which “en” means what. [12年10月23日 09:32:34]
<mfabian> Maybe “en✓”  would be OK, at least U+2713 CHECK MARK is usually
          available in fonts. [12年10月23日 09:33:35]

... another channel ...

<mfabian> I also thought images might be nicer for the ime status because the
          ibus-typing-booster input methods are either hard to distinguish from
          the plain keyboards or the status becomes rather long. Currently
          ibus-typing-booster displays something like “en-GB(Hunspell)” as the
          status, which is clear but too long I think. Because the status is
          currently only text, I thought of changing it to something like
          “en-GB

Comment 5 Mike FABIAN 2012-11-12 08:39:19 UTC
bugzilla still seems to cut off comments when characters above the BMP
are used, here is the rest of the last comment which vanished:

...
 I thought of changing it to something like
          “en-GB <(U+1F680 ROCKET)>” but very [12年10月26日 09:04:29]
<mfabian> few fonts have that glyph. Maybe “en-GB✓” is good enough to indicate
          that it is a sort of spellchecker/autocompleter and there are enough
          fonts which have the CHECK MARK. For ibus-typing-booster this should
          be enough but for Chinese it will be quite hard to differentiate
          between the many input methods. 
<tagoh_> I basically like that idea and yeah, that would addresses the above
         issue right. but it's the fact there are a concern that the image may
         introduces unintuitive icon as we had in the past. engine developer or
         icon designer would needs to take care of it carefully. otherwise that
         will be messed up again. [12年10月26日 09:08:59]
<ueno> for the switcher, perhaps good to have IME name (in a small font) under
       each icon. currently only active IME name is shown at the bottom - I'm
       not a designer though ;) [12年10月26日 09:17:03]
<mfabian> ueno: Where is that, in f18 gnome-shell? [12年10月26日 09:42:05]
<ueno> mfabian, upstream ibus with gtk panel [12年10月26日 09:48:46]
<mfabian> ueno: So I cannot see that in f18 gnome-shell, right?
                                                          [12年10月26日 09:50:39]
<ueno> right [12年10月26日 09:51:52]

Comment 6 Fedora Update System 2012-11-12 13:46:15 UTC
ibus-typing-booster-0.0.21-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/ibus-typing-booster-0.0.21-1.fc18

Comment 7 Fedora Update System 2012-11-12 14:08:19 UTC
ibus-typing-booster-0.0.21-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/ibus-typing-booster-0.0.21-1.fc17

Comment 8 Fedora Update System 2012-11-12 14:22:27 UTC
ibus-typing-booster-0.0.21-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/ibus-typing-booster-0.0.21-1.fc16

Comment 9 Fedora Update System 2012-11-12 18:34:38 UTC
Package ibus-typing-booster-0.0.21-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing ibus-typing-booster-0.0.21-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-18053/ibus-typing-booster-0.0.21-1.fc18
then log in and leave karma (feedback).

Comment 10 Fedora Update System 2012-11-15 07:11:21 UTC
ibus-typing-booster-0.0.22-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/ibus-typing-booster-0.0.22-1.fc18

Comment 11 Fedora Update System 2012-11-15 07:40:09 UTC
ibus-typing-booster-0.0.22-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/ibus-typing-booster-0.0.22-1.fc16

Comment 12 Fedora Update System 2012-11-15 07:58:25 UTC
ibus-typing-booster-0.0.22-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/ibus-typing-booster-0.0.22-1.fc17

Comment 13 Fedora Update System 2012-11-23 13:59:29 UTC
ibus-typing-booster-0.0.23-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/ibus-typing-booster-0.0.23-1.fc18

Comment 14 Fedora Update System 2012-11-23 15:32:18 UTC
ibus-typing-booster-0.0.23-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/ibus-typing-booster-0.0.23-1.fc16

Comment 15 Fedora Update System 2012-11-23 16:16:19 UTC
ibus-typing-booster-0.0.23-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/ibus-typing-booster-0.0.23-1.fc17

Comment 16 Fedora Update System 2012-11-28 11:22:28 UTC
ibus-typing-booster-0.0.22-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 17 Fedora Update System 2012-11-28 11:34:02 UTC
ibus-typing-booster-0.0.22-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 18 Fedora Update System 2012-11-29 06:45:15 UTC
ibus-typing-booster-0.0.22-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 19 Fedora Update System 2012-12-05 06:54:34 UTC
ibus-typing-booster-0.0.23-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 20 Fedora Update System 2012-12-05 06:58:55 UTC
ibus-typing-booster-0.0.23-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 21 Fedora Update System 2012-12-05 07:13:47 UTC
ibus-typing-booster-0.0.23-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 22 Jens Petersen 2013-01-15 08:44:56 UTC
Currently I see "en-GB✓" and "da-DK✓", etc.
But are there any examples of when xx-YY would be ambiguous?

If not then I think better to drop "✓" since it just makes
the IME unncessarily wider IMHO.  Sorry I didn't this before.
xx-YY is already rather long compared to other sources.

Comment 23 Jens Petersen 2013-02-14 02:23:40 UTC
Reopening for comment 22.

Comment 25 Fedora Update System 2013-05-06 12:23:26 UTC
ibus-typing-booster-0.0.27-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/ibus-typing-booster-0.0.27-1.fc17

Comment 26 Fedora Update System 2013-05-06 12:52:18 UTC
ibus-typing-booster-0.0.27-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/ibus-typing-booster-0.0.27-1.fc18

Comment 27 Fedora Update System 2013-05-06 13:24:02 UTC
ibus-typing-booster-0.0.27-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/ibus-typing-booster-0.0.27-1.fc19

Comment 28 Fedora Update System 2013-05-06 18:30:06 UTC
Package ibus-typing-booster-0.0.27-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing ibus-typing-booster-0.0.27-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-7476/ibus-typing-booster-0.0.27-1.fc19
then log in and leave karma (feedback).

Comment 29 Fedora Update System 2013-05-10 19:28:57 UTC
ibus-typing-booster-0.0.28-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/ibus-typing-booster-0.0.28-1.fc19

Comment 30 Fedora Update System 2013-05-10 19:39:02 UTC
ibus-typing-booster-0.0.28-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/ibus-typing-booster-0.0.28-1.fc17

Comment 31 Fedora Update System 2013-05-10 20:18:02 UTC
ibus-typing-booster-0.0.28-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/ibus-typing-booster-0.0.28-1.fc18

Comment 32 Fedora Update System 2013-05-14 07:14:25 UTC
ibus-typing-booster-0.0.29-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/ibus-typing-booster-0.0.29-1.fc19

Comment 33 Fedora Update System 2013-05-14 07:24:32 UTC
ibus-typing-booster-0.0.29-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/ibus-typing-booster-0.0.29-1.fc17

Comment 34 Fedora Update System 2013-05-14 07:34:08 UTC
ibus-typing-booster-0.0.29-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/ibus-typing-booster-0.0.29-1.fc18

Comment 35 Fedora Update System 2013-05-26 02:56:33 UTC
ibus-typing-booster-0.0.29-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 36 Fedora Update System 2013-05-26 02:58:19 UTC
ibus-typing-booster-0.0.29-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 37 Fedora Update System 2013-05-26 03:37:45 UTC
ibus-typing-booster-0.0.29-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.