Bug 875305 - xterm has strange problems with the display
xterm has strange problems with the display
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xterm (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Lichvar
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-10 05:20 EST by lee
Modified: 2014-01-21 10:08 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 10:08:13 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xterm window when running 'xterm -t', then running 'ls' in the xterm window (778.56 KB, image/jpeg)
2013-07-18 03:31 EDT, lee
no flags Details
xterm window: started as 'xterm', running 'ls' in the xterm window (107.07 KB, image/jpeg)
2013-07-18 03:41 EDT, lee
no flags Details

  None (edit)
Description lee 2012-11-10 05:20:03 EST
Description of problem:

Starting xterm yields a blank window.  Xterm is working, though, except for the output to the display.  Starting xterm with the -tb option results in:


-bash-4.2$ /bin/xterm -tb
/bin/xterm: warning, error event received:
X Error of failed request:  BadWindow (invalid Window parameter)
  Major opcode of failed request:  18 (X_ChangeProperty)
  Resource id in failed request:  0x0
  Serial number of failed request:  260
  Current serial number in output stream:  262
-bash-4.2$ 


Sometimes it works until the xterm window loses focus.

Version-Release number of selected component (if applicable):

X.Org 7.6.0(286)

How reproducible:

run 'xterm -tb'

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 lee 2012-11-10 05:54:18 EST
Perhaps this is a problem with fvwm; the display of xterm isn't blank when I'm using i3 instead of fvwm.  Starting with -tb doesn't work with i3, either.
Comment 2 lee 2012-11-10 05:56:06 EST
Perhaps this is a problem with fvwm; the display of xterm isn't blank when I'm using i3 instead of fvwm.  Starting with -tb doesn't work with i3, either.
Comment 3 Thomas E. Dickey 2012-11-12 17:01:15 EST
"-tb" is an option which is not configured in Fedora,
as far as I'm aware.

It is used in Gentoo and Cygwin.
See my comments in
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=406169
Comment 4 lee 2012-11-13 08:17:59 EST
Shouldn't it give a more reasonable error message like "please compile xterm with the toolbar option enabled" instead?

Anyway, toolbar or not, the xterm window is blank when running it with fvwm as window manager while it works fine with i3. Does anyone have the same results? Can I somehow find out if this a problem of fvwm or of xterm?
Comment 5 Thomas E. Dickey 2012-11-19 05:31:47 EST
maybe/maybe not: there are several command-line options which
are conditionally compiled.

Checking now, I see that there's a hole in the rewrite of
command-line options from a few years ago.  xterm is
using that "-tb" as "-t" (tek4014) rather than reporting an error.
I'll have a fix for that in #287.

But the tek4014 window is working properly - your login shell
may clear it (or something) and produce some unexpected behavior.
Comment 6 lee 2012-11-19 08:19:35 EST
The shell running in the xterm window is bash, so nothing unusual.  If the shell in the xterm was doing it, then why would xterm work with i3 and not with fvwm?
Comment 7 Fedora Update System 2012-11-26 11:57:17 EST
xterm-287-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/xterm-287-1.fc18
Comment 8 Fedora Update System 2012-11-27 04:48:26 EST
Package xterm-287-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing xterm-287-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-19090/xterm-287-1.fc18
then log in and leave karma (feedback).
Comment 9 Fedora Update System 2012-12-01 04:53:09 EST
xterm-287-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 lee 2013-07-16 06:56:05 EDT
The problem still persists with xterm-293-1.fc19.x86_64 and fvwm-2.6.5-4.fc19.x86_64 on Fedora 19.
Comment 11 Miroslav Lichvar 2013-07-16 07:12:18 EDT
Ok, reopening.
Comment 12 Thomas E. Dickey 2013-07-17 09:52:29 EDT
With Fedora19 and xterm-293, I see only the expected behavior
for "-t" and "-tb" options (a Tek4014 window and a help-message
respectively).
Comment 13 lee 2013-07-18 03:29:27 EDT
For clarification:

The problem is that starting xterm, without any parameters, starts xterm and it displays an empty screen (in the color specified through ~/.Xresources) with a cursor in the top left corner of the window.

I can type into the xterm window and execute commands, but there is no output to the xterm window.  When I switch to another workspace or when I resize the xterm window, what I have typed and what has been output to the window is displayed.  I can type some more into the window, but that is not displayed until I switch to another workspace or resize the window.

Apparently it takes an explicit redraw request sent by fvwm --- or whatever happens when switching workspaces and resizing windows --- to the xterm window for output to be displayed in the window.


When I start xterm with the '-t' option, output shows up in the xterm window, but it looks messed up.  It seems that control sequences are printed as characters, and the ouput to the window is not scrolled but overwritten so that several layers of text overlay each other.  When I type 'clear' to clear the screen and press enter, the screen isn't cleared.  I can not mark text with the mouse pointer in the xterm window.


This happens when fvwm is used as a window manager.  It does not happen, and xterm works fine, when i3 is used as a window manager.

I'll try to attach a screenshot.  In the screenshot, you see an 'xterm -t' with the output of 'ls', showing the overlay effect.

Let me add that I usually never use the '-t' option with xterm, it only came up through this bug report.

Can I do something to help debug this?
Comment 14 lee 2013-07-18 03:31:56 EDT
Created attachment 775156 [details]
xterm window when running 'xterm -t', then running 'ls' in the xterm window
Comment 15 lee 2013-07-18 03:39:16 EDT
I just noticed that the output into the xterm window is displayed in the icon box while the xterm window is still empty.  I'll add another screenshot showing this:  starting 'xterm' without the '-t' option, running 'ls' in the xterm window.

Please note how the thumbnail image of the xterm window is displayed at the bottom left in the icon box.  You can see the output of 'ls' in there while the actual xterm window is still empty.
Comment 16 lee 2013-07-18 03:41:21 EDT
Created attachment 775168 [details]
xterm window: started as 'xterm', running 'ls' in the xterm window

Please note the thumbnail of the xterm window in the icon box on the bottom left.  It shows what is probably the output of 'ls' in the thumbnail while the actual xterm window is still empty.
Comment 17 Thomas E. Dickey 2013-07-18 04:30:31 EDT
Starting xterm with the "-t" option opens the Tek4014 window.
That's a feature, not a bug:

http://invisible-island.net/xterm/manpage/xterm.html

Starting without options, you may still have resources set which
have not been analyzed.  An output from "appres XTerm" shows some
of that.

For testing with fvwm, I was looking at the default configuration
as installed by Redhat - it's possible that the problem lies in your
particular configuration...
Comment 18 Thomas E. Dickey 2013-07-18 05:18:55 EDT
For the issue with sessions - some clue for that would be useful.
Starting xterm with "-t" - not much there.  Incidentally, you can
have both vt100 and tek4014 windows visible at the same time.
Only one accepts input; output is updated on the one that accepts
input.  Previous outputs are retained - however due to the attention
given vt100 window, it's possible that repainting tek4014 has been
overlooked in some scenario.  So... the first thing to do in
investigating is to (for example) not assume that "-tb" means the
same thing as "-t".  If you need that on some platforms, while it
is not available on others, use the "toolBar" resource setting.

For more information, see

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=406169
Comment 19 lee 2013-07-18 07:31:54 EDT
> For testing with fvwm, I was looking at the default configuration
> as installed by Redhat - it's possible that the problem lies in your
> particular configuration...

You are right!  When I do not start the FvwmIconBox module, xterm works fine.

I'm asking on the fvwm mailing list about this.  Let's see what they say ...


To: fvwm@fvwm.org
Subject: xterm with FvwmIconBox on Fedora
From: lee <lee@yun.yagibdah.de>
Gcc: mail.posted
Organization: my virtual residence
--text follows this line--
Hi,

when starting FvwmIconBox with fvwm and then starting xterm, output to the
xterm window does not work, i. e. the window is blank until resized or
when the workspace is switched.

When (re-)starting fvwm without the FvwmIconBox module, xterm works
fine.  Please see [1] for a more detailed reference.

The FvwmIconBox is configured as follows:


DestroyModuleConfig FvwmIconBox: *
############################################################
# Note that icons are shown in the module
#    ONLY if NoIcon commnand is applied.
Style     "*"  NoIcon
# 
############################################################
*FvwmIconBox: IconifiedTitleInvertedRelief
*FvwmIconBox: IconifiedTitleRelief 4
*FvwmIconBox: UseSkipList
*FvwmIconBox: IconBack    black
*FvwmIconBox: IconFore    darkgreen
*FvwmIconBox: IconHiFore  green
*FvwmIconBox: IconHiBack  black
*FvwmIconBox: Back        DarkSlateGray
*FvwmIconBox: Fore        green
*FvwmIconBox: Geometry    4x4+5+915
*FvwmIconBox: MaxIconSize 64x38
*FvwmIconBox: Font        "xft:Liberation:pixelsize=10:Medium"
*FvwmIconBox: SortIcons   IconName
*FvwmIconBox: Padding     4
*FvwmIconBox: Lines       4
*FvwmIconBox: SBWidth     11
*FvwmIconBox: Placement   Left Top
*FvwmIconBox: HideSC Horizontal
*FvwmIconBox: SetWMIconSize
*FvwmIconBox: HilightFocusWin
*FvwmIconBox: Mouse       1       Click           RaiseLower
*FvwmIconBox: Mouse       1       DoubleClick     Iconify
*FvwmIconBox: Mouse       2       Click           Iconify -1, Focus
*FvwmIconBox: Mouse       3       Click           Module FvwmIdent


Is there anything in there that breaks xterm?  Can someone verify this
problem?


[1]: https://bugzilla.redhat.com/show_bug.cgi?id=875305

-- 
Debugger entered--Lisp error: (error "C-c C-c can do nothing useful at
this location")
Comment 20 Miroslav Lichvar 2014-01-21 10:08:13 EST
Assuming the second problem discussed here was an fvwm bug, I'm closing this bug.

Please reopen if it turns out to be an xterm problem. Thanks.

Note You need to log in before you can comment on or make changes to this bug.