Bug 875359 - Review Request: willie - a simple, lightweight, open source, easy-to-use IRC Utility bot, written in Python.
Summary: Review Request: willie - a simple, lightweight, open source, easy-to-use IRC ...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: Package Review
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Fabian Affolter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-11-10 19:34 UTC by Elad Alfassa
Modified: 2014-09-15 12:52 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-02-03 13:27:53 UTC
Type: ---
mail: fedora-review+
gwync: fedora-cvs+


Attachments (Terms of Use)

Description Elad Alfassa 2012-11-10 19:34:57 UTC
Spec URL: http://elad.fedorapeople.org/reviews/willie/willie.spec
SRPM URL: http://elad.fedorapeople.org/reviews/willie/willie-3.1-1.fc18.src.rpm
Description: Willie is a simple, lightweight, open source, easy-to-use IRC Utility bot, written in Python.
It is designed to be easy to use, run and extend.

Fedora Account System Username: elad

Comment 2 bharper 2012-11-15 23:05:45 UTC
Note that I am not a sponsor, but I starting some reviews in an effort to become a packager. 

I did look over your files, I did notice a few things.

$ rpmlint willie-3.1-2.fc18.src.rpm 
willie.src: I: enchant-dictionary-not-found en_US
willie.src: W: summary-not-capitalized C a simple, lightweight, open source, easy-to-use IRC Utility bot, written in Python.
willie.src: W: summary-ended-with-dot C a simple, lightweight, open source, easy-to-use IRC Utility bot, written in Python.
willie.src: E: summary-too-long C a simple, lightweight, open source, easy-to-use IRC Utility bot, written in Python.
willie.src: E: description-line-too-long C Willie is a simple, lightweight, open source, easy-to-use IRC Utility bot, written in Python.
willie.src: W: invalid-license EFLv2
1 packages and 0 specfiles checked; 2 errors, 3 warnings.

Looks like you need to clean up the summary, and take the line break from the description.  Also change the license to 'EFL 2.0'.  

I was able to build a RPM and install it with a fedora-rawhide-x86_64 mock environment.

Comment 4 Fabian Affolter 2012-11-18 10:37:14 UTC
rpmlint complains...

[fab@laptop11 SRPMS]$ rpmlint willie-3.1-3.fc18.src.rpm
willie.src: E: description-line-too-long C Willie is a simple, lightweight, open source, easy-to-use IRC Utility bot, written in Python.
1 packages and 0 specfiles checked; 1 errors, 0 warnings.

[fab@laptop11 noarch]$ rpmlint willie-3.1-3.fc17.noarch.rpm 
willie.noarch: E: description-line-too-long C Willie is a simple, lightweight, open source, easy-to-use IRC Utility bot, written in Python.
willie.noarch: E: non-executable-script /usr/lib/python2.7/site-packages/willie/modules/ai.py 0644L /usr/bin/env
willie.noarch: E: non-executable-script /usr/lib/python2.7/site-packages/willie/modules/countdown.py 0644L /usr/bin/env
willie.noarch: W: wrong-file-end-of-line-encoding /usr/share/doc/willie-3.1/CREDITS
willie.noarch: E: non-executable-script /usr/lib/python2.7/site-packages/willie/bot.py 0644L /usr/bin/env
willie.noarch: E: non-executable-script /usr/lib/python2.7/site-packages/willie
[...]
willie.noarch: E: non-executable-script /usr/lib/python2.7/site-packages/willie/modules/ip.py 0644L /usr/bin/env
willie.noarch: E: non-executable-script /usr/lib/python2.7/site-packages/willie/modules/translate.py 0644L /usr/bin/env
willie.noarch: W: no-manual-page-for-binary willie.py
1 packages and 0 specfiles checked; 52 errors, 3 warnings.

Comment 5 Elad Alfassa 2012-11-18 10:47:25 UTC
rpmlint can keep complaining. All site-packages files are library files - not scripts, the 80-char limit for description line is just an arbitrary and outdated limit.
The only warning which is worth fixing here is removing Windows line ends from CREDITS.

Comment 6 Fabian Affolter 2012-11-18 10:58:57 UTC
So, the shebang in those files is not needed.

Comment 7 Elad Alfassa 2012-11-18 11:21:31 UTC
Will be fixed in a new upstream release later today.

Comment 8 Elad Alfassa 2012-11-18 20:12:16 UTC
New upstream release:

Spec URL: http://elad.fedorapeople.org/reviews/willie/willie.spec
SRPM URL: http://elad.fedorapeople.org/reviews/willie/willie-3.1.1-1.fc18.src.rpm

The only outstanding issue now is the fact that willie.py doesn't have a manpage, and there isn't much I can do about it until we make a manual page upstream, and that'll have to wait at least until the next maintenance release. All documentation regarding using this bot is in the upstream wiki.

Comment 9 Elad Alfassa 2012-11-19 20:48:36 UTC
New upstream release (yes, again)

Spec URL: http://elad.fedorapeople.org/reviews/willie/willie.spec
SRPM URL: http://elad.fedorapeople.org/reviews/willie/willie-3.1.2-1.fc18.src.rpm

Comment 10 Fabian Affolter 2012-11-20 17:17:34 UTC
Perphaps a new release appears before I start with the review. Could you please use python2-devel instead of python-devel? As far as I remember the Python guidelines say so. Thanks.

Comment 11 Elad Alfassa 2012-11-20 18:13:37 UTC
Sure. And I don't think upstream will have a new release soon.

Spec URL: http://elad.fedorapeople.org/reviews/willie/willie.spec
SRPM URL: http://elad.fedorapeople.org/reviews/willie/willie-3.1.2-2.fc18.src.rpm

Comment 12 Fabian Affolter 2012-11-25 21:35:07 UTC
Package Review
==============

Key:
[x] = Pass
[!] = Fail
[-] = Not applicable
[?] = Not evaluated
[ ] = Manual review needed



===== MUST items =====

Generic:
[x]: Package is licensed with an open-source compatible license and meets
     other legal requirements as defined in the legal section of Packaging
     Guidelines.
[x]: Package successfully compiles and builds into binary rpms on at least one
     supported primary architecture.
[-]: %build honors applicable compiler flags or justifies otherwise.
[x]: All build dependencies are listed in BuildRequires, except for any that
     are listed in the exceptions section of Packaging Guidelines.
[x]: Package contains no bundled libraries.
[x]: Changelog in prescribed format.
[!]: Package does not run rm -rf %{buildroot} (or $RPM_BUILD_ROOT) at the
     beginning of %install.
     Note: rm -rf %{buildroot} present but not required
[x]: Sources contain only permissible code or content.
[x]: Each %files section contains %defattr if rpm < 4.4
[x]: Macros in Summary, %description expandable at SRPM build time.
[-]: Package contains desktop file if it is a GUI application.
[-]: Development files must be in a -devel package
[x]: Package requires other packages for directories it uses.
[x]: Package uses nothing in %doc for runtime.
[x]: Package is not known to require ExcludeArch.
[x]: Package does not contain duplicates in %files.
[x]: Permissions on files are set properly.
[x]: Package complies to the Packaging Guidelines
[x]: Spec file lacks Packager, Vendor, PreReq tags.
[x]: If (and only if) the source package includes the text of the license(s)
     in its own file, then that file, containing the text of the license(s)
     for the package is included in %doc.
[x]: License field in the package spec file matches the actual license.
     Note: Checking patched sources after %prep for licenses. Licenses found:
     "Unknown or generated". 1 files have unknown license. Detailed output of
     licensecheck in /home/fab/reviews/875359-willie/licensecheck.txt
[x]: Package consistently uses macro is (instead of hard-coded directory
     names).
[x]: Package is named using only allowed ASCII characters.
[x]: Package is named according to the Package Naming Guidelines.
[x]: Package does not generate any conflict.
     Note: Package contains no Conflicts: tag(s)
[x]: Package do not use a name that already exist
[x]: Package obeys FHS, except libexecdir and /usr/target.
[-]: If the package is a rename of another package, proper Obsoletes and
     Provides are present.
[x]: Package must own all directories that it creates.
[x]: Package does not own files or directories owned by other packages.
[x]: Package installs properly.
[x]: Package is not relocatable.
[x]: Requires correct, justified where necessary.
[x]: CheckResultdir
[x]: Rpmlint is run on all rpms the build produces.
     Note: There are rpmlint messages (see attachment).
[x]: Sources used to build the package match the upstream source, as provided
     in the spec URL.
[x]: Spec file is legible and written in American English.
[x]: Spec file name must match the spec package %{name}, in the format
     %{name}.spec.
[-]: Package contains systemd file(s) if in need.
[x]: File names are valid UTF-8.
[-]: Large documentation must go in a -doc subpackage.
     Note: Documentation size is 215040 bytes in 25 files.
[x]: Packages must not store files under /srv, /opt or /usr/local

Python:
[x]: Package contains BR: python2-devel or python3-devel
[x]: Binary eggs must be removed in %prep
[x]: Python eggs must not download any dependencies during the build process.
[x]: A package which is used by another package via an egg interface should
     provide egg info.
[x]: Package meets the Packaging Guidelines::Python

===== SHOULD items =====

Generic:
[x]: Reviewer should test that the package builds in mock.
[x]: Buildroot is not present
[x]: Package has no %clean section with rm -rf %{buildroot} (or
     $RPM_BUILD_ROOT)
[x]: If the source package does not include license text(s) as a separate file
     from upstream, the packager SHOULD query upstream to include it.
[x]: Dist tag is present.
[x]: No file requires outside of /etc, /bin, /sbin, /usr/bin, /usr/sbin.
[x]: Final provides and requires are sane (rpm -q --provides and rpm -q
     --requires).
[x]: Package functions as described.
[x]: Latest version is packaged.
[x]: Package does not include license text files separate from upstream.
[x]: The placement of pkgconfig(.pc) files are correct.
[x]: SourceX tarball generation or download is documented.
[x]: SourceX / PatchY prefixed with %{name}.
[x]: SourceX is a working URL.
[-]: Description and summary sections in the package spec file contains
     translations for supported Non-English languages, if available.
[x]: Package should compile and build into binary rpms on all supported
     architectures.
[-]: %check is present and all tests pass.
[-]: Packages should try to preserve timestamps of original installed files.
[x]: Spec use %global instead of %define.

===== EXTRA items =====

Generic:
[x]: Rpmlint is run on all installed packages.
     Note: There are rpmlint messages (see attachment).
[x]: Spec file according to URL is the same as in SRPM.
[x]: Large data in /usr/share should live in a noarch subpackage if package is
     arched.


Rpmlint
-------
Checking: willie-3.1.2-2.fc17.noarch.rpm
          willie-3.1.2-2.fc17.src.rpm
willie.noarch: W: no-manual-page-for-binary willie.py
2 packages and 0 specfiles checked; 0 errors, 1 warnings.




Rpmlint (installed packages)
----------------------------
# rpmlint willie
willie.noarch: W: no-manual-page-for-binary willie.py
1 packages and 0 specfiles checked; 0 errors, 1 warnings.
# echo 'rpmlint-done:'



Requires
--------
willie-3.1.2-2.fc17.noarch.rpm (rpmlib, GLIBC filtered):
    
    /usr/bin/python  
    MySQL-python  
    pyOpenSSL  
    python(abi) = 2.7
    python-enchant  
    python-feedparser  
    python-lxml  
    python-praw  
    pytz  



Provides
--------
willie-3.1.2-2.fc17.noarch.rpm:
    
    willie = 3.1.2-2.fc17



MD5-sum check
-------------
http://willie.dftba.net/files/willie-3.1.2.tar.gz :
  CHECKSUM(SHA256) this package     : 15ba641f1aec04a130a673dd2ac5e925b2a532b6e823c67e7dc393ad5e27aae1
  CHECKSUM(SHA256) upstream package : 15ba641f1aec04a130a673dd2ac5e925b2a532b6e823c67e7dc393ad5e27aae1


Generated by fedora-review 0.3.1 (b71abc1) last change: 2012-10-16
Buildroot used: fedora-17-x86_64
Command line :/usr/bin/fedora-review -b 875359

Please remove 'rm -rf $RPM_BUILD_ROOT' in the %install section before scm import.

Package APPROVED

Comment 13 Elad Alfassa 2012-11-25 21:39:57 UTC
New Package SCM Request
=======================
Package Name: willie
Short Description: a simple, lightweight, open source, easy-to-use IRC Utility bot, written in Python
Owners: elad
Branches: f17 f18
InitialCC:

Comment 14 Gwyn Ciesla 2012-11-26 13:08:56 UTC
Git done (by process-git-requests).

Comment 15 Fedora Update System 2012-11-26 13:29:24 UTC
willie-3.1.2-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/willie-3.1.2-2.fc17

Comment 16 Fedora Update System 2012-11-26 13:36:15 UTC
willie-3.1.2-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/willie-3.1.2-2.fc18

Comment 17 Fedora Update System 2012-11-27 09:48:09 UTC
willie-3.1.2-2.fc18 has been pushed to the Fedora 18 testing repository.

Comment 18 Fedora Update System 2013-01-25 17:53:49 UTC
willie-3.1.3-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/willie-3.1.3-1.fc17

Comment 19 Fedora Update System 2013-01-25 17:54:44 UTC
willie-3.1.3-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/willie-3.1.3-1.fc18

Comment 20 Fedora Update System 2013-02-03 13:27:55 UTC
willie-3.1.3-1.fc18 has been pushed to the Fedora 18 stable repository.

Comment 21 Fedora Update System 2013-02-03 13:48:53 UTC
willie-3.1.3-1.fc17 has been pushed to the Fedora 17 stable repository.

Comment 22 Elad Alfassa 2014-09-14 19:42:07 UTC
Package Change Request
======================
Package Name: willie
New Branches: epel7
Owners: elad embolalia

Comment 23 Gwyn Ciesla 2014-09-15 12:07:09 UTC
Git done (by process-git-requests).


Note You need to log in before you can comment on or make changes to this bug.