Bug 875423 - SELinux is preventing /usr/sbin/ifconfig from 'search' accesses on the directory net.
SELinux is preventing /usr/sbin/ifconfig from 'search' accesses on the direct...
Status: CLOSED DUPLICATE of bug 875424
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
17
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:e8d7c3a8c132a89b6f3a880bf7c...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-11 00:35 EST by Anthony Vidas
Modified: 2012-11-12 08:42 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-12 08:42:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: type (9 bytes, text/plain)
2012-11-11 00:35 EST, Anthony Vidas
no flags Details
File: hashmarkername (14 bytes, text/plain)
2012-11-11 00:35 EST, Anthony Vidas
no flags Details

  None (edit)
Description Anthony Vidas 2012-11-11 00:35:13 EST
Additional info:
libreport version: 2.0.18
kernel:         3.6.6-1.fc17.i686

description:
:SELinux is preventing /usr/sbin/ifconfig from 'search' accesses on the directory net.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that ifconfig should be allowed search access on the net directory by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep ifconfig /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:colord_t:s0
:Target Context                system_u:object_r:sysctl_net_t:s0
:Target Objects                net [ dir ]
:Source                        ifconfig
:Source Path                   /usr/sbin/ifconfig
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           net-tools-1.60-138.20120702git.fc17.i686
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-156.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Permissive
:Host Name                     (removed)
:Platform                      Linux (removed) 3.6.6-1.fc17.i686 #1 SMP Mon Nov 5
:                              22:11:18 UTC 2012 i686 i686
:Alert Count                   2
:First Seen                    2012-11-11 00:34:17 EST
:Last Seen                     2012-11-11 00:34:25 EST
:Local ID                      b909112b-ed87-4afd-bd64-2bcaa585454b
:
:Raw Audit Messages
:type=AVC msg=audit(1352612065.9:71): avc:  denied  { search } for  pid=1557 comm="ifconfig" name="net" dev="proc" ino=9373 scontext=system_u:system_r:colord_t:s0 tcontext=system_u:object_r:sysctl_net_t:s0 tclass=dir
:
:
:type=SYSCALL msg=audit(1352612065.9:71): arch=i386 syscall=access per=400000 success=no exit=ENOENT a0=805539b a1=4 a2=8059520 a3=8059320 items=0 ppid=1556 pid=1557 auid=4294967295 uid=997 gid=994 euid=997 suid=997 fsuid=997 egid=994 sgid=994 fsgid=994 tty=(none) ses=4294967295 comm=ifconfig exe=/usr/sbin/ifconfig subj=system_u:system_r:colord_t:s0 key=(null)
:
:Hash: ifconfig,colord_t,sysctl_net_t,dir,search
:
:audit2allow
:
:#============= colord_t ==============
:allow colord_t sysctl_net_t:dir search;
:
:audit2allow -R
:
:#============= colord_t ==============
:allow colord_t sysctl_net_t:dir search;
:


Potential duplicate bug: 741753
Comment 1 Anthony Vidas 2012-11-11 00:35:37 EST
Created attachment 642582 [details]
File: type
Comment 2 Anthony Vidas 2012-11-11 00:35:39 EST
Created attachment 642583 [details]
File: hashmarkername
Comment 3 Miroslav Grepl 2012-11-12 08:42:47 EST

*** This bug has been marked as a duplicate of bug 875424 ***

Note You need to log in before you can comment on or make changes to this bug.