Bug 875520 - <procedure> blocks do not have <xref> anchors set in PDFs
<procedure> blocks do not have <xref> anchors set in PDFs
Status: CLOSED CURRENTRELEASE
Product: Publican
Classification: Community
Component: publican (Show other bugs)
3.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Fearn
Ruediger Landmann
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-11 16:29 EST by Jared MORGAN
Modified: 2015-08-09 21:22 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-11 21:03:40 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
View Save Time: Import and Export Controller Maps to see the fault with the procedure linking. (239.64 KB, application/pdf)
2012-11-11 16:29 EST, Jared MORGAN
no flags Details

  None (edit)
Description Jared MORGAN 2012-11-11 16:29:17 EST
Created attachment 643063 [details]
View Save Time: Import and Export Controller Maps to see the fault with the procedure linking.

Description of problem:

Procedure blocks are not being linked to in the PDF, and can not be clicked to jump to the correct point in the document.

The xref is formatted correctly, but there is no link logic behind it.

Version-Release number of selected component (if applicable):

Publican 3

How reproducible:

100%

Steps to Reproduce:
1. Check out https://github.com/jaredmorgs/USB_BT_Joystick_Center/
2. Build the document to PDF (or view attached)
3. Open the document and go to the "Save Time: Import and Export Controller Maps" section.
4. Try clicking on the Procedure links.

  
Actual results:

Links do not resolve to the procedures.

Expected results:

Links resolve, and jump you to the correct location.
Comment 1 Ruediger Landmann 2012-11-11 17:43:20 EST
Which version of Publican and which PDF reader (and version) did this fail on?

Works for me with publican-3.0-0.fc17.t223.noarch and:

* Adobe Reader 9.3.0
* Evince 3.4.0
* XPDF 3.03

However, doesn't seem to work on:

* Okular 0.15.2 

but since no links of any kind of all seem to be working in Okular right now, I think that's not our fault...
Comment 2 Ruediger Landmann 2012-11-11 21:03:40 EST
[closing after discussion with reporter; old build]

Note You need to log in before you can comment on or make changes to this bug.