This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 875537 - [abrt] gnome-shell-3.6.1-3.fc18: g_return_if_fail_warning: Process /usr/bin/gnome-shell was killed by signal 6 (SIGABRT)
[abrt] gnome-shell-3.6.1-3.fc18: g_return_if_fail_warning: Process /usr/bin/g...
Status: CLOSED DUPLICATE of bug 810040
Product: Fedora
Classification: Fedora
Component: gnome-shell (Show other bugs)
18
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Owen Taylor
Fedora Extras Quality Assurance
abrt_hash:acc454d25b467cee722b026ed64...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-11 19:31 EST by Samuel Greenfeld
Modified: 2012-11-12 13:00 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-12 13:00:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: environ (2.35 KB, text/plain)
2012-11-11 19:31 EST, Samuel Greenfeld
no flags Details
File: limits (1.29 KB, text/plain)
2012-11-11 19:31 EST, Samuel Greenfeld
no flags Details
File: backtrace (23.29 KB, text/plain)
2012-11-11 19:31 EST, Samuel Greenfeld
no flags Details
File: cgroup (127 bytes, text/plain)
2012-11-11 19:31 EST, Samuel Greenfeld
no flags Details
File: executable (20 bytes, text/plain)
2012-11-11 19:31 EST, Samuel Greenfeld
no flags Details
File: maps (38.28 KB, text/plain)
2012-11-11 19:32 EST, Samuel Greenfeld
no flags Details
File: dso_list (13.08 KB, text/plain)
2012-11-11 19:32 EST, Samuel Greenfeld
no flags Details
File: proc_pid_status (784 bytes, text/plain)
2012-11-11 19:32 EST, Samuel Greenfeld
no flags Details
File: var_log_messages (785 bytes, text/plain)
2012-11-11 19:32 EST, Samuel Greenfeld
no flags Details
File: open_fds (516 bytes, text/plain)
2012-11-11 19:32 EST, Samuel Greenfeld
no flags Details
gdm :0-greeter.log with errors/exceptions (4.70 KB, text/plain)
2012-11-11 21:43 EST, Samuel Greenfeld
no flags Details

  None (edit)
Description Samuel Greenfeld 2012-11-11 19:31:46 EST
Description of problem:
 1. Install Fedora 18 Beta TC8 with GNOME desktop+development utilities on VMware ESXi 5.0 server (use RHEL 6 container for chosen architecture; I've done both x86 and x64).
 2. As soon as you reboot and finish the final firstboot steps you will be told "Oh No! Something has gone wrong!" similar to #860886.  The logs indicate that gnome-shell.desktop kept respawning to the point something stops trying to restart it.

This issue has not been seen with a F18 Alpha system upgraded over time (which should have pretty much the same RPMs).

The issue seems to be related to permissions & GNOME.  Using KDM/KDE does not hit the "Oh no" problem; starting GNOME via "startx" as root works but not as a normal user (who also sees "Oh no!").

If this is an unrelated crash reported by ABRT to the above I apologize in advance.


Version-Release number of selected component:
gnome-shell-3.6.1-3.fc18

Additional info:
libreport version: 2.0.18
abrt_version:   2.0.18
backtrace_rating: 4
cmdline:        /usr/bin/gnome-shell
crash_function: g_return_if_fail_warning
kernel:         3.6.6-3.fc18.i686.PAE

truncated backtrace:
:Thread no. 1 (10 frames)
: #5 g_return_if_fail_warning at gmessages.c:1012
: #6 g_str_has_prefix at gstrfuncs.c:2780
: #7 default_log_handler at main.c:272
: #10 dconf_shm_open at dconf-shm.c:63
: #11 dconf_engine_source_user_reopen at dconf-engine-source-user.c:76
: #12 dconf_engine_source_refresh at dconf-engine-source.c:57
: #13 dconf_engine_acquire_sources at dconf-engine.c:201
: #14 dconf_engine_get_state at dconf-engine.c:311
: #15 dconf_engine_watch_fast at dconf-engine.c:762
: #16 g_settings_backend_subscribe at gsettingsbackend.c:886

Potential duplicate bug: 841844
Comment 1 Samuel Greenfeld 2012-11-11 19:31:49 EST
Created attachment 643117 [details]
File: environ
Comment 2 Samuel Greenfeld 2012-11-11 19:31:52 EST
Created attachment 643118 [details]
File: limits
Comment 3 Samuel Greenfeld 2012-11-11 19:31:55 EST
Created attachment 643119 [details]
File: backtrace
Comment 4 Samuel Greenfeld 2012-11-11 19:31:56 EST
Created attachment 643120 [details]
File: cgroup
Comment 5 Samuel Greenfeld 2012-11-11 19:31:58 EST
Created attachment 643121 [details]
File: executable
Comment 6 Samuel Greenfeld 2012-11-11 19:32:01 EST
Created attachment 643122 [details]
File: maps
Comment 7 Samuel Greenfeld 2012-11-11 19:32:03 EST
Created attachment 643123 [details]
File: dso_list
Comment 8 Samuel Greenfeld 2012-11-11 19:32:05 EST
Created attachment 643124 [details]
File: proc_pid_status
Comment 9 Samuel Greenfeld 2012-11-11 19:32:07 EST
Created attachment 643125 [details]
File: var_log_messages
Comment 10 Samuel Greenfeld 2012-11-11 19:32:09 EST
Created attachment 643126 [details]
File: open_fds
Comment 11 Samuel Greenfeld 2012-11-11 21:43:08 EST
Created attachment 643163 [details]
gdm :0-greeter.log with errors/exceptions
Comment 12 Samuel Greenfeld 2012-11-12 13:00:28 EST
Watching the blocker review meeting today I discovered this is a duplicate of #810040, and is dependent on if there is a USB bus enabled for the VM or not (which ESXi does not provide by default).

*** This bug has been marked as a duplicate of bug 810040 ***

Note You need to log in before you can comment on or make changes to this bug.