Bug 875644 - Kickstart upgrade doesn't reboot to upgraded system
Summary: Kickstart upgrade doesn't reboot to upgraded system
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda (Show other bugs)
(Show other bugs)
Version: 6.4
Hardware: s390x Linux
high
high
Target Milestone: rc
: ---
Assignee: Samantha N. Bueno
QA Contact: Release Test Team
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 960065 841211
TreeView+ depends on / blocked
 
Reported: 2012-11-12 09:35 UTC by Jan Stodola
Modified: 2015-09-28 02:26 UTC (History)
2 users (show)

Fixed In Version: anaconda-13.21.210-1
Doc Type: Bug Fix
Doc Text:
Cause: Anaconda could not set the boot device since it was not set properly. Consequence: Manual reboot of the system was required upon completion of an upgrade. Fix: Proper support for bootloader upgrades was implemented for s390x. Result: Manual and kickstart upgrades on s390x will detect the correct boot device and reboot the system after upgrading.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-21 09:55:10 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda.program.log (28.78 KB, text/plain)
2013-09-09 11:32 UTC, Jan Stodola
no flags Details
anaconda.storage.log (95.46 KB, text/plain)
2013-09-09 11:32 UTC, Jan Stodola
no flags Details
anaconda.yum.log (2.30 KB, text/plain)
2013-09-09 11:32 UTC, Jan Stodola
no flags Details
upgrade.log.syslog (200 bytes, text/plain)
2013-09-09 11:32 UTC, Jan Stodola
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1588 normal SHIPPED_LIVE anaconda bug fix and enhancement update 2013-11-21 00:40:22 UTC

Description Jan Stodola 2012-11-12 09:35:18 UTC
Description of problem:
When kickstart upgrade is performed on s390x, anaconda shuts down the system instead of rebooting although "reboot" command is present in kickstart.

Version-Release number of selected component (if applicable):
anaconda-13.21.183-1.el6

How reproducible:
always

Steps to Reproduce:
1. install previous version of RHEL. Following partitioning was used:
bootloader --location=mbr
zerombr
clearpart --all --initlabel
part /boot --asprimary --size=500 --label=boot
part swap --fstype=swap --recommended --label=swap
part / --grow --size=2048

2. prepare kickstart for upgrade - make sure that "reboot" command is present:
upgrade
lang en_US.UTF-8
keyboard us
reboot
cmdline
bootloader --upgrade

3. run kickstart upgrade
  
Actual results:
system is halted after upgrade

Expected results:
system is rebooted after upgrade

Additional info:
When running manual upgrade, anaconda successfully reboots at the end of the upgrade. I'm able to reproduce only on s390x, x86_64 works as expected.

Comment 5 Samantha N. Bueno 2012-12-20 20:29:41 UTC
Pushing this off to RHEL6.5 planning since it's not a 6.4 blocker.

Comment 7 RHEL Product and Program Management 2013-05-06 21:16:16 UTC
This request was evaluated by Red Hat Product Management for
inclusion in a Red Hat Enterprise Linux release.  Product
Management has requested further review of this request by
Red Hat Engineering, for potential inclusion in a Red Hat
Enterprise Linux release for currently deployed products.
This request is not yet committed for inclusion in a release.

Comment 12 Samantha N. Bueno 2013-08-07 13:48:52 UTC
Patch posted for review.

Comment 13 Samantha N. Bueno 2013-08-07 21:14:20 UTC
Patch pushed, commit 530820d10f2d4d47095ff33cd01bc85ae835f3e7 in rhel6-branch.

Comment 15 Jan Stodola 2013-09-09 11:29:33 UTC
Retested with anaconda-13.21.204-1.el6, but reboot is still not happening - system shuts down after upgrade. 

From anaconda.log:
...
11:27:33,817 INFO    : Unable to set reIPL device to None: cannot concatenate 'str' and 'NoneType' objects
11:27:33,821 INFO    : reIPL configuration failed => halt
11:27:33,823 INFO    : leaving (1) step reipl

Logs from the upgrade will be attached. Moving to ASSIGNED.

Comment 16 Jan Stodola 2013-09-09 11:32:19 UTC
Created attachment 795580 [details]
anaconda.log

Comment 17 Jan Stodola 2013-09-09 11:32:25 UTC
Created attachment 795581 [details]
anaconda.program.log

Comment 18 Jan Stodola 2013-09-09 11:32:30 UTC
Created attachment 795582 [details]
anaconda.storage.log

Comment 19 Jan Stodola 2013-09-09 11:32:34 UTC
Created attachment 795583 [details]
anaconda.syslog

Comment 20 Jan Stodola 2013-09-09 11:32:39 UTC
Created attachment 795584 [details]
anaconda.yum.log

Comment 21 Jan Stodola 2013-09-09 11:32:43 UTC
Created attachment 795585 [details]
upgrade.log.syslog

Comment 23 Samantha N. Bueno 2013-10-04 14:06:56 UTC
Patch posted for review.

Comment 24 Samantha N. Bueno 2013-10-07 13:47:13 UTC
Patch pushed, commit 5b136c01148b8d78fa4d779d05704cef9f582813.

Comment 26 Jan Stodola 2013-10-10 11:24:59 UTC
Anaconda upgrade using kickstart rebooted at the end of the upgrade, system booted correctly. Retested with anaconda-13.21.211-1.el6, compose RHEL6.5-20131009.0.

Moving to VERIFIED.

Comment 28 errata-xmlrpc 2013-11-21 09:55:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1588.html


Note You need to log in before you can comment on or make changes to this bug.