Bug 875727 - Extract of "--strip-components" archive fails on file matching with "Not found in archive"
Summary: Extract of "--strip-components" archive fails on file matching with "Not foun...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: tar
Version: 6.4
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: ---
Assignee: Pavel Raiskup
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
Depends On:
Blocks: 881827
TreeView+ depends on / blocked
 
Reported: 2012-11-12 13:26 UTC by David Kutálek
Modified: 2013-02-21 11:04 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-02-21 11:04:01 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:0489 normal SHIPPED_LIVE tar bug fix update 2013-02-20 21:06:21 UTC

Description David Kutálek 2012-11-12 13:26:49 UTC
Description of problem:

tar x -v -J -f ./sosreport-qaredhat.com-20121112055222-56b6.tar.xz --strip-components=2 '*/sos_logs/sosreport-plugin-errors.txt'
tar: */sos_logs/sosreport-plugin-errors.txt: Not found in archive
tar: Exiting with failure status due to previous errors

Without --strip-components file matching works.

This is a regression from 6.3, probably introduced by fix of bug 841308.

Version-Release number of selected component (if applicable):

tar-1.23-9.el6.ppc64 

How reproducible:

Always using command above

Steps to Reproduce:
1. use --strip-components together with file matching for extraction
2.
3.
  
Actual results:

Faile matching fails

Expected results:

File matching should work

Additional info:

Comment 3 Pavel Raiskup 2012-11-12 13:31:22 UTC
(In reply to comment #1)
> Upstream fix:
> http://git.savannah.gnu.org/cgit/tar.git/commit/
> ?id=28e91b48f680a6fab90ee39145123647345f385f

Yes, I have prepared patch already.

This bug is covered in upstream testsuite.

Comment 10 Pavel Raiskup 2012-11-14 08:12:33 UTC
Relevant test in upstream testsuite:

>       ...
>       30: mode of extracted directories                   ok
>       31: extracting symlinks to a read-only dir          ok
>       32: restoring mode on existing directory            ok
> ===>  33: name matching/transformation ordering           ok
>       34: keep-old-files                                  ok
>       35: skip-old-files                                  ok
>       36: single-volume label                             ok
>       ....

Comment 15 errata-xmlrpc 2013-02-21 11:04:01 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0489.html


Note You need to log in before you can comment on or make changes to this bug.