Bug 875778 - lxc-0.9.0 is available
Summary: lxc-0.9.0 is available
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: lxc
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Thomas Moschny
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-11-12 15:02 UTC by Upstream Release Monitoring
Modified: 2013-12-14 03:27 UTC (History)
11 users (show)

Fixed In Version: lxc-0.9.0-2.fc20
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-12-05 03:22:48 UTC
Type: ---


Attachments (Terms of Use)
spec file for 0.9.0 (5.38 KB, application/octet-stream)
2013-03-22 13:47 UTC, Daniele Viganò
no flags Details
Patch to lxc-fedora which adds lxc.autodev =1 (669 bytes, patch)
2013-04-19 17:11 UTC, Enrique
no flags Details | Diff

Description Upstream Release Monitoring 2012-11-12 15:02:24 UTC
Latest upstream release: 0.8.0
Current version in Fedora Rawhide: 0.7.5
URL: http://sourceforge.net/api/file/index/project-name/lxc/mtime/desc/limit/100/rss

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_release_monitoring

Comment 1 Haïkel Guémar 2012-11-12 19:04:33 UTC
@Thomas: are you taking care of this ?

Comment 2 Thomas Moschny 2012-11-20 13:23:17 UTC
(In reply to comment #1)
> @Thomas: are you taking care of this ?

Yes, will do. Was on a business trip.

Comment 3 Vedran Miletić 2012-12-24 00:33:10 UTC
Any ETA on this? Any chance on getting it updated before F18 is released?

Comment 4 Thomas Moschny 2012-12-27 11:38:32 UTC
Yes, should be ready until then.

Comment 5 Vedran Miletić 2012-12-27 16:48:22 UTC
Great.

Comment 6 David Ward 2013-02-11 02:59:59 UTC
Please update to 0.8.0 in Fedora 17/18 as soon as possible.  The previous versions have a systemd incompatibility.

Comment 7 Thomas Moschny 2013-02-15 21:31:07 UTC
I have built lxc 0.8.0 in rawhide now.

Alas, I also tested this version on my F18 machine and there are still problems with systemd. See for example http://sourceforge.net/tracker/?func=detail&aid=3559833&group_id=163076&atid=826303.

So, I am not sure whether it is worth the effort creating F17 and F18 packages that also will not work properly.

According to upstream, 0.9.0~alpha3 is soon to come, maybe we should wait for that.

Comment 8 David Ward 2013-02-17 00:47:05 UTC
The bug you referenced actually has an end user workaround -- change the existing filesystem mounts to private before starting any containers:

mount --make-rprivate /

(A more complete solution to dealing with shared mounts in lxc is being worked out on the mailing list.)  I am able to use lxc 0.9.0.alpha2 successfully on Fedora 18 with the workaround above.

However, lxc 0.7.5 and earlier have some more serious problems with cgroup handling which manifest when using systemd, and there is no end user workaround.  See for example this fix to upstream that I made before 0.8.0:  http://lxc.git.sourceforge.net/git/gitweb.cgi?p=lxc/lxc;a=commit;h=1d39a0658370ac104825e796bf90bb96ae0b7027

Since the packages in the Fedora 17/18 repo would seem to be unusable to anyone, my suggestion would be to go ahead and update them to a version that at least operates correctly when using a known workaround.  (Or in the worse case, this will at least help identify any other bugs that may still exist, so they can get fixed sooner rather than later...?)

Comment 9 Arun S A G 2013-03-01 15:00:22 UTC
Please update  LXC. I am unable to anything with the current version of LXC shipped with Fedora.

Comment 11 Fedora Update System 2013-03-02 15:15:01 UTC
lxc-0.8.0-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/lxc-0.8.0-2.fc18

Comment 12 Fedora Update System 2013-03-02 15:15:27 UTC
lxc-0.8.0-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/lxc-0.8.0-2.fc17

Comment 13 Fedora Update System 2013-03-03 22:26:20 UTC
Package lxc-0.8.0-2.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing lxc-0.8.0-2.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-3330/lxc-0.8.0-2.fc17
then log in and leave karma (feedback).

Comment 14 Arun S A G 2013-03-04 05:46:18 UTC
(In reply to comment #13)
> Package lxc-0.8.0-2.fc17:
> * should fix your issue,
> * was pushed to the Fedora 17 testing repository,
> * should be available at your local mirror within two days.
> Update it with:
> # su -c 'yum update --enablerepo=updates-testing lxc-0.8.0-2.fc17'
> as soon as you are able to.
> Please go to the following url:
> https://admin.fedoraproject.org/updates/FEDORA-2013-3330/lxc-0.8.0-2.fc17
> then log in and leave karma (feedback).

Still doesn't solve the pivot_root problem


lxc-start: Invalid argument - pivot_root syscall failed
lxc-start: failed to setup pivot root
lxc-start: failed to set rootfs for 'test.lxc.test.com'
lxc-start: failed to setup the container
lxc-start: invalid sequence number 1. expected 2
lxc-start: failed to spawn 'test.lxc.test.com'

Comment 15 Thomas Moschny 2013-03-04 10:29:39 UTC
(In reply to comment #14)
> Still doesn't solve the pivot_root problem
> 
> 
> lxc-start: Invalid argument - pivot_root syscall failed
> lxc-start: failed to setup pivot root
> lxc-start: failed to set rootfs for 'test.lxc.test.com'
> lxc-start: failed to setup the container
> lxc-start: invalid sequence number 1. expected 2
> lxc-start: failed to spawn 'test.lxc.test.com'

Did you try the work around mentioned earlier (comment #8) in this ticket?

mount --make-rprivate /

Comment 16 Arun S A G 2013-03-04 11:46:47 UTC
After doing mount --make-rprivate /. Things seems to work! Thanks.

Comment 17 Arun S A G 2013-03-04 12:31:52 UTC
Also 0.9.0 alpha3 doesn't require any workarounds for LXC to work. Can we backport related patches to 0.8.0?

Comment 18 Thomas Moschny 2013-03-12 17:14:43 UTC
(In reply to comment #17)
> Also 0.9.0 alpha3 doesn't require any workarounds for LXC to work. Can we
> backport related patches to 0.8.0?

We could, but I am a bit hesitant to do that, as I can not really oversee side-effects this might have. Also, 0.9.0 now seems really round the corner.

Comment 19 Daniele Viganò 2013-03-22 13:44:54 UTC
I'm testing lxc-0.9.0rc1

Attached you can find the update spec file:

- Update to 0.9.0rc1.
- Update spec file to new upstream chages (ex. /etc/lxc/default, /usr/share/lxc/hooks)
- Add rsync as dependency for Ubuntu and Debian templates.
- Add docbook2X as build requirement.

The RPMS and SRPM for Fedora 17 x86_64 are here:
http://daniele.vigano.me/rpms/lxc-0.9.0rc1/

Comment 20 Daniele Viganò 2013-03-22 13:47:37 UTC
Created attachment 714550 [details]
spec file for 0.9.0

Comment 21 Thomas Moschny 2013-04-08 18:26:15 UTC
Updated lxc 0.9.0 packages are here:
  http://thm.fedorapeople.org/lxc/
for all active Fedora branches, plus EPEL-6.

Please test!

Any comments are appreciated. If there are no objections, I will create official updates.

Comment 22 Enrique 2013-04-15 16:27:31 UTC
 Hi,
 I have installed the F18 packages found here http://thm.fedorapeople.org/lxc/fedora-18/x86_64/ and tried to create a F18 guest with:

lxc-create -t fedora -n test -- -R 18

  At the end of the command I get some warnings:
 warning: Failed to read auxiliary vector, /proc not mounted?

 Also, when running lxc-start -n test I don't get any output, the console got frozen..

 In principle this should be reproducible, since I used a fresh installation of F18 x86_64.

Comment 23 Enrique 2013-04-19 17:10:26 UTC
 Hi,
 
 I have figured out that the problem was a missing option in the config:
lxc.autodev = 1

 This can be fixed in the lxc-fedora template. I have attached a patch that fixes that (autodev.patch). The patch is actually only a subset of a patch already proposed in the lxc-devel mailing list:

http://sourceforge.net/mailarchive/forum.php?thread_name=1365372287.19430.26.camel%40canyon.wittsend.com&forum_name=lxc-devel

Comment 24 Enrique 2013-04-19 17:11:30 UTC
Created attachment 737699 [details]
Patch to lxc-fedora which adds lxc.autodev =1

Comment 25 Fabian Affolter 2013-05-01 09:28:25 UTC
(In reply to comment #21)
> Please test!

0.9.0 works for me.

Well, the template is still buggy. Meaning not able to create Rawhide containers and set the root password but those are upstream issue.

Comment 26 Daniele Viganò 2013-05-01 09:31:13 UTC
(In reply to comment #25)
> (In reply to comment #21)
> > Please test!
> 
> 0.9.0 works for me.
> 
> Well, the template is still buggy. Meaning not able to create Rawhide
> containers and set the root password but those are upstream issue.

Also working well for me.
About the template I'm working on a template for the latest Fedora: https://gist.github.com/daniviga/4682880#file-bootstrap-fedora18-sh

Comment 27 Jeff Peeler 2013-06-02 02:17:33 UTC
(In reply to Thomas Moschny from comment #21)
> Updated lxc 0.9.0 packages are here:
>   http://thm.fedorapeople.org/lxc/
> for all active Fedora branches, plus EPEL-6.
> 
> Please test!
> 
> Any comments are appreciated. If there are no objections, I will create
> official updates.

I think checking that /usr/lib64/lxc/rootfs is not currently mounted would be a welcome addition. (I may have done something funky, but I think it caused the yum upgrade to fail.)

Comment 28 Daniele Viganò 2013-06-19 07:26:36 UTC
For me the LXC 0.9.0 packages provided by Thomas Moschny are working well also on Fedora 19 beta.

Comment 29 Enrique 2013-07-04 08:14:05 UTC
 
 Hi,

 I have tried to create a container of the fresh released F19 on a F18 host with the lxc-0.9.0-1.fc18.x86_64 package but it fails:

 Fetching from http://ftp.uni-erlangen.de/pub/Linux/MIRROR.fedora/core/development/19/x86_64/os//Packages/f/fedora-release-19-1.noarch.rpm
.....
curl: (22) The requested URL returned error: 404 Not Found
Failed to download fedora release rpm
.......
No repomd file
Error: File /var/cache/lxc/fedora/x86_64/19/partial/var/cache/yum/x86_64/$releasever/fedora/metalink.xml does not exist
Failed to download the rootfs, aborting.
...

 It looks like it is trying to download fedora-release-19-1.noarch.rpm, but the correct version which is in the repositories is fedora-release-19-2.noarch.rpm.

 Regards,
 Enrique

Comment 30 Enrique 2013-08-08 15:46:55 UTC
 In the LXC mailing list there is a patch which fixed the problem I mentioned in the previous message:

http://sourceforge.net/mailarchive/forum.php?thread_name=20130710155821.GA8005%40tp&forum_name=lxc-devel

Comment 31 Daniele Viganò 2013-08-25 12:00:25 UTC
Any news about the inclusion of LXC 0.9.0 in Fedora 19 (and maybe 18)? Version 0.8.0 is quite old, buggy and doesn't work out of the box.

Thanks

Comment 32 Arun S A G 2013-08-27 06:04:39 UTC
I can help out with the packaging and builds. I use this package now and then. I have also raised a request for co-maintainer ship. Please review and approve.

Comment 33 Daniele Viganò 2013-08-27 07:21:07 UTC
I'm currently testing and using Thomas Moschny packages with success and working on a template for the latest Fedora (17/18/19) https://gist.github.com/daniviga/4682880#file-bootstrap-fedora18-sh. If help is needed I'm available too.

Cheers

Comment 34 Fedora Update System 2013-09-04 18:17:13 UTC
lxc-0.9.0-2.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/lxc-0.9.0-2.fc20

Comment 35 Fedora Update System 2013-09-04 18:17:50 UTC
lxc-0.9.0-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/lxc-0.9.0-2.fc18

Comment 36 Fedora Update System 2013-09-04 18:18:25 UTC
lxc-0.9.0-2.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/lxc-0.9.0-2.el6

Comment 37 Fedora Update System 2013-09-04 18:19:00 UTC
lxc-0.9.0-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/lxc-0.9.0-2.fc19

Comment 38 Arun S A G 2013-09-19 21:47:34 UTC
This can be pushed! Works for me!

Comment 39 Fedora Update System 2013-12-05 03:22:48 UTC
lxc-0.9.0-2.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 40 Fedora Update System 2013-12-05 10:31:13 UTC
lxc-0.9.0-2.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 41 Fedora Update System 2013-12-05 10:40:59 UTC
lxc-0.9.0-2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 42 Fedora Update System 2013-12-14 03:27:05 UTC
lxc-0.9.0-2.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.