Bug 87578 - kickstart doesn't support graphical install over ftp/http
Summary: kickstart doesn't support graphical install over ftp/http
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
(Show other bugs)
Version: 8.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-03-29 03:56 UTC by Damian Menscher
Modified: 2007-04-18 16:52 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-25 16:28:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Damian Menscher 2003-03-29 03:56:26 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
I created a fairly basic kickstart file using redhat-config-kickstart.  I set it
up to use a local FTP server, and to do a graphical install.  Anaconda bombed
out saying it doesn't support a graphical install over FTP.  Changed my settings
to go over HTTP, and it died there too.  Changed my settings to do text-mode
install, and it died because I want it to configure X.  I'm running out of
options here....

Is there some reason network installs don't support graphics?  I can't think of
any good ones....

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.create kickstart file that uses ftp or http, and requires graphical install
2.
3.
    

Additional info:

Comment 1 Michael Fulbright 2003-03-31 21:15:25 UTC
The main reason is you'd have to grab 60+ MB of data and store it in RAM just to
start the graphical installer up.

We are considering adding this as an option however because people have machines
with enough RAM to do this now.

Comment 2 Ellen Williamson 2003-05-29 20:17:53 UTC
I am experiencing this same problem with RedHat 8.0.  I never had this happen
with my 7.1 kickstart installations.  Has something changed between these
versions?  How can we get kickstart working now?  thanks,  ellenw@vitesse.com

Comment 3 Michael Fulbright 2003-06-20 16:39:22 UTC
We have graphical HTTP/FTP working in our development branch.

Comment 4 Mike McLean 2003-06-25 16:28:39 UTC
Just to clarify, kickstart did not previously support ftp, http, or hd graphical
installs.  Only installs via cdrom or nfs could run in graphical mode.  

This has changed in the current codebase.  Look for it in the next release.


Note You need to log in before you can comment on or make changes to this bug.