Bug 875798 - NTP service crashed after stopping network service
Summary: NTP service crashed after stopping network service
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ntp
Version: 6.4
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: ---
Assignee: Miroslav Lichvar
QA Contact: Petr Sklenar ⛄
URL:
Whiteboard:
Depends On:
Blocks: ovirt-3.2-release 895654
TreeView+ depends on / blocked
 
Reported: 2012-11-12 15:30 UTC by Igor Lvovsky
Modified: 2018-12-05 15:42 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-02-21 11:04:45 UTC
Target Upstream Version:


Attachments (Terms of Use)
fix IPv6 only interface iteration (3.56 KB, patch)
2012-11-27 16:57 UTC, Miroslav Lichvar
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:0495 normal SHIPPED_LIVE ntp bug fix update 2013-02-20 21:06:02 UTC

Description Igor Lvovsky 2012-11-12 15:30:41 UTC
Description of problem:

The NTP service crashed after stopping network service

Version-Release number of selected component (if applicable):
ntp-4.2.4p8-2.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Run ntpd and network services
2. stop network service
3. ntpd is die
  
Actual results:


Expected results:


Additional info:

NTP doesn't run after the network start again.

Comment 2 Miroslav Lichvar 2012-11-12 16:32:36 UTC
Can you please provide some logs when the network is restarted?

Comment 3 Igor Lvovsky 2012-11-12 16:52:55 UTC
there is no ntpd related logs in /var/log/messages.

When I added PEERNTP=no to /etc/sysconfig/network the ntpd stayed alive after network restart

Comment 4 Igor Lvovsky 2012-11-12 17:11:33 UTC
You can reproduce it easly with:
service network stop; sleep 10; service network start

Comment 5 Miroslav Lichvar 2012-11-12 18:27:38 UTC
From further discussion with the reporter it seems it happens when the network is stopped and after 10 seconds started again. "service network restart" doesn't trigger the bug. The latest ntp from f18 doesn't crash. There are 6 network interfaces configured on the machine and ntpd is not restarted by dhclient.

Backtrace:

#0  0x00007ffff6fc78a5 in raise () from /lib64/libc.so.6
#1  0x00007ffff6fc9085 in abort () from /lib64/libc.so.6
#2  0x00007ffff7fe121e in default_callback (file=0x7ffff7ff34d3 "./../libisc/ifiter_ioctl.c", line=571, 
    type=<value optimized out>, cond=0x7ffff7ff35e0 "iter->pos < (unsigned int) iter->ifc.ifc_len")
    at ../libisc/assertions.c:91
#3  0x00007ffff7fdf36e in internal_current4 (iter=0x7ffff826b1a0) at ../libisc/ifiter_ioctl.c:571
#4  0x00007ffff7fdfbbc in internal_current (iter=0x7ffff826b1a0) at ../libisc/ifiter_ioctl.c:994
#5  isc_interfaceiter_first (iter=0x7ffff826b1a0) at ../libisc/interfaceiter.c:175
#6  0x00007ffff7f8d4a4 in update_interfaces (receiver=0, data=0x0, port=31488) at ntp_io.c:1281
#7  0x00007ffff7f8e715 in interface_update (receiver=<value optimized out>, data=<value optimized out>) at ntp_io.c:1119
#8  0x00007ffff7fac3e7 in timer () at ntp_timer.c:394
#9  0x00007ffff7f8f263 in ntpdmain (argc=<value optimized out>, argv=<value optimized out>) at ntpd.c:1098
#10 0x00007ffff6fb3cdd in __libc_start_main () from /lib64/libc.so.6
#11 0x00007ffff7f85cc9 in _start ()

Comment 6 RHEL Product and Program Management 2012-11-13 11:39:50 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.

Comment 7 lpeer 2012-11-20 13:18:42 UTC
NTP not functioning can cause an issue with VM migration.
The guest can suffer from clock skew and then migration fails.
I think this bug is important enough to be fixed in 6.4 z stream.

Since I am not familiar with the details of the migration issue I am adding Barak to keep track of this bug and maybe provide more details.

Comment 8 Miroslav Lichvar 2012-11-27 16:54:11 UTC
This crash happens when the system doesn't have any IPv4 addresses, but it has an IPv6 address. I think that is a rare situation, usually there is at least 127.0.0.1 configured on the loopback interface which is the first interface brought up by the network service.

Comment 9 Miroslav Lichvar 2012-11-27 16:57:28 UTC
Created attachment 652925 [details]
fix IPv6 only interface iteration

Comment 10 Barak 2012-12-14 14:33:35 UTC
(In reply to comment #7)
> 
> Since I am not familiar with the details of the migration issue I am adding
> Barak to keep track of this bug and maybe provide more details.

migration of a VM back in time will cause the vm to stack.
I don't think it's relevant to the bug.
What is important is that the ntp should not crash

Comment 20 errata-xmlrpc 2013-02-21 11:04:45 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0495.html


Note You need to log in before you can comment on or make changes to this bug.