Bug 87584 - shading an docbook programlisting causes flow problems in PDF output
shading an docbook programlisting causes flow problems in PDF output
Status: CLOSED CANTFIX
Product: Red Hat Linux
Classification: Retired
Component: passivetex (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-03-29 03:29 EST by John Finlay
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-18 13:09:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
docbook source file with programlisting (4.81 KB, text/plain)
2003-03-29 03:41 EST, John Finlay
no flags Details
XSL to add shading to programlisting for test.xml (565 bytes, text/plain)
2003-03-29 03:42 EST, John Finlay
no flags Details

  None (edit)
Description John Finlay 2003-03-29 03:29:56 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020823
Netscape/7.0

Description of problem:
I am trying to create a PDF coument from a DocBook XML source using xmlto. I
added an XSL fragment to shade the background of a <programlisting> block -
fo:block has the attribute background-color="#E0E0E0". This causes a
programlisting of longer than 60 lines to run off the page instead of flowing to
the next page. If I don't shade the block then the flow is OK and multiple pages
are used for the programlisting. Not sure if this is a passivetex bug or a tetex
bug or some where else.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.run xmlto -m pdf.xml pdf text.xml
2.observe output in acroread or other PDF viewer
3.
    

Actual Results:  programlisting is truncated

Expected Results:  porgramlisting should have comtinued to multiple pages

Additional info:
Comment 1 John Finlay 2003-03-29 03:41:19 EST
Created attachment 90781 [details]
docbook source file with programlisting
Comment 2 John Finlay 2003-03-29 03:42:37 EST
Created attachment 90782 [details]
XSL to add shading to programlisting for test.xml
Comment 3 Tim Waugh 2003-03-29 17:29:06 EST
passivetex-1.23-1 from rawhide exhibits the same bad behaviour.  Seems like it's
a passivetex bug of some sort.

More precisely, it seems to be the handling of background-color that's at fault,
since

xmlto fo -m pdf.xsl test.xml
perl -pi -e 's, background-color="#E0E0E0",,' test.fo
xmlto --skip-validation pdf test.fo

produces correct output, although of course without the desired background colour.

Reported to docbook-apps mailing list, in case there's a known solution already.
Comment 4 Bill Nottingham 2006-08-07 15:50:53 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Red Hat apologizes that these issues have not been resolved yet. We do
want to make sure that no important bugs slip through the cracks.
Please check if this issue is still present in a current Fedora Core
release. If so, please change the product and version to match, and
check the box indicating that the requested information has been
provided. Note that any bug still open against Red Hat Linux on will be
closed as 'CANTFIX' on September 30, 2006. Thanks again for your help.
Comment 5 Bill Nottingham 2006-10-18 13:09:06 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Closing as CANTFIX.

Note You need to log in before you can comment on or make changes to this bug.