Bug 875846 - [i18n] "ON" and "OFF" not translated in switches on DVD (gtk30.mo not on DVD)
[i18n] "ON" and "OFF" not translated in switches on DVD (gtk30.mo not on DVD)
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: lorax (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Martin Gracik
Fedora Extras Quality Assurance
AcceptedBlocker
: i18n, Reopened
: 892749 892752 (view as bug list)
Depends On:
Blocks: F18Blocker/F18FinalBlocker 858628
  Show dependency treegraph
 
Reported: 2012-11-12 11:42 EST by Steve Tyler
Modified: 2013-07-04 09:05 EDT (History)
14 users (show)

See Also:
Fixed In Version: lorax-18.29-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-08 16:34:05 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Steve Tyler 2012-11-12 11:42:14 EST
Description of problem:

The Network Configuration spoke and the Date & Time spoke have an ON/OFF switch with text that is not translated to the language selected by the user in the Welcome dialog.

The switches appear to be implemented with GtkSwitch:
http://developer.gnome.org/gtk3/3.0/GtkSwitch.html

Version-Release number of selected component (if applicable):
anaconda-18.28-1
Fedora-18-Beta-TC8-x86_64-DVD.iso

How reproducible:
Always.

Steps to Reproduce:
1. Start installer.
2. In the Welcome dialog, select a non-English language that has nearly complete translation coverage:
   https://fedora.transifex.com/projects/p/anaconda/
3. Enter the Network Configuration spoke.
   Note text on switch.
   Click on switch to toggle.
   Note text on switch.
4. Enter the Date & Time spoke.
   Note text on switch.
   Click on switch to toggle.
   Note text on switch.
  
Actual results:
"ON" and "OFF" are displayed for several languages:
Spanish
Assamese
Chinese (China)
French
Russian

Expected results:
"ON" and "OFF" are translated to the selected language.

Additional info:

See also this critique of GtkSwitch:

On GtkSwitch
13 March 2011
http://jeff.ecchi.ca/blog/2011/03/13/on-gtkswitch/

Tested with:
$ qemu-kvm -m 2048 -hda f18-test-2.img -cdrom ~/xfr/fedora/F18/F18-Beta/TC8/Fedora-18-Beta-TC8-x86_64-DVD.iso -usb -vga qxl -boot menu=on -usbdevice mouse
Comment 1 Steve Tyler 2012-11-12 11:46:41 EST
(In reply to comment #0)
...
> See also this critique of GtkSwitch:
> 
> On GtkSwitch
> 13 March 2011
> http://jeff.ecchi.ca/blog/2011/03/13/on-gtkswitch/

This is exactly the problem that I have when looking at a switch:

"The ON/OFF thing can be confusing to a minority of users: does the fact that it currently displays “ON” mean that it “is on” or that “clicking this will turn it on”?"
Comment 2 Steve Tyler 2012-11-12 23:54:11 EST
On the Live CD, the "ON" and "OFF" strings are either translated or "|" and "O".

Amending bug summary.

Tested with the five languages in Comment 0 with:
anaconda-18.28-1 
$ qemu-kvm -m 2048 -hda f18-test-2.img -cdrom ~/xfr/fedora/F18/F18-Beta/TC8/Fedora-18-Beta-TC8-x86_64-Live-Desktop.iso -usb -vga qxl -boot menu=on -usbdevice mouse
Comment 3 Chris Lumens 2012-11-29 21:34:52 EST
Likely the same as bug 858628, given this is just another stock GTK widget not being translated.  I'll look at it tomorrow.

*** This bug has been marked as a duplicate of bug 858628 ***
Comment 4 Steve Tyler 2012-12-17 11:56:46 EST
Reopening per Bug 858628, Comment 21.
Comment 5 Steve Tyler 2012-12-17 13:07:27 EST
(In reply to comment #0)
...
> The switches appear to be implemented with GtkSwitch:
> http://developer.gnome.org/gtk3/3.0/GtkSwitch.html
...

The DVD does not have gtk30.mo in /usr/share/locale/*/LC_MESSAGES/.
The Live CD has gtk20.mo and gtk30.mo.
Refining bug summary.

Tested with:

$ qemu-kvm -m 2048 -hda f18-test-2.img -cdrom ~/xfr/fedora/F18/F18-Final/TC2/Fedora-18-TC2-x86_64-DVD.iso -usb -vga qxl -boot menu=on -usbdevice mouse

$ qemu-kvm -m 2048 -hda f18-test-1.img -cdrom ~/xfr/fedora/F18/F18-Final/TC2/Fedora-18-TC2-x86_64-Live-Desktop.iso -usb -vga qxl -boot menu=on -usbdevice mouse
Comment 6 Chris Lumens 2012-12-17 13:19:21 EST
This line in lorax is eliminating the locale file:

removefrom gtk3 /usr/share/* /usr/${libdir}/gtk-3.0/*
Comment 7 Steve Tyler 2012-12-17 14:37:58 EST
Proposing as F18 Final blocker per release criterion:[1]

14. All critical path actions on release-blocking desktop environments should correctly display all sufficiently complete translations available for use 

1. The gtk3 translations appear to be complete[2], but they are not being displayed.
2. Cannot be fixed with an update.

[1] https://fedoraproject.org/wiki/Fedora_18_Final_Release_Criteria
[2] http://ftp.gnome.org/pub/gnome/sources/gtk+/3.6/
Comment 8 Kamil Páral 2012-12-18 05:34:01 EST
Does missing gtk30.mo also cause missing translations of several OK/Cancel buttons? It seems like a probable cause, because they are translated on LiveCD and untranslated on DVD, see bug 858628 comment 20.
Comment 9 Adam Williamson 2012-12-19 12:42:54 EST
Discussed at 2012-12-19 blocker review meeting: http://meetbot.fedoraproject.org/fedora-bugzappers/2012-12-19/f18final-blocker-review-6.2012-12-19-17.02.log.txt . Accepted as a blocker per criterion "All critical path actions on release-blocking desktop environments should correctly display all sufficiently complete translations available for use". We could possibly wiggle a bit on this if it turns out to be a more complex issue, but we didn't want to waste time deliberating when the fix appears to be a one-liner in lorax.
Comment 10 Fedora Update System 2012-12-20 10:11:53 EST
lorax-18.29-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/lorax-18.29-1.fc18
Comment 11 Fedora Update System 2012-12-20 20:34:56 EST
Package lorax-18.29-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing lorax-18.29-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-20747/lorax-18.29-1.fc18
then log in and leave karma (feedback).
Comment 12 Kamil Páral 2013-01-03 07:57:50 EST
This is still not fixed in TC4, gtk30.mo is still missing.

Dennis, which lorax version was used to create TC4?
Comment 13 Adam Williamson 2013-01-03 12:15:45 EST
D'oh - I missed this for the TC4 request because the bug is marked ASSIGNED, not MODIFIED or ON_QA. I think all this needs is a re-spin with new lorax.
Comment 14 Kamil Páral 2013-01-07 03:34:05 EST
This is not fixed with RC1, no gtk30.mo present.

Dennis, version of lorax used?
Comment 15 Kamil Páral 2013-01-07 04:42:41 EST
I have learned that there is a /.buildstamp file if you boot DVD/netinst. It says Lorax=18.24-1.

Therefore an old version was used.
Comment 16 Jaroslav Reznik 2013-01-07 06:20:48 EST
I left a note in a rel-eng compose ticket.
Comment 17 Chris Lumens 2013-01-07 13:23:10 EST
*** Bug 892749 has been marked as a duplicate of this bug. ***
Comment 18 Chris Lumens 2013-01-07 13:23:13 EST
*** Bug 892752 has been marked as a duplicate of this bug. ***
Comment 19 Jaroslav Reznik 2013-01-07 18:32:36 EST
Old lorax has been used for RC1 due to broken mock config on compose box.
Comment 20 Kamil Páral 2013-01-08 05:31:17 EST
Buttons translated with RC2, gtk30.mo present.
Comment 21 Fedora Update System 2013-01-08 16:34:12 EST
lorax-18.29-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.