This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 87592 - sendmail needlessly required
sendmail needlessly required
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: distribution (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-03-29 10:16 EST by Chris Ricker
Modified: 2014-03-16 22:35 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-04-01 10:41:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Ricker 2003-03-29 10:16:39 EST
during installation, sendmail is currently required (meaning that I cannot
deselect it during package selection). It should instead be default (meaning
that its selected, but can be deselected), for those of us who install postfix
instead and have no need for sendmail to be installed

currently, I just have to 

rpm -e sendmail
rpm -e sendmail-cf

in the %post to work around this bug
Comment 1 Bill Nottingham 2003-03-31 11:51:50 EST
It's in the 'core' group, which is always installed anyway, as I recall. So
having it default in mailserver won't help your case. 
Comment 2 Chris Ricker 2003-04-01 09:39:36 EST
It's not in core

It's in base, where it is default like it should be

The problem is that it's in mail-server as well, and there it is mandatory
instead of default
Comment 3 Bill Nottingham 2003-04-01 10:41:58 EST
The issues is that if it's default-but-unselected in mail server, then you have
to rely on the comps implementation to DTRT to avoid machines being installed
without any mailserver. I don't think this will change at this point.

Note You need to log in before you can comment on or make changes to this bug.