Bug 875942 - KeyError: None
KeyError: None
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
abrt_hash:e9f11c7bef14e5a6d82a6e452a1...
:
: 877241 (view as bug list)
Depends On:
Blocks: F18Beta-accepted/F18BetaFreezeExcept
  Show dependency treegraph
 
Reported: 2012-11-12 16:49 EST by David Cantrell
Modified: 2012-11-23 07:16 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-23 02:28:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (282.42 KB, text/plain)
2012-11-12 16:49 EST, David Cantrell
no flags Details
File: product (6 bytes, text/plain)
2012-11-12 16:49 EST, David Cantrell
no flags Details
File: type (9 bytes, text/plain)
2012-11-12 16:49 EST, David Cantrell
no flags Details
File: ifcfg.log (641 bytes, text/plain)
2012-11-12 16:49 EST, David Cantrell
no flags Details
File: storage.log (153.95 KB, text/plain)
2012-11-12 16:49 EST, David Cantrell
no flags Details
File: version (2 bytes, text/plain)
2012-11-12 16:49 EST, David Cantrell
no flags Details
File: environ (780 bytes, text/plain)
2012-11-12 16:49 EST, David Cantrell
no flags Details
File: executable (14 bytes, text/plain)
2012-11-12 16:49 EST, David Cantrell
no flags Details
File: anaconda.log (8.62 KB, text/plain)
2012-11-12 16:49 EST, David Cantrell
no flags Details
File: syslog (60.11 KB, text/plain)
2012-11-12 16:49 EST, David Cantrell
no flags Details
File: hashmarkername (8 bytes, text/plain)
2012-11-12 16:49 EST, David Cantrell
no flags Details
File: packaging.log (2.83 KB, text/plain)
2012-11-12 16:49 EST, David Cantrell
no flags Details
File: cmdline_file (87 bytes, text/plain)
2012-11-12 16:49 EST, David Cantrell
no flags Details
File: release (24 bytes, text/plain)
2012-11-12 16:49 EST, David Cantrell
no flags Details
File: program.log (26.23 KB, text/plain)
2012-11-12 16:49 EST, David Cantrell
no flags Details

  None (edit)
Description David Cantrell 2012-11-12 16:49:05 EST
Description of problem:
Performing custom partitioning on a virt guest that has an existing F-18 LUKS LVM installation.  I enter my password on the first encrypted volume I see and click Unlock, then get this traceback.

Version-Release number of selected component:
anaconda-18.28

Additional info:
libreport version: 2.0.17
cmdline:        /usr/bin/python  /sbin/anaconda
kernel:         3.6.6-3.fc18.x86_64

description:
:The following was filed automatically by anaconda:
:anaconda 18.28 exception report
:Traceback (most recent call first):
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 1508, in _populate_right_side
:    typeCombo.set_active(type_index_map[device_type])
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 1823, in on_selector_clicked
:    self._populate_right_side(selector)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 1687, in _show_first_mountpoint
:    self.on_selector_clicked(page._members[0])
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 1841, in on_page_clicked
:    self._show_first_mountpoint(page=page)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 701, in _do_refresh
:    self.on_page_clicked(self._accordion.currentPage())
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 2071, in on_unlock_clicked
:    self._do_refresh()
:KeyError: None
Comment 1 David Cantrell 2012-11-12 16:49:09 EST
Created attachment 643778 [details]
File: anaconda-tb
Comment 2 David Cantrell 2012-11-12 16:49:10 EST
Created attachment 643779 [details]
File: product
Comment 3 David Cantrell 2012-11-12 16:49:12 EST
Created attachment 643780 [details]
File: type
Comment 4 David Cantrell 2012-11-12 16:49:14 EST
Created attachment 643781 [details]
File: ifcfg.log
Comment 5 David Cantrell 2012-11-12 16:49:16 EST
Created attachment 643782 [details]
File: storage.log
Comment 6 David Cantrell 2012-11-12 16:49:17 EST
Created attachment 643783 [details]
File: version
Comment 7 David Cantrell 2012-11-12 16:49:19 EST
Created attachment 643784 [details]
File: environ
Comment 8 David Cantrell 2012-11-12 16:49:21 EST
Created attachment 643785 [details]
File: executable
Comment 9 David Cantrell 2012-11-12 16:49:23 EST
Created attachment 643786 [details]
File: anaconda.log
Comment 10 David Cantrell 2012-11-12 16:49:25 EST
Created attachment 643787 [details]
File: syslog
Comment 11 David Cantrell 2012-11-12 16:49:27 EST
Created attachment 643788 [details]
File: hashmarkername
Comment 12 David Cantrell 2012-11-12 16:49:29 EST
Created attachment 643789 [details]
File: packaging.log
Comment 13 David Cantrell 2012-11-12 16:49:31 EST
Created attachment 643790 [details]
File: cmdline_file
Comment 14 David Cantrell 2012-11-12 16:49:33 EST
Created attachment 643791 [details]
File: release
Comment 15 David Cantrell 2012-11-12 16:49:36 EST
Created attachment 643792 [details]
File: program.log
Comment 16 David Lehman 2012-11-14 15:57:51 EST
We need special handling for the case of a vg that is also a leaf, probably a special display for the RHS that says something like "Not sure what this device is, but your only options are to remove it or leave it as-is."
Comment 17 David Lehman 2012-11-19 13:41:55 EST
*** Bug 877241 has been marked as a duplicate of this bug. ***
Comment 18 David Lehman 2012-11-19 17:07:55 EST
This means that anyone with a preexisting VG with encrypted PVs (read: encrypted autopart) who tries to unlock the PVs from the custom spoke will end up hitting a traceback and therefore will be unable to work with their existing VG.

(Yes, same scenario as bug 878225. The immediate fix for this is what exposed that one.)
Comment 19 Adam Williamson 2012-11-19 19:25:22 EST
I'm at least +1 nth as this is a rather frustrating problem and not too hard to hit it - just try and install to a system with existing autopart encrypted LVM and go through custom part. I'm not sure it's bad enough to be blocker, but dlehman says the fixes for this and 878225 are small and tested, so I'm +/-0 blocker, +1 NTH.
Comment 20 Dennis Gilmore 2012-11-19 19:28:40 EST
+1 NTH here
Comment 21 Kevin Fenzi 2012-11-19 19:30:51 EST
+1 NTH
Comment 22 Adam Williamson 2012-11-19 19:35:09 EST
AcceptedNTH at least (blocker status can wait for a meeting)
Comment 23 Fedora Update System 2012-11-20 17:03:03 EST
anaconda-18.29.2-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/FEDORA-2012-18468/anaconda-18.29.2-1.fc18
Comment 24 Kamil Páral 2012-11-21 11:25:09 EST
I wasn't able to reproduce the issue with anaconda 18.28, so I can't test the fix. I created default F18 encrypted LVM installation and rebooted back into the installer, but I could unlock it just fine. I had the whole VG encrypted.
I also performed an F17 installation where I had VG unencrypted and only a single LV encrypted, but again, after rebooting to anaconda 18.28, I could unlock it just fine.

So either the reproducer is not complete or it doesn't happen always.
Comment 25 David Lehman 2012-11-21 12:15:39 EST
(In reply to comment #24)
> So either the reproducer is not complete or it doesn't happen always.

It requires multiple disks. You unlock one of the PVs (preferably the one on the last disk), then click on the new entry that appears under the Unknown section on the left side. That entry should represent a VG, which should trigger the unhandled exception.
Comment 26 Adam Williamson 2012-11-21 13:32:10 EST
Discussed at 2012-11-21 blocker review meeting. We confirmed the NTH call on this but rejected it as a blocker as we think it's just a bit too complex to make the criteria, with the addition of the requirement for multiple disks. I will try and test it with RC1 if I can reproduce the failure.
Comment 27 Fedora Update System 2012-11-21 15:51:32 EST
Package anaconda-18.29.2-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-18.29.2-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-18468/anaconda-18.29.2-1.fc18
then log in and leave karma (feedback).
Comment 28 Adam Williamson 2012-11-23 01:43:23 EST
we need to confirm this is fixed in RC1.
Comment 29 Fedora Update System 2012-11-23 02:28:05 EST
anaconda-18.29.2-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 30 Kamil Páral 2012-11-23 07:16:36 EST
Verified fixed in 18.29.2. That doesn't mean that there are no other problems (e.g. no LVs appeared after unlocking the VG), but this particular crash is gone.

Note You need to log in before you can comment on or make changes to this bug.