Bug 87601 - Reiser hammers CPU >2gig file, also causes loss of free space
Reiser hammers CPU >2gig file, also causes loss of free space
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: kernel-utils (Show other bugs)
2.1
i686 Linux
high Severity high
: ---
: ---
Assigned To: Larry Woodman
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-03-30 00:39 EST by Thomas S
Modified: 2007-11-30 17:06 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-12 11:13:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas S 2003-03-30 00:39:24 EST
Description of problem:

Bug is really reference to the 7.2 bug #57714 which is marked closed (fix was put into 2.4.18 kernels) but A.S. does not have the fix 
even with the latest kernel.

Creating a large file >2gig the CPU goes to full use, the process creating the file can't be killed.  At 2gig the file stays the same size 
(according to ls), but doing multiple 'df' commands on the filesystem shows that space is still being used by the process.  To repair, 
only a 'reboot -f -n' will bounce the box (sync hangs).  I can't completely verify it, but I believe the space gets allocated but can't be 
deallocated.  As shown below I've got >5gig less space available than I can account for.

[root@tweek root]# df -k /files
Filesystem           1k-blocks      Used Available Use% Mounted o
/dev/hdd1            120057164  81171436  38885728  68% /files
[root@tweek root]# du -ks /files/
76292030        /files

I tried running reiserfsck to get back the space, but to no avail the space is still appears to be unavailable.


Version-Release number of selected component (if applicable):
kernel-smp-2.4.9-e.16
reiserfs-utils-3.x.0j-3 


How reproducible:
Every time.

Steps to Reproduce:
1. Create a single big file: dd if=/dev/zero of=test bs=1M count=3000
2. At 2gig CPU gets hammered
3. dd process can't be killed

Actual results:
Both CPU's got 100% use, free space in the reiser filesystem is lost:

Expected results:
File should be created without killing CPU and without losing free space

Additional info:
I believe it is related to the warning of off Reiser's web page at http://www.namesys.com/download.html but I can't say for sure.
Comment 1 Arjan van de Ven 2003-03-30 08:40:25 EST
as far as I know, reiserfs is very very unsupported in AS2.1
Comment 2 Suzanne Hillman 2003-08-12 11:13:09 EDT
Because reiser is not supported in AS2.1, closing this bug.

Note You need to log in before you can comment on or make changes to this bug.