Bug 876025 - RFE: [WebTrans] prompt user for action when there is unsaved changes before switching context
RFE: [WebTrans] prompt user for action when there is unsaved changes before s...
Status: CLOSED NOTABUG
Product: Zanata
Classification: Community
Component: Usability (Show other bugs)
development
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Isaac Rooskov
Zanata-QA Mailling List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-13 00:13 EST by Patrick Huang
Modified: 2015-08-06 01:54 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-03-10 01:41:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Patrick Huang 2012-11-13 00:13:40 EST
Description of problem:
Whenever user is about to change context, and has unsaved change in editor, Zanata should prompt the user for actions.

Version-Release number of selected component (if applicable):
2.0-

How reproducible:
Always

Steps to Reproduce:
1. Go to translation editor and type in some text (one row become unsaved)
2. Type something in the search box and hit enter
  
Actual results:
Page is reloaded with messages matching the search string but unsaved change is lost

Expected results:
Similar to filter by state option change, user should be prompted to "save change", "save as fuzzy", "discard change" and "cancel" before reloading the page

Additional info:
There may be other occasion that current page context is about to change (current page contents is about to change). If there is unsaved changes, we should ask the user about what action he wants to take before making the context switch.
Comment 1 Michelle Kim 2015-03-10 01:41:13 EDT
Patrick, It seems to be fixed. I just tested it and works for me. I am closing the bug. Please re-open if you think it is not fixed.

Note You need to log in before you can comment on or make changes to this bug.