Bug 87606 - POP authentication doesn't work with imap-2002b-5
POP authentication doesn't work with imap-2002b-5
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: uw-imap (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: John Dennis
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-03-30 09:14 EST by Jonathan Kamens
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-03 03:03:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Kamens 2003-03-30 09:14:04 EST
With imap from raw hide:

jik:/usr/src/packages!1449$ telnet localhost pop3
Trying 127.0.0.1...
Connected to localhost.localdomain (127.0.0.1).
Escape character is '^]'.
+OK POP3 localhost.localdomain v2002.81rh server ready
USER XXX
-ERR Unknown AUTHORIZATION state command
quit
+OK Sayonara
Connection closed by foreign host.

After downgrading to imap-2001a-18:

jik:/usr/src/packages!1452$ telnet localhost pop3
Trying 127.0.0.1...
Connected to localhost.localdomain (127.0.0.1).
Escape character is '^]'.
+OK POP3 localhost.localdomain v2001.78rh server ready
USER XXX
+OK User name accepted, password please
PASS XXX
+OK Mailbox open, 12 messages
quit
+OK Sayonara
Connection closed by foreign host.
Comment 1 Jonathan Kamens 2003-06-10 20:42:39 EDT
This is still broken in imap-2002b-6.  Surely you can't ship the next release
with this still broken!
Comment 2 Jonathan Kamens 2003-06-10 22:22:36 EDT
I found the explanation for this.  See
<URL:http://www.faqchest.com/prgm/wuimap-l/imap-02/imap-0211/imap02112214_20708.html>.
 Basically, in the default configuration of the new version of imap, plaintext
passwords are disabled on non-SSL connections.

If you intended to make this change, then I think you need to document the hell
out of it.  If you didn't intend to make the change, then I think you need to
change how the imap RPM is compiled so that plaintext passwords are allowed.
Comment 3 Bill Nottingham 2006-08-07 21:44:41 EDT
'Red Hat Raw Hide' refers to the development tree for Red Hat Linux.
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Red Hat apologizes that these issues were not resolved in a more
timely manner. However, we do want to make sure that important 
don't slip through the cracks. If these issues are still present
in a current release, such as Fedora Core 5, please move these
bugs to that product and version. Note that any remaining Red Hat
Raw Hide bugs will be closed as 'CANTFIX' on September 30, 2006.
Thanks again for your help.
Comment 4 Jonathan Kamens 2006-09-03 03:03:19 EDT
This is fixed in current version in extras devel.

Note You need to log in before you can comment on or make changes to this bug.