Bug 876066 - Using uninitialized value
Summary: Using uninitialized value
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: hplip
Version: 6.4
Hardware: Unspecified
OS: Unspecified
low
unspecified
Target Milestone: rc
: ---
Assignee: Tim Waugh
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-11-13 08:35 UTC by Ondrej Oprala
Modified: 2016-02-01 02:08 UTC (History)
5 users (show)

Fixed In Version: hplip-3.14.6-1.el6
Doc Type: Bug Fix
Doc Text:
Prior to this update, the use of an uninitialized value could produce incorrect output from the hpcups driver. The underlying source code has been modified to initialize the value before it is used, and the described unexpected behavior is therefore prevented.
Clone Of:
Environment:
Last Closed: 2015-07-22 06:12:58 UTC


Attachments (Terms of Use)
List of all defects added in hplip-3.12.4-1.el6 (70.05 KB, text/plain)
2012-11-13 08:35 UTC, Ondrej Oprala
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1282 normal SHIPPED_LIVE hplip bug fix and enhancement update 2015-07-20 17:49:01 UTC
Launchpad 800802 None None None 2012-11-13 10:07:58 UTC

Description Ondrej Oprala 2012-11-13 08:35:09 UTC
Created attachment 643998 [details]
List of all defects added in hplip-3.12.4-1.el6

Description of problem:
/builddir/build/BUILD/hplip-3.12.4/prnt/hpcups/LJZjStream.cpp:681: uninit_use: Using uninitialized value "cups_header.Duplex".

Comment 2 Jiri Popelka 2012-11-13 10:07:58 UTC
The LJZjStream::preProcessRasterData() was added in 3.11.12.
I added possible fix to upstream report https://bugs.launchpad.net/hplip/+bug/800802

Comment 3 RHEL Product and Program Management 2012-12-14 08:01:48 UTC
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.

Comment 10 errata-xmlrpc 2015-07-22 06:12:58 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1282.html


Note You need to log in before you can comment on or make changes to this bug.