Bug 87607 - Rendering problem with JAVA form
Rendering problem with JAVA form
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-03-30 09:35 EST by Joachim Frieben
Modified: 2007-04-18 12:52 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-10 12:30:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of poorly rendered Java form (2.78 KB, image/png)
2003-03-30 09:37 EST, Joachim Frieben
no flags Details
Screenshot of better rendered Java form (2.88 KB, image/png)
2003-04-09 16:53 EDT, Joachim Frieben
no flags Details

  None (edit)
Description Joachim Frieben 2003-03-30 09:35:48 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030206

Description of problem:
Using mozilla-1.2.1-20 in conjunction with j2re-1.4.1_02-fcs to carry
out online banking operations via the Internet, it turns out that the
corresponding Java form is rendered badly (see attached PNG-file, where
only the upper half of text entries is displayed).

Version-Release number of selected component (if applicable):
4.2.99.901-20030213.0

How reproducible:
Always

Steps to Reproduce:
1. Connect to my bank via Internet
2. Wait for Java application to be started
3. Login to my bank account

Actual Results:  The entry boxes are rendered poorly. In fact, their vertical
size is too small, such that only the upper half of text entries is displayed.

Expected Results:  The entries of text boxes should be rendered properly.

Additional info:

The problem exists ever since I am using mozilla for this purpose, and I thought
it was a problem with SUN's JRE, but I had the occasion to try out the same on a
DELL Precsion workstation with some NVidia chip based graphics card, and there
everything was fine. I conclude that the difficulties may be related to the
XFree86 driver implementation. The actual module used in the present case is
'mga'. The graphics card is a Matrox Millennium II PCI card with 8MB of memory.
Comment 1 Joachim Frieben 2003-03-30 09:37:59 EST
Created attachment 90791 [details]
Screenshot of poorly rendered Java form
Comment 2 Mike A. Harris 2003-03-30 13:09:33 EST
This could be a mozilla problem, or it could be a Java problem.  There
is no way to really know what it is.  I obviously can't log into your
bank account in order to reproduce this, so I'm not sure what - if
anything can be done about it.

Disable 2D acceleration with Option "noaccel" and see if the problem goes
away.  If so, then it is possibly a video driver issue, if not then
it is possibly a mozilla or java issue.

What happens when you disable 2D acceleration?
Comment 3 Joachim Frieben 2003-03-31 11:45:32 EST
Neither adding the "noaccel" option to the "XF86Config" file nor configuring the
graphics card as a VESA-compatible device cures the reported flaw. However, I
insist that on some DELL Precision workstation used for comparison, running Red
Hat Linux 7.2 and *exactly* the same versions of "mozilla" and "j2re" but a
different graphics device (NVidia) and an older version of XFree86 4, everything
works fine.
Comment 4 Joachim Frieben 2003-04-09 16:50:17 EDT
Well, as of j2re-1.4.2-beta, the rendering is much more improved, virtually
flawless, except for bad alignment of boxes. However, text entries are perfectly
readable now (see attached screen shot).
Comment 5 Joachim Frieben 2003-04-09 16:53:00 EDT
Created attachment 91048 [details]
Screenshot of better rendered Java form
Comment 6 Mike A. Harris 2003-04-10 16:50:26 EDT
If you have changed the Java version you're using, and you are seeing
rendering changes on screen - either improvements or regressions, that
seems indicative to me that the rendering problems stem from within
Java itself, and not from XFree86.

Have you contacted your Java vendor about this problem?
Comment 7 Mike A. Harris 2004-01-10 12:30:33 EST
This is most likely a Java implementation bug, and not an XFree86
bug.  Closing as NOTABUG.

Note You need to log in before you can comment on or make changes to this bug.