Bug 876157 - Downloading failed: invalid data in .treeinfo: No option 'upgrade' in section: 'images-x86_64'
Downloading failed: invalid data in .treeinfo: No option 'upgrade' in section...
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: fedup (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Will Woods
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F18Beta/F18BetaBlocker
  Show dependency treegraph
 
Reported: 2012-11-13 08:23 EST by Jan Sedlák
Modified: 2012-11-13 12:40 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-13 10:01:42 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
fedup debug log (531.31 KB, text/x-log)
2012-11-13 08:23 EST, Jan Sedlák
no flags Details

  None (edit)
Description Jan Sedlák 2012-11-13 08:23:35 EST
Created attachment 644094 [details]
fedup debug log

Description of problem:
I tried running fedup using instructions from wiki ("sudo fedup-cli --network 18 --debuglog fedupdebug.log --instrepo=http://tflink.fedorapeople.org/fedup/f18-upgrade/x86_64") and with fedup from github and it failed with error "Downloading failed: invalid data in .treeinfo: No option 'upgrade' in section: 'images-x86_64'". See attached fedup log.
Comment 1 Josef Skladanka 2012-11-13 09:28:46 EST
I'm hitting the same error.
Comment 2 Will Woods 2012-11-13 10:01:42 EST
This requires images built with a newer lorax, e.g.:

  https://github.com/wgwoods/lorax

Patches have been sent to lorax upstream. In the meantime, you'll need to fix your repo and/or ask tflink to edit his .treeinfo so it has "upgrade = $PATH/upgrade.img" instead.

Feel free to reopen if that doesn't fix it.
Comment 3 Tim Flink 2012-11-13 12:40:39 EST
I've hacked the described change into the test repo and it appears to work from my initial testing. I'm currently working on testing the lorax changes for fedup and will update the initramfs in the test repo once there are changes in git.

Note You need to log in before you can comment on or make changes to this bug.