Bug 876166 - java_cup: Licensing problems
java_cup: Licensing problems
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: java_cup (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: gil cattaneo
Fedora Extras Quality Assurance
:
Depends On:
Blocks: FE-Legal
  Show dependency treegraph
 
Reported: 2012-11-13 08:35 EST by Mikolaj Izdebski
Modified: 2012-11-23 02:29 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-13 11:20:09 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mikolaj Izdebski 2012-11-13 08:35:19 EST
License tag is "BSD and LGPLv2"

Problem 1. There is no LGPLv2 code from what I saw (there used to be LGPLv2+ ant task, but it was removed).

Problem 2. Upstream license is MIT, not BSD:
http://www2.cs.tum.edu/projects/cup/

Problem 3. License terms are violated because no license text is included with the package. License says "Permission [...] is hereby granted, provided that the above copyright notice appear in all copies"
Comment 1 Tom "spot" Callaway 2012-11-13 11:20:09 EST
Fixed in rawhide: java_cup-0.11a-10.fc19
Comment 2 Fedora Update System 2012-11-13 14:31:08 EST
java_cup-0.11a-10.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/java_cup-0.11a-10.fc18
Comment 3 Fedora Update System 2012-11-23 02:29:24 EST
java_cup-0.11a-10.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.