Bug 876180 - KeyError: None
KeyError: None
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
RejectedBlocker AcceptedNTH abrt_hash...
:
Depends On:
Blocks: F18Beta-accepted/F18BetaFreezeExcept
  Show dependency treegraph
 
Reported: 2012-11-13 09:09 EST by Martin
Modified: 2014-09-14 20:04 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-23 02:27:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: anaconda-tb (453.88 KB, text/plain)
2012-11-13 09:09 EST, Martin
no flags Details
File: product (6 bytes, text/plain)
2012-11-13 09:09 EST, Martin
no flags Details
File: type (9 bytes, text/plain)
2012-11-13 09:09 EST, Martin
no flags Details
File: environ (817 bytes, text/plain)
2012-11-13 09:09 EST, Martin
no flags Details
File: storage.log (236.61 KB, text/plain)
2012-11-13 09:09 EST, Martin
no flags Details
File: version (11 bytes, text/plain)
2012-11-13 09:09 EST, Martin
no flags Details
File: program.log (73.20 KB, text/plain)
2012-11-13 09:09 EST, Martin
no flags Details
File: executable (14 bytes, text/plain)
2012-11-13 09:09 EST, Martin
no flags Details
File: anaconda.log (11.25 KB, text/plain)
2012-11-13 09:09 EST, Martin
no flags Details
File: syslog (100.25 KB, text/plain)
2012-11-13 09:09 EST, Martin
no flags Details
File: hashmarkername (8 bytes, text/plain)
2012-11-13 09:09 EST, Martin
no flags Details
File: packaging.log (3.99 KB, text/plain)
2012-11-13 09:09 EST, Martin
no flags Details
File: cmdline_file (180 bytes, text/plain)
2012-11-13 09:09 EST, Martin
no flags Details
File: release (24 bytes, text/plain)
2012-11-13 09:10 EST, Martin
no flags Details

  None (edit)
Description Martin 2012-11-13 09:09:19 EST
Version-Release number of selected component:
anaconda-18.28

Additional info:
libreport version: 2.0.17
cmdline:        /usr/bin/python  /sbin/anaconda
kernel:         3.6.6-3.fc18.x86_64

description:
:The following was filed automatically by anaconda:
:anaconda 18.28 exception report
:Traceback (most recent call first):
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/__init__.py", line 1987, in getDeviceFactory
:    factory_class = class_table[device_type]
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 887, in _save_right_side
:    raid_level=raid_level)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 1837, in on_page_clicked
:    self._save_right_side(self._current_selector)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/lib/accordion.py", line 119, in _onExpanded
:    cb(obj.get_child())
:KeyError: None
Comment 1 Martin 2012-11-13 09:09:27 EST
Created attachment 644116 [details]
File: anaconda-tb
Comment 2 Martin 2012-11-13 09:09:30 EST
Created attachment 644117 [details]
File: product
Comment 3 Martin 2012-11-13 09:09:34 EST
Created attachment 644118 [details]
File: type
Comment 4 Martin 2012-11-13 09:09:36 EST
Created attachment 644119 [details]
File: environ
Comment 5 Martin 2012-11-13 09:09:39 EST
Created attachment 644120 [details]
File: storage.log
Comment 6 Martin 2012-11-13 09:09:41 EST
Created attachment 644121 [details]
File: version
Comment 7 Martin 2012-11-13 09:09:45 EST
Created attachment 644122 [details]
File: program.log
Comment 8 Martin 2012-11-13 09:09:47 EST
Created attachment 644123 [details]
File: executable
Comment 9 Martin 2012-11-13 09:09:50 EST
Created attachment 644124 [details]
File: anaconda.log
Comment 10 Martin 2012-11-13 09:09:53 EST
Created attachment 644125 [details]
File: syslog
Comment 11 Martin 2012-11-13 09:09:55 EST
Created attachment 644126 [details]
File: hashmarkername
Comment 12 Martin 2012-11-13 09:09:57 EST
Created attachment 644127 [details]
File: packaging.log
Comment 13 Martin 2012-11-13 09:09:59 EST
Created attachment 644128 [details]
File: cmdline_file
Comment 14 Martin 2012-11-13 09:10:02 EST
Created attachment 644129 [details]
File: release
Comment 15 David Lehman 2012-11-13 12:53:18 EST
Bug occurs when user visits a locked LUKS device without unlocking it and then selects another group/page/device.
Comment 16 Adam Williamson 2012-11-14 05:17:28 EST
voting in advance of tomorrow's blocker meeting, which I won't be around for. I'm a bit borderline on this one - crashers are bad, but this one seems easy enough to workaround, and we can't really block on every complex custom part crasher anyone finds. count me a weak -1 blocker, +1 nth for this. if it turns out at the meeting that the issue is more serious than it seems right now (I'm going on comment #15), disregard the above.
Comment 17 Kamil Páral 2012-11-14 12:28:02 EST
Discussed at 2012-11-14 blocker bug meeting. Rejected as a blocker, but accepted NTH:  This doesn't clearly hit any release criteria for F18 beta but fixing installer crashes is preferred - a tested fix would be considered past freeze
Comment 18 Adam Williamson 2012-11-15 23:36:19 EST
I hit this same crasher a different way today - https://bugzilla.redhat.com/show_bug.cgi?id=877241 . dlehman is looking at it.
Comment 19 Fedora Update System 2012-11-18 20:14:41 EST
anaconda-18.29.1-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.29.1-1.fc18
Comment 20 Fedora Update System 2012-11-19 01:55:51 EST
Package anaconda-18.29.1-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-18.29.1-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-18468/anaconda-18.29.1-1.fc18
then log in and leave karma (feedback).
Comment 21 Fedora Update System 2012-11-21 15:51:06 EST
Package anaconda-18.29.2-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-18.29.2-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-18468/anaconda-18.29.2-1.fc18
then log in and leave karma (feedback).
Comment 22 Adam Williamson 2012-11-23 01:45:23 EST
needs re-testing.
Comment 23 Fedora Update System 2012-11-23 02:27:29 EST
anaconda-18.29.2-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.