Bug 876184 - Unable to select GNOME desktop during software selection
Unable to select GNOME desktop during software selection
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-bluetooth (Show other bugs)
18
s390x All
unspecified Severity urgent
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks: ZedoraTracker
  Show dependency treegraph
 
Reported: 2012-11-13 09:11 EST by IBM Bug Proxy
Modified: 2012-12-06 23:24 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-06 23:24:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot during failure (113.57 KB, image/jpeg)
2012-11-13 09:11 EST, IBM Bug Proxy
no flags Details
Failure messages after selecting Remove Packages option (50.02 KB, image/jpeg)
2012-11-13 09:11 EST, IBM Bug Proxy
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
IBM Linux Technology Center 86685 None None None 2012-11-13 09:11:01 EST

  None (edit)
Description IBM Bug Proxy 2012-11-13 09:11:00 EST
== Comment: #0 - SACHIN P. SANT <ssant@in.ibm.com> - 2012-11-12 05:22:22 ==
Steps to recreate the the problem.

1) Start F18 installation on zVM guest
2) Go through initial few screens.
3) On Software Selection screen select GNOME Desktop.

Due to failed dependencies installer cannot continue with installation (Refer to the attached screenshot)
If I select the Remove Packages option am able to proceed to next screen, but installation eventually fails with anaconda exception.

== Comment: #1 - SACHIN P. SANT <ssant@in.ibm.com> - 2012-11-12 05:25:37 ==


== Comment: #4 - Brent J. Baude <baude@us.ibm.com> - 2012-11-12 10:18:04 ==
It's just a dependancy issue and quite common in this phase in Fedora.  The 390 Fedora release engineer just needs to know about them and he/she can fix it up.  Instead of the screen shot, provide him with the text-based list of packages which can be had from the log files.
Comment 1 IBM Bug Proxy 2012-11-13 09:11:17 EST
Created attachment 644130 [details]
Screenshot during failure
Comment 2 IBM Bug Proxy 2012-11-13 09:11:35 EST
Created attachment 644131 [details]
Failure messages after selecting Remove Packages option
Comment 3 Bill Nottingham 2012-11-13 15:11:12 EST
Hm.

We could add some architecture specifications to the environments in comps, I suppose. Or have the s390 secondary arch filter their comps file.

But there's not much to help that you're installing something that may not make much sense for your platform. 

For the specific issue, gnome-bluetooth probably needs to not be built on s390, or have some requirements %ifarched in its spec file.
Comment 4 IBM Bug Proxy 2012-11-14 02:50:34 EST
------- Comment From ssant@in.ibm.com 2012-11-14 07:49 EDT-------
Following are the dependency errors displayed during a manual install of GNOME

# yum groupinstall "GNOME Desktop"
........
........ <SNIP> ........
...............

---> Package sox.s390x 0:14.4.0-2.fc18 will be installed
--> Running transaction check
---> Package OpenEXR-libs.s390x 0:1.7.1-1.fc18 will be installed
---> Package festival-lib.s390x 0:1.96-21.fc18 will be installed
---> Package festival-speechtools-libs.s390x 0:1.2.96-21.fc18 will be installed
---> Package festvox-slt-arctic-hts.noarch 0:0.20061229-21.fc18 will be installed
---> Package gnome-bluetooth.s390x 1:3.4.0-2.fc17 will be installed
--> Processing Dependency: pulseaudio-module-bluetooth for package: 1:gnome-bluetooth-3.4.0-2.fc17.s390x
--> Processing Dependency: obexd for package: 1:gnome-bluetooth-3.4.0-2.fc17.s390x
--> Processing Dependency: gvfs-obexftp for package: 1:gnome-bluetooth-3.4.0-2.fc17.s390x
---> Package gnome-boxes.s390x 0:3.6.1.1-1.fc18 will be installed
--> Processing Dependency: libvirt-daemon-kvm for package: gnome-boxes-3.6.1.1-1.fc18.s390x
---> Package ilmbase.s390x 0:1.0.3-4.fc18 will be installed
---> Package libgdither.s390x 0:0.6-5.fc18 will be installed
--> Finished Dependency Resolution
Error: Package: 1:gnome-bluetooth-3.4.0-2.fc17.s390x (F18-latest)
Requires: obexd
Error: Package: 1:gnome-bluetooth-3.4.0-2.fc17.s390x (F18-latest)
Requires: pulseaudio-module-bluetooth
Error: Package: gnome-boxes-3.6.1.1-1.fc18.s390x (F18-latest)
Requires: libvirt-daemon-kvm
Error: Package: 1:gnome-bluetooth-3.4.0-2.fc17.s390x (F18-latest)
Requires: gvfs-obexftp

#
Comment 5 IBM Bug Proxy 2012-11-14 04:56:39 EST
------- Comment From ssant@in.ibm.com 2012-11-14 09:45 EDT-------
So as per your comment(In reply to comment #9)
> Hm.
>
> We could add some architecture specifications to the environments in comps,
> I suppose. Or have the s390 secondary arch filter their comps file.
>
> But there's not much to help that you're installing something that may not
> make much sense for your platform.
>
> For the specific issue, gnome-bluetooth probably needs to not be built on
> s390, or have some requirements %ifarched in its spec file.

I see two error messages (dependency)

Error: Package: 1:gnome-bluetooth-3.4.0-2.fc17.s390x (F18-latest)
Requires: obexd
Error: Package: 1:gnome-bluetooth-3.4.0-2.fc17.s390x (F18-latest)
Requires: pulseaudio-module-bluetooth
Error: Package: gnome-boxes-3.6.1.1-1.fc18.s390x (F18-latest)
Requires: libvirt-daemon-kvm
Error: Package: 1:gnome-bluetooth-3.4.0-2.fc17.s390x (F18-latest)
Requires: gvfs-obexftp

So if I read your comment correctly you are proposing to remove gnome-bluetooth package for s390. Please confirm.

What about gnome-boxes ? should this also be removed and is not required for s390 ?
Comment 6 IBM Bug Proxy 2012-11-14 05:00:45 EST
------- Comment From ssant@in.ibm.com 2012-11-14 09:55 EDT-------
Test scenario I am trying here are prereqs for 3D desktop evaluation. Here is my plan

1) Install F18 with GNOME.
2) vncserver package available and able to configure.
3) Use the swrast related configuration tweak to enable 3D emulation.
4) Once the desktop is up and running try to use different GUI screens to see if they work as expected.
Comment 7 Ray Strode [halfline] 2012-11-14 11:32:31 EST
I don't think vncserver supports the COMPOSITE extension, so (if I'm right) I think that will need to be fixed first before your testing can begin.
Comment 8 IBM Bug Proxy 2012-11-19 14:30:40 EST
------- Comment From willschm@us.ibm.com 2012-11-19 19:24 EDT-------
(re-commenting with greater visibility)

> I don't think vncserver supports the COMPOSITE extension, so (if I'm right)
> I think that will need to be fixed first before your testing can begin.

We had a patch to specifically enable the Composite extension on Power a while back.  I *think* the patches have since gone upstream, per
commit 17a8e2bea2d18e2bab04dc9a24f919c924cc7dbd
Author: Adam Jackson <ajax <at> redhat.com>
Date:   Mon Jul 23 15:55:14 2012 -0400

To verify the composite extension was enabled in the build, we would run this within a vncserver session, and look for "Composite (opcode: 146) in the output.
xdpyinfo -queryExtensions | grep opcode(In reply to comment #13)
Comment 9 IBM Bug Proxy 2012-11-20 02:10:37 EST
------- Comment From mgrf@de.ibm.com 2012-11-20 07:07 EDT-------
Thanks for the update regarding vncserver and composite extension

What is the status with the package dependencies that is blocking our verification of 3D emulation?

I guess we should have finished that before Fedora 18 development cutoff - so time is short

(In reply to comment #11)
> > Hm.
> > We could add some architecture specifications to the environments in comps,
> >
> > For the specific issue, gnome-bluetooth probably needs to not be built on
> > s390, or have some requirements %ifarched in its spec file.
>
> I see two error messages (dependency)
>
> Error: Package: 1:gnome-bluetooth-3.4.0-2.fc17.s390x (F18-latest)
>            Requires: obexd
> Error: Package: 1:gnome-bluetooth-3.4.0-2.fc17.s390x (F18-latest)
>            Requires: pulseaudio-module-bluetooth
> Error: Package: gnome-boxes-3.6.1.1-1.fc18.s390x (F18-latest)
>            Requires: libvirt-daemon-kvm
> Error: Package: 1:gnome-bluetooth-3.4.0-2.fc17.s390x (F18-latest)
>            Requires: gvfs-obexftp
>
Comment 10 Dan Horák 2012-11-20 04:52:11 EST
Lets start with the easier one - gnome-boxes requires libvirt-kvm-daemon => libvirt will start providing libvirt-kvm-daemon on ppc64 and s390x in its next build, see bug #872545 for details

The gnome-bluetooth issue is more complicated, because a F-17 build is inherited to the F-18 composes
- the "gnome" group in comps lists gnome-bluetooth as the required package and the comps and the rel-eng tools don't provide a mechanism like ExcludeArch (see Bill's comment #3)
- also gnome-shell < 3.6.2-2.fc18 had gnome-bluetooth as hard-coded Requires (this is fixed now).

The options are either
a) to build the whole bluetooth stack, which is IMHO doable but will waste some disk/memory space
b) drop the ExcludeArch: s390(x) from gnome-bluetooth which was added during f18 development and rebuild it with the hard-coded obex/... dependencies skipped on s390(x)
c) to workaround the dependency issue (maybe Obsoletes: gnome-bluetooth in gnome-shell would work).
d) The last option to improve the rel-eng data and tools can be thought in the long term.
Comment 11 IBM Bug Proxy 2012-11-20 07:10:44 EST
------- Comment From mgrf@de.ibm.com 2012-11-20 12:05 EDT-------
Hi Dan,
yes either options c) or b)  - which is easier to implement
gnome-bluetooth is not required on z
Comment 12 Fedora Update System 2012-11-29 11:15:12 EST
gnome-bluetooth-3.6.1-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/gnome-bluetooth-3.6.1-2.fc18
Comment 13 Fedora Update System 2012-11-30 01:34:22 EST
Package gnome-bluetooth-3.6.1-2.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gnome-bluetooth-3.6.1-2.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-19370/gnome-bluetooth-3.6.1-2.fc18
then log in and leave karma (feedback).
Comment 14 IBM Bug Proxy 2012-12-04 03:30:54 EST
------- Comment From ssant@in.ibm.com 2012-12-04 08:27 EDT-------
With latest Fedora 18 build from Nov 28th this problem is fixed.

------- Comment From ssant@in.ibm.com 2012-12-04 08:28 EDT-------
Closing the report accordingly.
Comment 15 Fedora Update System 2012-12-06 23:24:55 EST
gnome-bluetooth-3.6.1-2.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.