Bug 87619 - Can't retrieve email messages
Summary: Can't retrieve email messages
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: evolution (Show other bugs)
(Show other bugs)
Version: 8.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-03-30 23:58 UTC by Brad
Modified: 2007-04-18 16:52 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-07-28 23:39:58 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screen dump of Evolution error (72.18 KB, image/jpeg)
2003-03-31 00:03 UTC, Brad
no flags Details
Details of the Evolution trace (2.79 KB, text/plain)
2003-04-02 06:31 UTC, Brad
no flags Details
Details of the Evolution trace (2.79 KB, text/plain)
2003-04-02 06:32 UTC, Brad
no flags Details
Details of the Evolution trace (2.79 KB, text/plain)
2003-04-02 06:33 UTC, Brad
no flags Details
Details of the Evolution trace (2.79 KB, text/plain)
2003-04-02 06:33 UTC, Brad
no flags Details
Details of the Evolution trace (2.79 KB, text/plain)
2003-04-02 06:34 UTC, Brad
no flags Details
Details of the Evolution trace (2.79 KB, text/plain)
2003-04-02 06:36 UTC, Brad
no flags Details

Description Brad 2003-03-30 23:58:25 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.9 (X11; Linux i686; U;) Gecko/20030314

Description of problem:
I have a Red Hat 7.3 mail server running kernel version 2.4.18-27.8.0, and a Red
Hat 8.0 mail client running kernel version 2.4.18-27.8.0 and using imap to
interogate the mail server. From rpm -qi on the mail server, the imap version  is:

imap-2001a-10.src.rpm

Often when I click on an unread message in my Inbox, I get "Error while
'Retrieving message xxxxx': No such file or directory." There is no hard disk
activity on the mail server when I do this, and it happens immeditely,
indicating to me that it is not even looking.

If I click on another message and then click back on the one with this error
message, often it will load OK, although sometimes I need to do this several
times to get it to load the email message.

This has only started to happen when I upgraded from evolution 1.0.8 to 1.2.3. 

Version-Release number of selected component (if applicable):
Evolution 1.2.3

How reproducible:
Sometimes

Steps to Reproduce:
1.Click on mail message
2. Read error in the middle of the screen.
3.
    

Additional info:

Comment 1 Brad 2003-03-31 00:03:04 UTC
Created attachment 90795 [details]
Screen dump of Evolution error

This is a typical error message.

Comment 2 Jeremy Katz 2003-04-02 05:42:08 UTC
Can you follow the instructions at 
http://support.ximian.com/cgi-bin/ximian.cfg/php/enduser/std_adp.php?&p_faqid=76
to get a trace of what's happening in the server traffic when you get this error?  

Also, are you connecting from more than one location to the mail server (as the
same user and accessing the same mailboxes)?

Comment 3 Brad 2003-04-02 06:31:09 UTC
Created attachment 90833 [details]
Details of the Evolution trace

Comment 4 Brad 2003-04-02 06:32:26 UTC
Created attachment 90834 [details]
Details of the Evolution trace

Comment 5 Brad 2003-04-02 06:33:18 UTC
Created attachment 90835 [details]
Details of the Evolution trace

Comment 6 Brad 2003-04-02 06:33:27 UTC
Created attachment 90836 [details]
Details of the Evolution trace

Comment 7 Brad 2003-04-02 06:34:34 UTC
Created attachment 90837 [details]
Details of the Evolution trace

Comment 8 Brad 2003-04-02 06:36:16 UTC
Created attachment 90838 [details]
Details of the Evolution trace

Comment 9 Brad 2003-04-02 06:37:19 UTC
We only have 2 x imap users on the mail server (and ~30 POP3 users) and both are
only connecting from one site each.

Please see attachment for the test results.

Comment 10 Brad 2003-04-02 06:41:24 UTC
Sorry about the multiple attachment files. It seems to re-submit the attachment
whenever you click "back" and then "forward" again.

Comment 11 Jeremy Katz 2003-04-09 00:52:03 UTC
Did you set CAMEL_VERBOSE_DEBUG before running here?  There doesn't seem to be
any of the verbose output.

Comment 12 Jeremy Katz 2003-07-28 23:39:58 UTC
Closing due to lack of activity.


Note You need to log in before you can comment on or make changes to this bug.