Bug 876223 - NFSISO installation doesn't use internally mounted DVD repo, instead uses Closest Mirror
NFSISO installation doesn't use internally mounted DVD repo, instead uses Clo...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
AcceptedBlocker
: Reopened
Depends On: 879187
Blocks: F18Blocker/F18FinalBlocker
  Show dependency treegraph
 
Reported: 2012-11-13 10:31 EST by Kamil Páral
Modified: 2013-01-10 01:57 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 08:59:04 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Kamil Páral 2012-11-13 10:31:55 EST
Description of problem:
I followed this test case:
https://fedoraproject.org/wiki/QA:Testcase_install_repository_NFSISO_variation

Older Fedora releases always used internal repository from the DVD.iso (mounted over NFS). That's the point of NFSISO, to use the mounted repository, otherwise I could have used inst.stage2 instead. But current Anaconda doesn't use the mounted repo, instead it defaults to Closest Mirror, and the internal repo can't even be selected in the GUI.

Version-Release number of selected component (if applicable):
F18 Beta TC8
anaconda 18.28

How reproducible:
always

Steps to Reproduce:
1. use the linked test case to boot with inst.repo=nfs:server:/path/dvd.iso
2. see Installation Source dialog
  
Actual results:
Closest Mirror is selected

Expected results:
internal DVD repo is selected

Additional info:
Please see bug 876218 comment 1 through bug 876218 comment 5 for installation logs.
Comment 1 Kamil Páral 2012-11-13 10:33:32 EST
I would argue this could be a F18 Final Blocker, because the major point of NFSISO support is to use the internal DVD repository, and that is broken, which violates:
" The installer must be able to use all supported local and remote package source options "
https://fedoraproject.org/wiki/Fedora_18_Final_Release_Criteria

But maybe other people will see it differently. Proposing, let's discuss.
Comment 2 Jesse Keating 2012-11-13 17:05:28 EST
I actually know what's causing this.  I fixed it partially for nfs, didn't quite fix it for nfsiso.
Comment 3 Jesse Keating 2012-11-13 17:16:30 EST
oh.  So I fixed it when you pass the inst.repo url that ends in the /directory/ holding the iso, but things are still odd when you pass the full url that includes the .iso file itself.  Working on that.
Comment 4 Paul Franklin (RHlists) 2012-11-13 19:28:49 EST
+1 Final blocker.
Comment 5 Kamil Páral 2012-11-14 07:07:48 EST
(In reply to comment #3)
> oh.  So I fixed it when you pass the inst.repo url that ends in the
> /directory/ holding the iso, but things are still odd when you pass the full
> url that includes the .iso file itself.  Working on that.

Jesse, the same problem applies for inst.repo=hd:<device>:<path>, no matter whether <path> is a directory or an .iso file. Do you want me to report a new bug, or you'll fix it as part of this one?
Comment 6 Jesse Keating 2012-11-14 12:46:23 EST
(In reply to comment #5)
> (In reply to comment #3)
> > oh.  So I fixed it when you pass the inst.repo url that ends in the
> > /directory/ holding the iso, but things are still odd when you pass the full
> > url that includes the .iso file itself.  Working on that.
> 
> Jesse, the same problem applies for inst.repo=hd:<device>:<path>, no matter
> whether <path> is a directory or an .iso file. Do you want me to report a
> new bug, or you'll fix it as part of this one?

That should be a new bug.  That's a slightly different bit of code, and the code for /this/ has a patch submitted.  The fix may be similar, but I don't want to convolute the two.
Comment 7 Fedora Update System 2012-11-20 17:03:11 EST
anaconda-18.29.2-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/FEDORA-2012-18468/anaconda-18.29.2-1.fc18
Comment 8 Fedora Update System 2012-11-21 15:51:39 EST
Package anaconda-18.29.2-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-18.29.2-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-18468/anaconda-18.29.2-1.fc18
then log in and leave karma (feedback).
Comment 9 Adam Williamson 2012-11-22 08:14:18 EST
Unfortunately I think the fix for this may have caused significant regressions in NFS functionality in RC1. See https://bugzilla.redhat.com/show_bug.cgi?id=879187 . (This may not be the cause, but it was the most closely-related change between TC9 and RC1 that I could see).
Comment 10 Kamil Páral 2012-11-22 11:12:57 EST
With anaconda 18.29.2 this is fixed with direct kernel boot, but with netinst I get the same traceback as in bug 879187.
Comment 11 Fedora Update System 2012-11-23 02:28:14 EST
anaconda-18.29.2-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Kamil Páral 2012-11-23 07:19:18 EST
Testing the fix requires having bug 879187 fixed first.
Comment 13 Adam Williamson 2012-12-03 14:53:32 EST
Discussed at 2012-12-03 blocker review meeting: http://meetbot.fedoraproject.org/fedora-qa/2012-12-03/f18final-blocker-review-1.2.2012-12-03-17.25.log.txt . We agreed that as written this is a blocker. We're 99% sure it's fixed already in Beta, but kparal wants to verify to his satisfaction before closing.
Comment 14 Kamil Páral 2012-12-04 08:59:04 EST
kparal is very satisfied now. He tested Beta netinst with the nfs workaround (remove inst.stage2 and use just inst.repo) and nfsiso worked great. He's closing the bug.
Comment 15 Adam Williamson 2012-12-05 03:55:30 EST
kparal will take questions in the blue room for seven minutes precisely. no autographs.

Note You need to log in before you can comment on or make changes to this bug.