This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 876304 - Documentation for pullback on STATISTICS_WINDOW_QUANTUM
Documentation for pullback on STATISTICS_WINDOW_QUANTUM
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: Grid_User_Guide (Show other bugs)
Development
All All
high Severity medium
: 2.3
: ---
Assigned To: David Ryan
Tomas Rusnak
: Documentation, Regression
Depends On: 869414
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-13 13:56 EST by Erik Erlandson
Modified: 2015-02-01 18:14 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-19 12:38:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Erik Erlandson 2012-11-13 13:56:41 EST
Description of problem:
To fix regression Bug 869414, new config vars were pulled back, and ought to be documented:
STATISTICS_WINDOW_QUANTUM
STATISTICS_WINDOW_SECONDS
STATISTICS_TO_PUBLISH


Additional info:

Here is the upstream doc LaTeX:

 	1380 	\label{param:​StatisticsToPublish}
	1381 	\item[\Macro{STATISTI​CS\_TO\_PUBLISH}]
	1382 	·​·​A·​comma·​and/​or·​space·​separated·​list·​that·​identifies·​which·​daemons·​are·​to
	1383 	·​·​publish·​Statistics·​attributes·​in·​their·​ClassAds,​·​as·​well·​as·​a·​level·​of
	1384 	·​·​verbosity·​to·​identify·​which·​attributes·​to·​include·​and·​which·​to·​omit·​from
	1385 	·​·​the·​ClassAd.​·​
	1386 	·​·​The·​syntax·​defines·​the·​two·​aspects·​by·​separating·​them·​with·​a·​colon;​
	1387 	·​·​the·​first·​aspect·​defines·​which·​daemon·​is·​to·​publish·​the·​statistics,​
	1388 	·​·​and·​the·​second·​aspect·​defines·​the·​verbosity.​
	1389 	·​·​This·​first·​aspect·​may·​be·​\Expr{SCHEDD}·​or·​\Expr{SCHEDULER}·​to·​publish
	1390 	·​·​Statistics·​attributes·​in·​the·​ClassAd·​of·​the·​\Condor{schedd}.​
	1391 	·​·​Or,​·​it·​may·​be·​\Expr{DC}·​or·​\Expr{DAEMONCORE}·​to·​publish·​
	1392 	·​·​DaemonCore·​statistics.​
	1393 	·​·​After·​the·​colon·​may·​be·​the·​value·​\Expr{0},​·​\Expr{1},​·​\Expr{2},​·​or·​\Expr{3}.​
	1394 	·​·​A·​value·​of·​·​\Expr{0}·​turns·​off·​the·​publishing·​of·​any·​Statistics·​attributes.​
	1395 	·​·​A·​value·​of·​·​\Expr{1}·​is·​the·​default·​level,​·​where·​some·​Statistics·​attributes
	1396 	·​·​are·​published·​and·​others·​are·​omitted.​
	1397 	·​·​A·​value·​of·​·​\Expr{2}·​is·​the·​verbose·​level,​·​where·​all·​Statistics·​attributes
	1398 	·​·​are·​published.​
	1399 	·​·​A·​value·​of·​·​\Expr{3}·​is·​the·​super·​verbose·​level,​·​which·​is·​currently·​unused,​
	1400 	·​·​but·​intended·​to·​be·​all·​Statistics·​attributes·​published·​at·​the·​verbose
	1401 	·​·​level·​plus·​extra·​information.​
	1402 	·​·​As·​an·​example,​·​to·​cause·​a·​verbose·​setting·​of·​the·​publication·​of·​Statistics
	1403 	·​·​attributes·​for·​the·​\Condor{schedd}:​
	1404 	\begin{verbatim}
	1405 	·​·​STATISTICS_TO_PUBLISH​·​=·​SCHEDD:​2
	1406 	\end{verbatim}
	1407 	·​·​
	1408 	\label{param:​StatisticsWindowSecon​ds}
	1409 	\item[\Macro{STATISTI​CS\_WINDOW\_SECONDS}]​
	1410 	·​·​An·​integer·​value·​that·​controls·​the·​time·​window·​size,​·​in·​seconds,​·​for
	1411 	·​·​collecting·​windowed·​daemon·​statistics·​(by·​convention,​·​windowed·​statistics
	1412 	·​·​typically·​are·​of·​the·​form·​'RecentXxx')​.​·​·​Any·​data·​contributing·​to·​a
	1413 	·​·​windowed·​statistic·​that·​is·​older·​than·​this·​number·​of·​seconds·​is·​dropped
	1414 	·​·​from·​the·​statistic.​·​·​For·​example·​if·​\Macro{STATISTICS\_WI​NDOW\_SECONDS}·​=·​300,​·​then
	1415 	·​·​any·​jobs·​submitted·​more·​than·​300·​seconds·​ago·​are·​not·​counted·​in·​the·​windowed
	1416 	·​·​statistic·​\Attr{RecentJobsSubmi​tted}.​·​·​Defaults·​to·​1200.​
	1417 	
	1418 	·​·​Configuration·​variables·​of·​the·​form·​\Macro{STATISTICS\_WI​NDOW\_SECONDS\_<colle​ction>}
	1419 	·​·​override·​the·​global·​setting·​for·​a·​particular·​statistic·​collection.​·​·​Collection·​names
	1420 	·​·​currently·​implemented·​are·​'DC'·​(or·​'DAEMONCORE')​·​and·​'SCHEDD'·​(or·​'SCHEDULER')​
	1421 	
	1422 	\label{param:​StatisticsWindowQuant​um}
	1423 	\item[\Macro{STATISTI​CS\_WINDOW\_QUANTUM}]​
	1424 	·​·​An·​integer·​value·​that·​controls·​the·​time·​quantization,​·​in·​seconds,​·​for·​the·​data·​structures·​
	1425 	·​·​that·​maintain·​windowed·​statistics.​·​·​Defaults·​to·​240.​·​·​·​Smaller·​values·​yield·​higher
	1426 	·​·​time·​resolution·​and·​reduce·​'sawtoothing'·​of·​windowed·​statistic·​values,​·​at·​the·​expense·​of
	1427 	·​·​requiring·​larger·​data·​structures·​for·​maintenance.​
	1428 	
	1429 	·​·​Configuration·​variables·​of·​the·​form·​\Macro{STATISTICS\_WI​NDOW\_QUANTUM\_<colle​ction>}
	1430 	·​·​override·​the·​global·​setting·​for·​a·​particular·​statistic·​collection.​
Comment 3 Tomas Rusnak 2013-02-19 07:48:28 EST
Documentation for following paramaters was added into A.3. System wide configuration file variables chapter:

STATISTICS_WINDOW_QUANTUM
STATISTICS_WINDOW_SECONDS
STATISTICS_TO_PUBLISH

>>> VERIFIED

Note You need to log in before you can comment on or make changes to this bug.