Bug 876334 - haproxy runs as initrc_t
Summary: haproxy runs as initrc_t
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: selinux-policy
Version: 6.3
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Miroslav Grepl
QA Contact: Milos Malik
URL:
Whiteboard:
Depends On:
Blocks: 832330
TreeView+ depends on / blocked
 
Reported: 2012-11-13 20:56 UTC by Milos Malik
Modified: 2013-11-21 10:10 UTC (History)
1 user (show)

Fixed In Version: selinux-policy-3.7.19-208.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-11-21 10:10:40 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1598 0 normal SHIPPED_LIVE selinux-policy bug fix and enhancement update 2013-11-20 21:39:24 UTC

Description Milos Malik 2012-11-13 20:56:50 UTC
Description of problem:


Version-Release number of selected component (if applicable):
haproxy-1.4.22-4.el6op.x86_64
selinux-policy-3.7.19-179.el6.noarch
selinux-policy-targeted-3.7.19-179.el6.noarch

How reproducible:
always

Steps to Reproduce:
# service haproxy status
haproxy is stopped
# ps -efZ | grep haproxy
unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 root 19554 19502  0 23:53 pts/0 00:00:00 grep haproxy
# service haproxy start
Starting haproxy:                                          [  OK  ]
# service haproxy status
haproxy (pid  19567) is running...
# ps -efZ | grep haproxy
unconfined_u:system_r:initrc_t:s0 haproxy 19567    1  0 23:53 ?        00:00:00 /usr/sbin/haproxy -D -f /etc/haproxy/haproxy.cfg -p /var/run/haproxy.pid
unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 root 19579 19502  0 23:54 pts/0 00:00:00 grep haproxy
#

Actual results:
* haproxy runs as initrc_t

Expected results:
 * haproxy runs in its own SELinux domain

Comment 1 Miroslav Grepl 2012-11-14 09:56:44 UTC
Does it cause any issue? If no, I would move it.

Comment 2 Milos Malik 2012-11-14 11:08:47 UTC
No issues found.

Comment 7 errata-xmlrpc 2013-11-21 10:10:40 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1598.html


Note You need to log in before you can comment on or make changes to this bug.