Bug 876444 - RHEL guest cannot extend its desktop to 2nd monitor after connect to it with remote-viewer for several times
Summary: RHEL guest cannot extend its desktop to 2nd monitor after connect to it with ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-viewer
Version: 6.4
Hardware: x86_64
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: Marc-Andre Lureau
QA Contact: Virtualization Bugs
URL:
Whiteboard:
: 908822 (view as bug list)
Depends On:
Blocks: 960054 920988 947046
TreeView+ depends on / blocked
 
Reported: 2012-11-14 07:35 UTC by Geyang Kong
Modified: 2013-11-21 08:04 UTC (History)
15 users (show)

Fixed In Version: virt-viewer-0.5.6-1.el6
Doc Type: Bug Fix
Doc Text:
Cause: Runing virt-viewer in fullscreen. Consequence: Randomly creates mirror monitors. Fix: Keep the association of client window and monitors. Result: Extra monitors are can no longer become mirror monitor randomly.
Clone Of:
: 920988 (view as bug list)
Environment:
Last Closed: 2013-11-21 08:04:11 UTC
Target Upstream Version:


Attachments (Terms of Use)
debug log (209.41 KB, text/plain)
2012-11-14 07:36 UTC, Geyang Kong
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1578 normal SHIPPED_LIVE virt-viewer bug fix and enhancement update 2013-11-20 21:39:50 UTC

Description Geyang Kong 2012-11-14 07:35:25 UTC
Description of problem:
  RHEL guest cannot extend its desktop to 2nd monitor after connect to it with remote-viewer for several times.

Version-Release number of selected component (if applicable):
virt-viewer-0.5.2-16.el6.x86_64
spice-server-0.12.0-2.el6.x86_64
spice-glib-0.14-5.el6.x86_64
spice-gtk-tools-0.14-5.el6.x86_64
spice-gtk-python-0.14-5.el6.x86_64
spice-vdagent-0.8.1-3.el6.x86_64
spice-gtk-0.14-5.el6.x86_64
spice-protocol-0.12.2-1.el6.noarch

How reproducible:
Sometimes, about 95%

Reproduce steps:
1. Have a notebook computer and plugged another display to its VGA interface.
2. Install a rhel guest on it, make sure it has spice+qxl device and spicevmc channel.
3. Update spice-vdagent and xorg-x11-drv-qxl
4. Run remote-viewer spice://127.0.0.1:5900 --full-screen=auto-conf
5. Close remote-viewer.
6. Repeat step 4 and 5 for several times.

Actual results:
1. After step 6, 2nd monitor becomes to a mirrored one.

Expected results:
1. 2nd monitor should be an extended monitor.

Additional info:

Comment 1 Geyang Kong 2012-11-14 07:36:47 UTC
Created attachment 644605 [details]
debug log

Comment 3 Marian Krcmarik 2012-12-04 19:52:23 UTC
I can reproduce this:
1. Get dual screen physical setup.
2. Connect to a guest with remote-viewer.
3. Go to fullscreen (even with one guest screen VM).
4. change resolution within the guest

-> suddenly two mirrored screen shows up.

Note sure this is a bug of virt-viewer, mostl likely spice-vdagent.

Comment 6 Marc-Andre Lureau 2013-05-09 23:34:06 UTC
*** Bug 908822 has been marked as a duplicate of this bug. ***

Comment 15 CongDong 2013-07-08 03:26:11 UTC
I can reproduce this bug:

Version and Steps are same as description.

result:
1. After step 6, 2nd monitor becomes to a mirrored one.

Verify:
# rpm -qa | grep spice
spice-gtk-0.20-1.el6.x86_64
spice-client-0.8.2-15.el6.x86_64
spice-glib-0.20-1.el6.x86_64
spice-vdagent-0.14.0-1.el6.x86_64
spice-server-0.12.3-1.el6.x86_64
spice-gtk-python-0.20-1.el6.x86_64
# rpm -qa virt-viewer
virt-viewer-0.5.6-1.el6.x86_64

Steps:
Same as description.

Result:
2nd monitor should be an extended monitor.

Comment 17 errata-xmlrpc 2013-11-21 08:04:11 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1578.html


Note You need to log in before you can comment on or make changes to this bug.