Bug 876445 - Title bar of second form becomes invisible when connect to a RHEL guest with 2nd monitor through remote-viewer.
Summary: Title bar of second form becomes invisible when connect to a RHEL guest with ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-viewer
Version: 6.4
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Marc-Andre Lureau
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-11-14 07:35 UTC by Geyang Kong
Modified: 2013-11-21 08:04 UTC (History)
13 users (show)

Fixed In Version: virt-viewer-0.5.6-1.el6
Doc Type: Bug Fix
Doc Text:
Cause: Leaving fullscreen state. Consequence: The title bar of the client window is hidden. Fix: Wait until the window is mapped before going fullscreen, to workaround metacity issue. Result: When leaving fullscreen, the client window title is visible and reachable.
Clone Of:
Environment:
Last Closed: 2013-11-21 08:04:35 UTC
Target Upstream Version:


Attachments (Terms of Use)
simpler reproducer, showing perhaps a gtk or metacity issue (1.09 KB, text/x-chdr)
2013-05-16 14:41 UTC, Marc-Andre Lureau
no flags Details
simpler reproducer, showing perhaps a gtk or metacity issue (1.74 KB, text/x-chdr)
2013-05-16 18:00 UTC, Marc-Andre Lureau
no flags Details
metacity log (380.82 KB, text/plain)
2013-05-16 18:10 UTC, Marc-Andre Lureau
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1578 normal SHIPPED_LIVE virt-viewer bug fix and enhancement update 2013-11-20 21:39:50 UTC

Description Geyang Kong 2012-11-14 07:35:27 UTC
Description of problem:
  Title bar of second form becomes invisible when connect to a RHEL guest with 2nd monitor through remote-viewer.

Version-Release number of selected component (if applicable):
virt-viewer-0.5.2-16.el6.x86_64
spice-server-0.12.0-2.el6.x86_64
spice-glib-0.14-5.el6.x86_64
spice-gtk-tools-0.14-5.el6.x86_64
spice-gtk-python-0.14-5.el6.x86_64
spice-vdagent-0.8.1-3.el6.x86_64
spice-gtk-0.14-5.el6.x86_64
spice-protocol-0.12.2-1.el6.noarch

How reproducible:
Sometimes, about 70%

Reproduce steps:
1. Have a notebook computer and plugged another display to its VGA interface.
2. Install a rhel guest on it, make sure it has spice+qxl device and spicevmc channel.
3. Update spice-vdagent and xorg-x11-drv-qxl
4. Run remote-viewer spice://127.0.0.1:5900 --full-screen=auto-conf
5. Leave full-screen mode.
6. Check console forms.

Actual results:
1. After step 6, first form becomes to normal size and I can visit its title bar and re-size it.
2. After step 6, second form only displays its menus but I cannot visit its title bar and cannot re-size it, click View->Zoom->Zoom In/Zoom Out/Normal Size will not work.

Expected results:
1. After step 6, second form should have same behaviors as the first one.

Additional info:

Comment 4 Marc-Andre Lureau 2013-05-14 14:12:10 UTC
I am working on it

Comment 5 Marc-Andre Lureau 2013-05-15 12:05:01 UTC
the metacity "force fullscreen" behaviour is somehow tricky to workaround. All the hacks I can think of end up being racy. We may need two seperate windows for fullscreen and window mode..

Comment 6 Marc-Andre Lureau 2013-05-16 14:41:49 UTC
Created attachment 748884 [details]
simpler reproducer, showing perhaps a gtk or metacity issue

Comment 7 Marc-Andre Lureau 2013-05-16 18:00:53 UTC
Created attachment 748986 [details]
simpler reproducer, showing perhaps a gtk or metacity issue

Comment 8 Marc-Andre Lureau 2013-05-16 18:10:51 UTC
Created attachment 748988 [details]
metacity log

Comment 9 Marc-Andre Lureau 2013-05-16 19:34:40 UTC
sent a workaround patch to ML, thanks to Owen help!

https://www.redhat.com/archives/virt-tools-list/2013-May/msg00053.html

Comment 14 CongDong 2013-07-04 10:39:33 UTC
I can reproduce this:

Version
# rpm -qa virt-viewer
virt-viewer-0.5.2-18.el6_4.2.x86_64
# rpm -qa | grep spice
spice-gtk-0.20-1.el6.x86_64
spice-server-0.12.3-1.el6.x86_64
spice-vdagent-0.14.0-1.el6.x86_64
spice-gtk-python-0.20-1.el6.x86_64
spice-client-0.8.2-15.el6.x86_64
spice-glib-0.20-1.el6.x86_64
spice-protocol-0.12.2-1.el6.noarch

Steps:
1. Have a spice guest run on the host with 2 mirrors.
2. #  remote-viewer spice://127.0.0.1:5900 --full-screen=auto-conf
3. Leave full-screen mode.
4. Check console forms.

Result:
1. After step 3, first form becomes to normal size and I can visit its title bar and re-size it.
2. After step 4, second form only displays its menus but I cannot visit its title bar.

Verify:
Version:
# rpm -qa virt-viewer
virt-viewer-0.5.6-1.el6.x86_64
# rpm -qa | grep spice
spice-gtk-0.20-1.el6.x86_64
spice-gtk-python-0.20-1.el6.x86_64
spice-vdagent-0.14.0-1.el6.x86_64
spice-server-0.12.3-1.el6.x86_64
spice-glib-0.20-1.el6.x86_64

Steps:
As the steps above.

Result:
After step 3, the two window both have the title bar, and work well.

Comment 16 errata-xmlrpc 2013-11-21 08:04:35 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1578.html


Note You need to log in before you can comment on or make changes to this bug.