Bug 876504 - [whql][wlk][block] viostor driver for win2k3 does not support s4
[whql][wlk][block] viostor driver for win2k3 does not support s4
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virtio-win (Show other bugs)
6.4
Unspecified Unspecified
urgent Severity urgent
: rc
: ---
Assigned To: Vadim Rozenfeld
Virtualization Bugs
: Regression, TestBlocker
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-14 05:02 EST by dawu
Modified: 2013-02-21 05:42 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 05:42:20 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
2k3-notSupportS4 (37.67 KB, image/png)
2012-11-14 05:06 EST, dawu
no flags Details

  None (edit)
Description dawu 2012-11-14 05:02:32 EST
Description of problem:
Viostor driver for win2k3 does not support s4

Version-Release number of selected component (if applicable):
virtio-win-prewhql-43
win2k3 32/64

How reproducible:
100%

Steps to Reproduce:
1.Start VM with virtio-block
CLI:/usr/libexec/qemu-kvm -M rhel6.4.0 -m 2G -smp 4 -cpu cpu64-rhel6,+x2apic -usbdevice tablet -drive file=win2k3-32.raw,format=raw,if=none,id=drive-virtio0,boot=on,cache=none,werror=stop,rerror=stop -device virtio-blk-pci,drive=drive-virtio0,id=virtio-blk-pci0,bootindex=1 -netdev tap,sndbuf=0,id=hostnet0,script=/etc/qemu-ifup,downscript=no -device rtl8139,netdev=hostnet0,mac=00:11:1a:06:33:26,bus=pci.0,addr=0x4 -boot c -uuid 7768409c-460c-4deb-ba44-7570b2cab3c6 -rtc base=localtime,clock=host,driftfix=slew -no-kvm-pit-reinjection -chardev socket,id=111a,path=/tmp/2k3-32-blk-43-new,server,nowait -mon chardev=111a,mode=readline -name win2k3-32-blk-new -vnc :1 -drive file=disk1.raw,if=none,id=drive-virtio1,cache=none,werror=stop,rerror=stop -device virtio-blk-pci,drive=drive-virtio1,id=virtio-blk-pci1 -drive file=disk2.raw,if=none,id=drive-virtio2,cache=none,werror=stop,rerror=stop -device virtio-blk-pci,drive=drive-virtio2,id=virtio-blk-pci2 -drive file=disk3.raw,if=none,id=drive-virtio3,cache=none,werror=stop,rerror=stop -device virtio-blk-pci,drive=drive-virtio3,id=virtio-blk-pci3 -drive file=disk4.raw,if=none,id=drive-virtio4,cache=none,werror=stop,rerror=stop -device virtio-blk-pci,drive=drive-virtio4,id=virtio-blk-pci4 -global PIIX4_PM.disable_s3=0 -global PIIX4_PM.disable_s4=0 -monitor stdio

2. Enable S4 on win2k3 guest with cmd : powercfg -H on
   S4 can be enabled
3. do S4 
  
Actual results:
win2k3 failed to do S4 with error "The storage drivers do not support hibernate"
and can not enable the S4 any more,please refer to the attachment for details

Expected results:
Win2k3 can do S4 successfully.

Additional info:
Whql job “common scenario stress with IO" and "sleep with IO" job failed due to this bug.
Tried on virtio-win-1.5.3.iso ,can support S4 and do S4 successfully .mark this bug as regression
Comment 1 dawu 2012-11-14 05:06:07 EST
Created attachment 644726 [details]
2k3-notSupportS4
Comment 4 Vadim Rozenfeld 2012-11-22 03:15:37 EST
Hi Dawn,

Could you please try drivers from build 46 available at
http://download.devel.redhat.com/brewroot/packages/virtio-win-prewhql/0.1/46/win/virtio-win-prewhql-0.1.zip ?

Thank you,
Vadim.
Comment 5 dawu 2012-11-22 04:52:26 EST
(In reply to comment #4)
> Hi Dawn,
> 
> Could you please try drivers from build 46 available at
> http://download.devel.redhat.com/brewroot/packages/virtio-win-prewhql/0.1/46/
> win/virtio-win-prewhql-0.1.zip ?
> 
> Thank you,
> Vadim.

Hi Vadim,

I have tried on build 46 with manually testing, this issue doesn't reproduce any more, but maybe we need to keep the bug open till the whql pass this job.

Thanks for your efforts,

Best Regards,
Dawn
Comment 6 Vadim Rozenfeld 2012-11-22 04:58:29 EST
(In reply to comment #5)
> (In reply to comment #4)
> > Hi Dawn,
> > 
> > Could you please try drivers from build 46 available at
> > http://download.devel.redhat.com/brewroot/packages/virtio-win-prewhql/0.1/46/
> > win/virtio-win-prewhql-0.1.zip ?
> > 
> > Thank you,
> > Vadim.
> 
> Hi Vadim,
> 
> I have tried on build 46 with manually testing, this issue doesn't reproduce
> any more, but maybe we need to keep the bug open till the whql pass this job.
> 

absolutely, let's wait until we sure that everything works fine.
Thank you,
Vadim.
 
> Thanks for your efforts,
> 
> Best Regards,
> Dawn
Comment 7 dawu 2012-12-06 22:33:39 EST
Reproduce this bug on virtio-win-prewhql-43, verified this bug on virtio-win-prewhql-48 with the same steps in comment #0, also verified this bug on virtio-win-prewhql-48 for related whql jobs “common scenario stress with IO" and "sleep with IO":

Actually Results:
on version virtio-win-prewhql-43, can reproduce this bug.
on version virtio-win-prewhql-48, this issue doesn't reproduce any more.
Based on above this issue has been fixed.

Thanks!

Best Regards,
Dawn
Comment 8 Mike Cao 2013-01-07 04:42:49 EST
SCSI WHQL job passed on virtio-win-prewhql-49 
Based on above ,this issue has been fixed 
move status to verified.
Comment 9 errata-xmlrpc 2013-02-21 05:42:20 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0441.html

Note You need to log in before you can comment on or make changes to this bug.