Bug 876534 - [regression] unable to boot from usb-host devices
[regression] unable to boot from usb-host devices
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Gerd Hoffmann
Virtualization Bugs
: Regression
Depends On:
Blocks: 876112
  Show dependency treegraph
 
Reported: 2012-11-14 06:08 EST by Paolo Bonzini
Modified: 2013-02-21 02:44 EST (History)
9 users (show)

See Also:
Fixed In Version: qemu-kvm-0.12.1.2-2.336.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 876112
Environment:
Last Closed: 2013-02-21 02:44:24 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Paolo Bonzini 2012-11-14 06:08:36 EST
The commit below was backported on RHEL6 as f7c85aba63fb55cea2cdb3c5011074cb386c9902.

Reproduced on qemu-kvm-0.12.1.2-2.334.el6 with this command (and also with -device usb-host):

/usr/libexec/qemu-kvm \
   -device usb-ehci -usbdevice host:0x13fe:0x3600 -boot menu=on

Reverting the commit fixes it.

+++ This bug was initially created as a clone of Bug #876112 +++

Description of problem:
USB flash drive passed ass usb-host gets skipped at boot.

Version-Release number of selected component (if applicable):
qemu-kvm-1.2.0-18.el7
Upstream since commit a844ed842d9a9d929645c09ae0f52f753d7a02e0
    usb-host: attach only to running guest

How reproducible:
Always.

Steps to Reproduce:
Run qemu with -device usb-host,hostbus=2,hostaddr=4,id=hostdev0,bootindex=1
  
Actual results:
Machine boots from the drive next in the boot order.

Expected results:
The machine will boot from the USB drive.

Additional info:
It doesn't appear in the boot menu either.
Comment 2 Gerd Hoffmann 2012-11-14 10:13:15 EST
http://patchwork.ozlabs.org/patch/198932/
Comment 3 Gerd Hoffmann 2012-11-16 10:05:37 EST
Patch posted.
Comment 4 Gerd Hoffmann 2012-11-19 05:58:40 EST
*** Bug 877927 has been marked as a duplicate of this bug. ***
Comment 7 Sibiao Luo 2012-11-23 02:46:32 EST
Reproduce this bug on qemu-kvm-0.12.1.2-2.334.el6.x86_64.
host info:
# uname -r && rpm -q qemu-kvm
2.6.32-342.el6.x86_64
qemu-kvm-0.12.1.2-2.334.el6.x86_64

Steps:
1.boot a guest with "-boot menu=on"  and attach a physical usb stick.
eg: ...-boot menu=on -readconfig /home/ich9-ehci-uhci.cfg -device usb-host,hostbus=2,hostaddr=3,id=hostdev2,bus=ehci.0,port=2
2.press F12 during POST to check the boot order.

Result:
after the step 2, there is no usb stick in the boot order, like:
Press F12 for boot menu.

Select boot device:

1. virtio-scsi Drive QEMU QEMU HARDDISK 0.12
2. virtio-scsi Drive QEMU QEMU HARDDISK 0.12
3. gPXE (PCI 00:05.0)
4. Legacy option rom

------------------------------------------------------------------
Verify this bug on qemu-kvm-0.12.1.2-2.337.el6.x86_64.
host info:
# uname -r && rpm -q qemu-kvm
2.6.32-342.el6.x86_64
qemu-kvm-0.12.1.2-2.337.el6.x86_64

Steps:
the same to reproduce

Result:
after the step 2, the usb stick is in the boot order, like:
Press F12 for boot menu.

Select boot device:

1. USB MSC Drive Kingston DT 101 G2 PMAP    <-----existing!
2. virtio-scsi Drive QEMU QEMU HARDDISK 0.12
3. virtio-scsi Drive QEMU QEMU HARDDISK 0.12
4. gPXE (PCI 00:05.0)
5. Legacy option rom

Base on above, this issue has been fixed correctly.
Comment 9 errata-xmlrpc 2013-02-21 02:44:24 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0527.html

Note You need to log in before you can comment on or make changes to this bug.