Bug 876547 - ValueError: ('invalid size specification', '-472.028417969 mb')
ValueError: ('invalid size specification', '-472.028417969 mb')
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
abrt_hash:1cc8ca089271e56ad872d1359bb...
:
Depends On:
Blocks: F18Blocker/F18FinalBlocker
  Show dependency treegraph
 
Reported: 2012-11-14 07:19 EST by Kamil Páral
Modified: 2014-07-29 04:31 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-07 23:30:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (170.71 KB, text/plain)
2012-11-14 07:19 EST, Kamil Páral
no flags Details
File: product (6 bytes, text/plain)
2012-11-14 07:19 EST, Kamil Páral
no flags Details
File: type (9 bytes, text/plain)
2012-11-14 07:19 EST, Kamil Páral
no flags Details
File: ifcfg.log (641 bytes, text/plain)
2012-11-14 07:19 EST, Kamil Páral
no flags Details
File: storage.log (47.20 KB, text/plain)
2012-11-14 07:19 EST, Kamil Páral
no flags Details
File: version (11 bytes, text/plain)
2012-11-14 07:19 EST, Kamil Páral
no flags Details
File: environ (743 bytes, text/plain)
2012-11-14 07:19 EST, Kamil Páral
no flags Details
File: executable (14 bytes, text/plain)
2012-11-14 07:19 EST, Kamil Páral
no flags Details
File: anaconda.log (5.60 KB, text/plain)
2012-11-14 07:19 EST, Kamil Páral
no flags Details
File: syslog (59.26 KB, text/plain)
2012-11-14 07:19 EST, Kamil Páral
no flags Details
File: hashmarkername (8 bytes, text/plain)
2012-11-14 07:19 EST, Kamil Páral
no flags Details
File: packaging.log (2.84 KB, text/plain)
2012-11-14 07:19 EST, Kamil Páral
no flags Details
File: cmdline_file (26 bytes, text/plain)
2012-11-14 07:19 EST, Kamil Páral
no flags Details
File: release (24 bytes, text/plain)
2012-11-14 07:19 EST, Kamil Páral
no flags Details
File: program.log (26.23 KB, text/plain)
2012-11-14 07:19 EST, Kamil Páral
no flags Details
partitioning dialog (62.55 KB, image/png)
2012-11-15 04:16 EST, Kamil Páral
no flags Details

  None (edit)
Description Kamil Páral 2012-11-14 07:19:02 EST
Description of problem:
This happened when I copied DVD.iso to a local partition and pxe-booted the installer with inst.repo=hd:vda1:/dvd.iso. The crash occured after clicking Reclaim Space button in the initial "you don't have enough free space" dialog.

Version-Release number of selected component:
anaconda-18.28

Additional info:
libreport version: 2.0.17
cmdline:        /usr/bin/python  /sbin/anaconda
kernel:         3.6.6-3.fc18.x86_64

description:
:The following was filed automatically by anaconda:
:anaconda 18.28 exception report
:Traceback (most recent call first):
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/size.py", line 79, in _parseSpec
:    raise ValueError("invalid size specification", spec)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/size.py", line 137, in __new__
:    self = Decimal.__new__(cls, value=_parseSpec(spec))
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/lib/resize.py", line 55, in size_str
:    return str(Size(spec=spec)).upper()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/lib/resize.py", line 151, in populate
:    _("%s of %s") % (size_str(freeSize), size_str(dev.size)),
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/lib/resize.py", line 197, in refresh
:    self.populate(disks)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/storage.py", line 739, in on_continue_clicked
:    resizeDialog.refresh(disks)
:ValueError: ('invalid size specification', '-472.028417969 mb')
Comment 1 Kamil Páral 2012-11-14 07:19:06 EST
Created attachment 644780 [details]
File: anaconda-tb
Comment 2 Kamil Páral 2012-11-14 07:19:09 EST
Created attachment 644781 [details]
File: product
Comment 3 Kamil Páral 2012-11-14 07:19:12 EST
Created attachment 644782 [details]
File: type
Comment 4 Kamil Páral 2012-11-14 07:19:15 EST
Created attachment 644783 [details]
File: ifcfg.log
Comment 5 Kamil Páral 2012-11-14 07:19:18 EST
Created attachment 644784 [details]
File: storage.log
Comment 6 Kamil Páral 2012-11-14 07:19:21 EST
Created attachment 644785 [details]
File: version
Comment 7 Kamil Páral 2012-11-14 07:19:23 EST
Created attachment 644786 [details]
File: environ
Comment 8 Kamil Páral 2012-11-14 07:19:26 EST
Created attachment 644787 [details]
File: executable
Comment 9 Kamil Páral 2012-11-14 07:19:28 EST
Created attachment 644788 [details]
File: anaconda.log
Comment 10 Kamil Páral 2012-11-14 07:19:30 EST
Created attachment 644789 [details]
File: syslog
Comment 11 Kamil Páral 2012-11-14 07:19:32 EST
Created attachment 644790 [details]
File: hashmarkername
Comment 12 Kamil Páral 2012-11-14 07:19:34 EST
Created attachment 644791 [details]
File: packaging.log
Comment 13 Kamil Páral 2012-11-14 07:19:37 EST
Created attachment 644792 [details]
File: cmdline_file
Comment 14 Kamil Páral 2012-11-14 07:19:39 EST
Created attachment 644793 [details]
File: release
Comment 15 Kamil Páral 2012-11-14 07:19:42 EST
Created attachment 644794 [details]
File: program.log
Comment 16 Kamil Páral 2012-11-14 07:20:32 EST
This seems to be a blocker:
 The installer must be able to use all supported local and remote package source options 
https://fedoraproject.org/wiki/Fedora_18_Final_Release_Criteria

Relevant test case:
https://fedoraproject.org/wiki/QA:Testcase_install_repository_Hard_drive_variation
Comment 17 Kamil Páral 2012-11-14 13:23:14 EST
I've just hit that again and this time I wasn't doing any inst.repo=hd: magic. Therefore it is probably more related to the actual disk contents.
Comment 18 Kamil Páral 2012-11-15 04:16:18 EST
Created attachment 645518 [details]
partitioning dialog

This is a related screenshot of the partitioning screen. Note how wrong it is, it says I have enough space and that I don't have enough space. After I click Reclaim Space, it crashes with the error above.
Comment 19 Kamil Páral 2012-11-23 07:48:32 EST
Hit Reclaim Space.

Package: anaconda-18.29.2
Architecture: i686
OS Release: Fedora release 18-Beta
Comment 20 Adam Williamson 2012-11-29 13:59:40 EST
Discussed at 2012-11-29 blocker review meeting: http://meetbot.fedoraproject.org/fedora-qa/2012-11-29/f18final-blocker-review-1.1.2012-11-29-17.01.log.txt . We don't yet have enough information on what's required to trigger this or enough people reproducing it to call it a blocker, but it's clearly a bad bug, so we are punting on it in the hopes that more information will show up.
Comment 21 Fedora Update System 2012-12-05 20:55:13 EST
anaconda-18.36-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.36-1.fc18
Comment 22 Fedora Update System 2012-12-06 15:17:45 EST
Package anaconda-18.36-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-18.36-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-19870/anaconda-18.36-1.fc18
then log in and leave karma (feedback).
Comment 23 Kamil Páral 2012-12-07 05:24:33 EST
I have repeated the procedure mentioned in the description, all is OK. But as comment 17 says, this was probably related to disk contents rather than install method, and I don't know how to verify that.

Anaconda devs, if you know some reproducer, I can try to re-verify, otherwise we just have to believe it works now.
Comment 24 Fedora Update System 2012-12-07 23:30:32 EST
anaconda-18.36-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.