Bug 876742 - [fix available] manipulation with larger tables in impress is very slow [NEEDINFO]
Summary: [fix available] manipulation with larger tables in impress is very slow
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libreoffice   
(Show other bugs)
Version: 6.3
Hardware: Unspecified
OS: Linux
unspecified
low
Target Milestone: rc
: ---
Assignee: David Tardon
QA Contact: Desktop QE
URL:
Whiteboard:
Keywords: Performance
Depends On:
Blocks: 960054
TreeView+ depends on / blocked
 
Reported: 2012-11-14 20:29 UTC by Mike Hitchcock
Modified: 2013-11-21 10:04 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Poor implementation of tables causing an internal copy of the table on every operation and a slow traversal of table contents Consequence: Slow operations on large tables Fix: Optimize table contents traversal. Result: Tables can be operated on in a responsive manner.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-21 10:04:11 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
tpelka: needinfo? (mhitchco)


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1594 normal SHIPPED_LIVE libreoffice bug fix and enhancement update 2013-11-20 22:04:20 UTC

Description Mike Hitchcock 2012-11-14 20:29:16 UTC
Description of problem: Libre Office Impress runs very slow when you have many slides and multiple object per slide.


Version-Release number of selected component (if applicable):


How reproducible: Very easily reproduced. 


Steps to Reproduce:
1. Create LibreOffice Impress presentation 
2. Add 20 slides
3. Add tables with at least 13 rows and 5 columns. Move the object around and create new rows 
  
Actual results: When moving objects, it sometimes took over 15 seconds for the object to finally move


Expected results: The results were consistently slow as expected.


Additional info: Tried clearing ~/.libreoffice with no success.
Tried turning off Hardware Acceleration
Tried increasing Graphics Cache to 100MB in LibreOffice

Comment 2 David Tardon 2013-02-01 11:58:31 UTC
We missed this one, sorry...

Yes, larger tables in impress are a pain. Let's see if I can speed it up a bit.

Comment 3 David Tardon 2013-03-23 09:19:52 UTC
fixed upstream by commit 91864e19c84ae9834d6e97ee5ddc4db5bf957681

Comment 8 errata-xmlrpc 2013-11-21 10:04:11 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1594.html


Note You need to log in before you can comment on or make changes to this bug.