Bug 87675 - ATI Radeon 9500 Crashing
ATI Radeon 9500 Crashing
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
athlon Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2003-03-31 22:58 EST by Randy Armstrong
Modified: 2007-04-18 12:52 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-09-30 11:40:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
XF86Config (3.12 KB, text/plain)
2003-04-02 21:56 EST, Randy Armstrong
no flags Details
XF86Config (3.12 KB, text/plain)
2003-04-02 21:57 EST, Randy Armstrong
no flags Details
XFree86.0.log (36.40 KB, text/plain)
2003-04-02 21:58 EST, Randy Armstrong
no flags Details

  None (edit)
Description Randy Armstrong 2003-03-31 22:58:19 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

Description of problem:
When I installed Red Hat 9.0 the auto configure tool chose my card as a 9500 
PRO, but it is in fact a 9500 non-pro. I was in luck becuase my card was in the 
list so I chose the correct one. Once the install was complete I look in the 
hardware manager and my card was still a 9500 PRO. Here is my real problem. 
Randomly during use of KDE or GNOME my computer would hang and there was 
nothing I could do about it. My mouse wouldnt move and my keyboard lightere 
were flickering on and off, the only thing left to do was restart my computer. 
Also some other times I would be using red hat and my mouse would be stuck, the 
pointer wouldnt move. I tried different mice and a usb to ps2 converter. 

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.Use Gnome or KDE for less than 10 minutes

Actual Results:  Lockup

Expected Results:  Continued use

Additional info:

Also happened when I used mandrake 9.1. I dont know if I should try the drivers 
on ATI's website becuase they are for XFree 4.2 not what I am using which is 
Comment 1 Mike Chambers 2003-03-31 23:53:41 EST
Would you please attach your XFree config file and log file (in plain text mode)
so that this could be troubleshooted?  Did you do a fresh install or an upgrade
and if an upgrade from what version?
Comment 2 David Balažic 2003-04-01 03:12:58 EST
"keyboard lightere were flickering on and off"
Isn't that a sign of kernel oops ?
Comment 3 Mike A. Harris 2003-04-01 07:03:30 EST
If the keyboard LEDs are flashing, then it sounds like a kernel panic as David
says above, and not an XFree86 problem.
Comment 4 Mike A. Harris 2003-04-01 07:07:35 EST
Also, The "9500" vs. "9500 Pro" is irrelevant.  All Radeon hardware is
configured identically, and the cosmetic name that is displayed in the
config tools is irrelevant.  While it may not be 100% accurate, it is
only _cosmetic_ and does not in any way whatsoever affect the operation
of the hardware.  To illustrate this, you can manually configure your
card and choose "Radeon 7000".  You'll notice that the card still works
identically as it did before, despite being told it is a Radeon 7000.
This is because the driver itself internally detects what the card is
at runtime, regardless of what X has been configured as, and does the
right thing.
Comment 5 Randy Armstrong 2003-04-01 09:13:18 EST
The situation has gotten worse. I went into linux to try to get those files for 
you but as soon as I get in my mouse is not working, again I tried different 
mice. Since I am very new to linux I dont know how to get the files without a 
mouse, is there a way in windows I could get them? 

also as an update: the mandrake people told me to try to disable 2d and 3d 
acceleration but that didnt work either.
Comment 6 Randy Armstrong 2003-04-01 11:43:17 EST
To add to what you are saying, I did a clean install and I had the keyboard 
flickering problem in mandrake 9.1. I hope that helps cause red hat 9 rocks and 
I would love to start using it crash free. Thanks again boys
Comment 7 Randy Armstrong 2003-04-02 17:52:41 EST
Sorry I am new to bugzilla, am I supposed to be updating you guys or should I 
just wait? 


Comment 8 Randy Armstrong 2003-04-02 21:56:57 EST
Created attachment 90855 [details]
Comment 9 Randy Armstrong 2003-04-02 21:57:28 EST
Created attachment 90856 [details]
Comment 10 Randy Armstrong 2003-04-02 21:58:54 EST
Created attachment 90857 [details]
Comment 11 Mike Chambers 2003-04-07 12:58:31 EDT
Any word on this bug?  Person reported it, asked me to find out or get a status.
Comment 12 Arjan van de Ven 2003-04-07 13:09:44 EDT
I've not seen any kernel oops text yet....
Comment 13 Bugzilla owner 2004-09-30 11:40:43 EDT
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/

Note You need to log in before you can comment on or make changes to this bug.